Author Topic: How to disable Auto focus (or follow mouse) (Solved)  (Read 1045 times)

Offline fero

  • Newly Subscribed
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
How to disable Auto focus (or follow mouse) (Solved)
« on: September 20, 2016, 07:34:08 am »
Hi, while working i dont know which keys i had pressed , suddenly the screen went to mouse focus mode, how to disable it , i didnt find the solution anywhere. The screen becomes zoomed and following by mouse. please help  :(  :(



system info

Code: [Select]
System:    Host: fenix-ASPIRE-E1-531 Kernel: 4.4.0-24-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Seven
Machine:   System: ACER product: ASPIRE E1-531 v: V2.17
           Mobo: ACER model: EA50_HC_CR v: Type2 - Board Version
           Bios: Insyde v: V2.17 date: 07/02/2013
CPU:       Dual core Intel Core i3-2348M (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 2300 MHz 1: 1293 MHz 2: 1238 MHz 3: 1357 MHz
           4: 1299 MHz
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           Card-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M]
           Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1366x768@60.01hz
           GLX Renderer: Mesa DRI Intel Sandybridge Mobile
           GLX Version: 3.0 Mesa 11.2.0
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-24-generic
Network:   Card-1: Broadcom NetLink BCM57785 Gigabit Ethernet PCIe driver: tg3
           IF: enp2s0f0 state: down mac: <filter>
           Card-2: Qualcomm Atheros AR9462 Wireless Network Adapter
           driver: ath9k
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (8.3% used)
           ID-1: /dev/sda model: WDC_WD5000LPVT size: 500.1GB
Partition: ID-1: / size: 48G used: 36G (79%) fs: ext4 dev: /dev/sda9
           ID-2: swap-1 size: 4.10GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 64.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 218 Uptime: 11 min Memory: 2330.0/7801.4MB
           Client: Shell (bash) inxi: 2.2.35

« Last Edit: September 29, 2016, 06:50:01 am by fero »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
How to disable Auto focus (or follow mouse)
« Reply #1 on: September 20, 2016, 07:34:08 am »
To help us help you, ALL new requests for technical support should include basic system information.

If you haven't already done so, please open a terminal (Ctrl+Alt+T) and run the following command:
Code: [Select]
inxi -Fzthen copy what was returned in the terminal and post it back here.

This was an automated response but please don't ignore it, providing this information now is highly likely to save time for both you and any prospective respondents and aid in the diagnosis of your problem  .. Thanks in advance :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: How to disable Auto focus (or follow mouse)
« Reply #2 on: September 20, 2016, 07:53:12 am »
Can you explain "mouse focus mode" ? .. eg. what happens, and where ?

[EDIT]

Is this what you mean...

Go to
menu > Preferences > Peppermint Control Center > Window Manager (tab)

then under "Focus model", choose "Click to focus"
« Last Edit: September 20, 2016, 07:57:46 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline fero

  • Newly Subscribed
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: How to disable Auto focus (or follow mouse) (SOLVED)
« Reply #3 on: September 29, 2016, 06:48:00 am »
hi , its resolved. The focus mode (zoom mode) is enabled by clicking  Alt + scroll up keys :D , i accidentally clicked again then got to know how it happened. Thank you all

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: How to disable Auto focus (or follow mouse) (Solved)
« Reply #4 on: September 30, 2016, 04:13:26 pm »
Ah right, now I get what you meant (desktop zoom, or zoom and pan .. or whatever it's called) .. glad you figured it out, saves me making a fool of myself totally misunderstanding what you were trying to explain because I'd forgot that even existed  :-[
« Last Edit: September 30, 2016, 04:17:43 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kataclysm

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Re: How to disable Auto focus (or follow mouse) (Solved)
« Reply #5 on: June 21, 2017, 09:52:49 am »
Is there a way to toggle this switch in the terminal?

I, too, have accidentally activated it on several occasions and it is too disorienting to go that many menus and tabs deep to get to a radio checkbox, so I end up having to reboot.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: How to disable Auto focus (or follow mouse) (Solved)
« Reply #6 on: June 21, 2017, 11:15:02 am »
If you mean the Alt+Scroll-UP zoom mode, not that I know of .. but just hitting Alt+Scroll-DOWN will return you to normal.



If you mean the mouse "click to focus"

Click to focus ON (default):
Code: [Select]
xfconf-query -c xfwm4 -p /general/click_to_focus -s trueClick to focus OFF (focus follows mouse):
Code: [Select]
xfconf-query -c xfwm4 -p /general/click_to_focus -s false
« Last Edit: June 21, 2017, 11:20:42 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec