Choose style:

Author Topic: Excessive cpu usage. (SOLVED)  (Read 2243 times)

0 Members and 1 Guest are viewing this topic.

Offline Jono

  • Jr. Member
  • **
  • Posts: 38
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 4+5
Excessive cpu usage. (SOLVED)
« on: June 22, 2014, 09:01:23 am »
The mintinstall search facility freezes on typing the first letter in the box and the cpu usage in task manager jumps to >50%. I try to close it, get the not responding notice, then close it. The cpu remains unhappy and the only solution is to log out. This happens on both our machines and is not a great handicap because of synaptic etc, but something is obviously wrong.

Perhaps related is that there are also some (entirely respectable) websites that cause cpu usage to jump to 80-90% but closing them drops usage back to normal. (10-20%). Interestingly, while the aggregate usage shows high, the sum of the individuals is still low, highest being Chromium at about 20%. Is this something I have to live with or is there a fix? Normal cpu and mobo temps are  45- 55C but jump to 70 or so, which seems on the high side. What is going on, please?
« Last Edit: June 22, 2014, 03:54:16 pm by Jono »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Excessive cpu usage.
« Reply #1 on: June 22, 2014, 10:17:16 am »
2 things here

a) Software Manager - This is fixed in Peppermint 5 which is due out tomorrow.

b) Sites with Flash .. flashplayer is extremely CPU intensive.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Jono

  • Jr. Member
  • **
  • Posts: 38
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 4+5
Re: Excessive cpu usage.
« Reply #2 on: June 22, 2014, 11:35:58 am »
Thanks for the info. I searched quite a lot (though maybe not enough) and couldn't find many references to mintinstall behaving  exactly as described, so it's a relief that it was a bug now fixed. I take the flash player point but 50% or so is more usual on that sort of site so I was a bit surprised to see 90%. Cpu is a Core 2 duo 1.4 GHz extra low voltage so quite slow but not greatly so. Will the issue get worse as machines get faster? The site in question was largely text with a superfluous animated window which makes me wonder what was the point.
Greatly looking forward to P5, and thanks again.

Ps it wasn't flash- still happening with flash disabled but no worries.

 
« Last Edit: June 22, 2014, 03:53:11 pm by Jono »