Author Topic: Grub install failed  (Read 5674 times)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Grub install failed
« Reply #15 on: June 08, 2017, 12:34:30 pm »
okay you seem to have 2 Linux partitions:-

Code: [Select]
/dev/sda8  569696256 953544703 383848448   183G Linux filesystem
and
/dev/sda10 334936064 569696255 234760192   112G Linux filesystem

do you know what these are ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #16 on: June 08, 2017, 12:43:00 pm »
Both were attempts to install Peppermint 8

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Grub install failed
« Reply #17 on: June 08, 2017, 02:09:18 pm »
Hi jlanep30, for future reference, could you please remember to encapsulate terminal outputs with the Insert, Code # function.  For extra long outputs, please use the Spoiler, Sp function.  If you’re a Chromium Browser and/or a Google Chrome user, please don't combine these functions.  For some reason they don’t work well together with these browsers.  Only use one or the other  ;).  These forum functions preserve the original format of the output.  This makes it easier for future visitors to relate to their own issues.  These functions are found in the forum editor, above the,  :-[ Embarrassed and  the :'( Cry emoticon respectively.  Use the Preview button to check how it'll look in the forum.  This time, I've done it for you - many thanks  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #18 on: June 08, 2017, 02:51:58 pm »
 Sorry about that!  I'm new to linux! I think I know what you are talking about and fixing to play around with it.

« Last Edit: June 08, 2017, 03:42:44 pm by AndyInMokum »

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Grub install failed
« Reply #19 on: June 08, 2017, 03:43:21 pm »
Sorry about that!  I'm new to linux! I think I know what you are talking about and fixing to play around with it.

No problem, you're not expect to know everything right away  :).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Grub install failed
« Reply #20 on: June 08, 2017, 04:12:42 pm »
Both were attempts to install Peppermint 8

Okay if they're both Peppermint, we can attempt to fix one of those, or we can remove them both and start again ?

I think we should do both .. see if we can fix one of those, and if it works delete them both and start again .. sound like a plan ?



If so .. Boot to the LiveUSB (and make sure you have an active internet connection) and run these commands in sequence:
Code: [Select]
sudo mount /dev/sda8 /mntthen
Code: [Select]
sudo mount /dev/sda1 /mnt/boot/efithen
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; donethen
Code: [Select]
sudo chroot /mntthen
Code: [Select]
grub-install /dev/sda --target=x86_64-efithen
Code: [Select]
update-grubthen hit Ctrl+D to exit the chroot environment. (the prompt should change back to $)

Close the terminal and shut down the PC

Remove the LiveUSB

Turn ON the PC

Were you offered both Peppermint or Windows ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #21 on: June 08, 2017, 05:37:03 pm »
If I boot live USB My wifi doesn't work and my computer doesn't have a Ethernet port...

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #22 on: June 08, 2017, 07:10:10 pm »
broadcom bcm43142 Network unclaimed:

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Grub install failed
« Reply #23 on: June 09, 2017, 05:57:02 am »
Okay try it without the internet connection .. and if you get any errors, please report them here.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #24 on: June 09, 2017, 01:57:24 pm »
Code: [Select]
peppermint@peppermint ~ $ sudo mount /dev/sda8 /mnt
peppermint@peppermint ~ $ sudo mount /dev/sda1 /mnt/boot/efi
peppermint@peppermint ~ $ for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
peppermint@peppermint ~ $ sudo chroot /mnt
root@peppermint / # grub-install /dev/sda --target=x86_64-efi
grub-install: error: /usr/lib/grub/x86_64-efi/modinfo.sh doesn't exist. Please specify --target or --directory.
root@peppermint / #
root@peppermint / # grub-install /dev/sda --target=x86_64-efi
grub-install: error: /usr/lib/grub/x86_64-efi/modinfo.sh doesn't exist. Please specify --target or --directory.
root@peppermint / # update-grub
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.8.0-53-generic
Found initrd image: /boot/initrd.img-4.8.0-53-generic
Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
Found Peppermint 8 Eight (8) on /dev/sda10
Adding boot menu entry for EFI firmware configuration
done
root@peppermint / # exit
peppermint@peppermint ~ $


Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #25 on: June 09, 2017, 02:02:11 pm »
Did not give me option to boot from peppermint.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Grub install failed
« Reply #26 on: June 09, 2017, 02:22:30 pm »
Were there any errors during those commands ?

If not, have you checked to see if anything other than Windows is available in the U/EFI boot manager menu ?
(peppermint will be listed as <ubuntu> in the EFI boot manager menu)

From the LiveUSB, what is the output from:#
Code: [Select]
efibootmgr -vnow ?
« Last Edit: June 09, 2017, 02:30:16 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2200
  • Karma: 458
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Grub install failed
« Reply #27 on: June 09, 2017, 04:01:44 pm »
Boot Mode is set to: UEFI with Legacy OPROM; Secure Boot: OFF

The other options I have is:

"Legacy Boot Mode, Secure Boot Off"

"UEFI Boot Mode, Secure Boot On"

Something tells me the boot mode could be the problem. I think one of the other modes might work properly.

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #28 on: June 09, 2017, 09:18:52 pm »
Ok I went through all the boot modes and still no change. 

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #29 on: June 09, 2017, 09:34:22 pm »
Code: [Select]
peppermint@peppermint ~ $ efibootmgr -v
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0002,2001,0000,0001,2002,2003
Boot0000* Hard Drive BBS(HD,,0x500)................-.C.......C.q...............................................A.........................
Boot0001* USB Storage Device BBS(HD,,0x500)............................................................................A...........................
Boot0002* Windows Boot Manager HD(1,GPT,bf8a8512-dbce-49fa-8e3f-333a1966b829,0x800,0xfa000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...H................
Boot0003* USB1-1 (SanDisk Cruzer Glide) PciRoot(0x0)/Pci(0x1d,0x0)/USB(0,0)/USB(1,0)/HD(1,MBR,0x4294967288,0x800,0x773cd00)RC
Boot2001* EFI USB Device RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC
peppermint@peppermint ~ $