Author Topic: Grub install failed  (Read 5637 times)

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Grub install failed
« on: June 05, 2017, 03:36:11 pm »
Having a problem installing Peppermint 8 64 bit on a Dell Inspiron 11 3000 (3148) I get a error message "the grub-efi amd64-signed  package failed to install" I'm trying to run it beside windows 10 an, Also my wifi doesn't work when running Peppermint on USB. Thanks!!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Grub install failed
« Reply #1 on: June 05, 2017, 06:17:19 pm »
have you tried disabling Secureboot in the BIOS ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #2 on: June 05, 2017, 09:16:36 pm »
Boot Mode is set to: UEFI with Legacy OPROM; Secure Boot: OFF

The other options I have is:

"Legacy Boot Mode, Secure Boot Off"

"UEFI Boot Mode, Secure Boot On"


Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3233
  • Karma: 625
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Grub install failed
« Reply #3 on: June 05, 2017, 10:24:54 pm »
Hi JLanep30,

Have you made sure windows "Fast startup" is also turned off.

https://www.howtogeek.com/243901/the-pros-and-cons-of-windows-10s-fast-startup-mode/  <<<  instructions on how to turn off are here, a little further down the article.

Regards Zeb...

« Last Edit: June 06, 2017, 10:35:00 pm by zebedeeboss »
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

P10r x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Grub install failed
« Reply #4 on: June 06, 2017, 04:39:58 am »
After making sure Windows fast boot/startup is disabled (see zebs post above), can you boot to the LiveUSB and post the output from:
Code: [Select]
sudo fdisk -l
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #5 on: June 06, 2017, 07:42:46 pm »
Thanks Guys! I'm out of town till tomorrow and going to try this when I get back....

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #6 on: June 07, 2017, 03:43:46 pm »
I tired to turn fast boot off but does t give me the option to turn on or off..

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #7 on: June 07, 2017, 03:51:08 pm »
I also read where you had to enable hibernation through command prompt which I tried but I get a "unable to perform operation. An unexpected error(0x65b) has occurred: function failed during execution."

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Grub install failed
« Reply #8 on: June 07, 2017, 07:44:42 pm »
can you boot to the LiveUSB and post the output from:
Code: [Select]
sudo fdisk -l
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #9 on: June 07, 2017, 09:42:53 pm »
sudo fdisk -l
[close]
« Last Edit: June 08, 2017, 04:03:31 am by mac »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Grub install failed
« Reply #10 on: June 08, 2017, 07:51:44 am »
Can you boot to the LiveUSB and post the output from:
Code: [Select]
sudo blkidand
Code: [Select]
sudo ls -l /boot/efi/EFIand
Code: [Select]
efibootmgr -v
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #11 on: June 08, 2017, 10:41:01 am »
Code: [Select]
sudo blkid
/dev/sda1: LABEL="ESP" UUID="8E75-1983" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="bf8a8512-dbce-49fa-8e3f-333a1966b829"
/dev/sda10: UUID="3a7a1797-b268-46ae-a552-f923d6658473" TYPE="ext4" PARTUUID="6ca7ec7e-7cd6-4fd5-aa17-cef252facf8d"
/dev/sda2: LABEL="DIAGS" UUID="2AE0-428D" TYPE="vfat" PARTLABEL="Basic data partition" PARTUUID="2af63dca-1da4-4694-882b-a08c54a98487"
/dev/sda4: LABEL="WINRETOOLS" UUID="9080E24680E23300" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="c1cf646f-48b2-4489-9836-db48f841fa90"
/dev/sda5: LABEL="OS" UUID="A640E92040E8F7C7" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="b406be57-d66c-41d8-bcef-8d7f8797cbb9"
/dev/sda6: UUID="CC1AC49B1AC48444" TYPE="ntfs" PARTUUID="4b9d6cb4-7aaa-49d5-b85e-81166354756e"
/dev/sda7: LABEL="PBR Image" UUID="BEE4EDBFE4ED79D3" TYPE="ntfs" PARTLABEL="Microsoft recovery partition" PARTUUID="99ebe311-7ed6-460d-8b37-d248de3b9203"
/dev/sda8: UUID="37a7166f-84b1-4174-bb46-5789f45f0c0b" TYPE="ext4" PARTUUID="280bd5ee-612a-4321-a357-755c84ead70c"
/dev/sdb1: LABEL="PEPPERMINT" UUID="1D0F-0D3F" TYPE="vfat" PARTUUID="000318f8-01"
/dev/loop0: TYPE="squashfs"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="8090f495-85cc-4841-b664-a38b7adcf753"
/dev/sda9: UUID="830380dd-22af-4875-b4bb-d47e4c75c38e" TYPE="swap" PARTUUID="1e248b32-b376-4236-a146-13fb7cbb66e9"
/dev/zram0: UUID="149329a0-ee49-4b54-9724-f96392b3db3f" TYPE="swap"
/dev/zram1: UUID="681a285c-5460-46d8-be01-195c87e81dd8" TYPE="swap"
/dev/zram2: UUID="1dd0618f-7aea-4e24-9119-cd9db858cb5c" TYPE="swap"
/dev/zram3: UUID="e3847659-5e64-40a8-b15b-1b326e3a8d1f" TYPE="swap"

« Last Edit: June 08, 2017, 02:04:17 pm by AndyInMokum »

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #12 on: June 08, 2017, 10:41:37 am »
Code: [Select]
efibootmgr -v
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0002,2001,0001,0000,2002,2003
Boot0000* USB Storage Device BBS(HD,,0x500)............................................................................A...........................
Boot0001* Hard Drive BBS(HD,,0x500)................-.C.......C.q.....................................N.........A.........................
Boot0002* Windows Boot Manager HD(1,GPT,bf8a8512-dbce-49fa-8e3f-333a1966b829,0x800,0xfa000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...H................
Boot0003* USB1-1 (SanDisk Cruzer Glide) PciRoot(0x0)/Pci(0x1d,0x0)/USB(0,0)/USB(0,0)/HD(1,MBR,0x4294967288,0x800,0x773cd00)RC
Boot2001* EFI USB Device RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC

« Last Edit: June 08, 2017, 02:05:39 pm by AndyInMokum »

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #13 on: June 08, 2017, 10:43:24 am »
sudo ls -l /boot/efi/EFI    file did not exist!

Offline jlanep30

  • Newly Subscribed
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: Grub install failed
« Reply #14 on: June 08, 2017, 10:55:08 am »
Code: [Select]
peppermint@peppermint ~ $ sudo ls -l /boot/efi/EFI
ls: cannot access '/boot/efi/EFI': No such file or directory
« Last Edit: June 08, 2017, 02:06:38 pm by AndyInMokum »