Author Topic: Peppermint 8, wrong time with internet server setup  (Read 2651 times)

Offline gychang

  • Member
  • ***
  • Posts: 102
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Peppermint 8, wrong time with internet server setup
« on: June 12, 2017, 02:20:41 pm »
Am using 32bit P8 on my old Dell laptop, no other os, set to America/LosAngeles, with time synchronized to internet server and is always running several hours ahead, any fix for this problem?

Code: [Select]
apaM6~$ inxi -Fz
System:    Host: M6 Kernel: 4.8.0-54-generic i686 (32 bit) Desktop: N/A
           Distro: Peppermint Eight
Machine:   System: Dell product: MM061
           Mobo: Dell model: 0XD720 Bios: Dell v: A04 date: 04/20/2006
CPU:       Dual core Intel T2300 (-MCP-) cache: 2048 KB
           clock speeds: max: 1667 MHz 1: 1667 MHz 2: 1667 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV515/M52 [Mobility Radeon X1300]
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1680x1050@60.11hz
           GLX Renderer: Gallium 0.4 on ATI RV515 GLX Version: 2.1 Mesa 17.0.2
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.8.0-54-generic
Network:   Card: Intel PRO/Wireless 3945ABG [Golan] Network Connection
           driver: iwl3945
           IF: wlp11s0 state: up mac: <filter>
Drives:    HDD Total Size: 60.0GB (21.8% used)
           ID-1: /dev/sda model: KINGSTON_SV300S3 size: 60.0GB
Partition: ID-1: / size: 14G used: 6.0G (47%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 25G used: 2.5G (11%) fs: ext4 dev: /dev/sda5
           ID-3: swap-1 size: 4.19GB used: 0.08GB (2%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 48.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 166 Uptime: 59 min Memory: 609.4/2011.7MB
           Client: Shell (bash) inxi: 2.2.35

thanks

Online murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2199
  • Karma: 458
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: Peppermint 8, wrong time with internet server setup
« Reply #1 on: June 12, 2017, 02:23:26 pm »
What happens if you unsynchronise it and just set it to the right time yourself? Does it stay that way?

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5898
  • Karma: 1160
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Peppermint 8, wrong time with internet server setup
« Reply #2 on: June 12, 2017, 02:53:11 pm »
Are you dual-booting winders, by any chance ?

EDIT

I looked at your previous threads, and you said you're dual-booting '10' for use with Citrix.

If that's the case, check this thread, for the answer:  https://goo.gl/nktTC2   ;)
« Last Edit: June 12, 2017, 02:59:38 pm by VinDSL »

Offline gychang

  • Member
  • ***
  • Posts: 102
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Peppermint 8, wrong time with internet server setup
« Reply #3 on: June 12, 2017, 04:51:37 pm »
Are you dual-booting winders, by any chance ?

EDIT

I looked at your previous threads, and you said you're dual-booting '10' for use with Citrix.

If that's the case, check this thread, for the answer:  https://goo.gl/nktTC2   ;)

this is my old laptop, only have P8 running, no dural booting.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint 8, wrong time with internet server setup
« Reply #4 on: June 12, 2017, 05:28:06 pm »
What is the ACTUAL time ?

and what's the output from:
Code: [Select]
timedatectl
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline gychang

  • Member
  • ***
  • Posts: 102
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Peppermint 8, wrong time with internet server setup
« Reply #5 on: June 13, 2017, 09:43:04 am »
What is the ACTUAL time ?

and what's the output from:
Code: [Select]
timedatectl

Here ..


Code: [Select]
apaM6~$ timedatectl
      Local time: Tue 2017-06-13 09:41:09 PDT
  Universal time: Tue 2017-06-13 16:41:09 UTC
        RTC time: Tue 2017-06-13 16:41:09
       Time zone: America/Los_Angeles (PDT, -0700)
 Network time on: yes
NTP synchronized: yes
 RTC in local TZ: no

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint 8, wrong time with internet server setup
« Reply #6 on: June 13, 2017, 01:42:48 pm »
So what was the ACTUAL time where you are when you ran that.

And what was the clock showing ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline gychang

  • Member
  • ***
  • Posts: 102
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Peppermint 8, wrong time with internet server setup
« Reply #7 on: June 13, 2017, 02:33:40 pm »
So what was the ACTUAL time where you are when you ran that.

And what was the clock showing ?

correct time is local time: 9:41AM

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint 8, wrong time with internet server setup
« Reply #8 on: June 13, 2017, 03:02:57 pm »
And what was che clock showing ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline gychang

  • Member
  • ***
  • Posts: 102
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Peppermint 8, wrong time with internet server setup
« Reply #9 on: June 13, 2017, 03:14:16 pm »
And what was che clock showing ?

clock was showing 4:41PM.

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5898
  • Karma: 1160
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Peppermint 8, wrong time with internet server setup
« Reply #10 on: June 13, 2017, 04:13:43 pm »
From my experience, you need to change the config file, so the real time clock syncs with the local timezone, not UTC, e.g.

Code: [Select]
RTC in local TZ: yes
« Last Edit: June 13, 2017, 04:31:29 pm by VinDSL »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Peppermint 8, wrong time with internet server setup
« Reply #11 on: June 13, 2017, 06:54:57 pm »
I changed it to that with
Code: [Select]
timedatectl set-local-rtc 1and It had a good old moan at me:-

Quote
Warning: The system is configured to read the RTC time in the local time zone.
         This mode can not be fully supported. It will create various problems
         with time zone changes and daylight saving time adjustments. The RTC
         time is never updated, it relies on external facilities to maintain it.
         If at all possible, use RTC in UTC by calling
         'timedatectl set-local-rtc 0'.

So I changed it back with:
Code: [Select]
timedatectl set-local-rtc 0


What happens if you just right-click the clock, select "Properties", then in the "Timezone:" box enter
America/Los_Angeles
is the clock right or wrong now ?

If there's already something in that box .. try removing it (ie leave it blank).
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5898
  • Karma: 1160
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Peppermint 8, wrong time with internet server setup
« Reply #12 on: June 13, 2017, 07:45:32 pm »
I changed it to that with
Code: [Select]
timedatectl set-local-rtc 1

Yeah, that's what I start with, then ...
Code: [Select]
timedatectl set-ntp true
Here's the result:
Code: [Select]
timedatectl status         
      Local time: Tue 2017-06-13 19:42:23 MST
  Universal time: Wed 2017-06-14 02:42:23 UTC
        RTC time: Tue 2017-06-13 19:42:23
       Time zone: America/Phoenix (MST, -0700)
 Network time on: yes
NTP synchronized: yes
 RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
         This mode can not be fully supported. It will create various problems
         with time zone changes and daylight saving time adjustments. The RTC
         time is never updated, it relies on external facilities to maintain it.
         If at all possible, use RTC in UTC by calling
         'timedatectl set-local-rtc 0'.

I've never had a prob with it, despite the nag.  8)


EDIT


Just thinking - I haxor this file, too ...

Code: [Select]
cat /etc/default/rcS
#
# /etc/default/rcS
#
# Default settings for the scripts in /etc/rcS.d/
#
# For information about these variables see the rcS(5) manual page.
#
# This file belongs to the "initscripts" package.

# okay mofo, take this !
UTC=no

# delete files in /tmp during boot older than x days.
# '0' means always, -1 or 'infinite' disables the feature
#TMPTIME=0

# spawn sulogin during boot, continue normal boot if not used in 30 seconds
#SULOGIN=no

# do not allow users to log in until the boot has completed
#DELAYLOGIN=no

# be more verbose during the boot process
#VERBOSE=no

# automatically repair filesystems with inconsistencies during boot
#FSCKFIX=no
« Last Edit: June 13, 2017, 07:52:12 pm by VinDSL »

Offline gychang

  • Member
  • ***
  • Posts: 102
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Peppermint 8, wrong time with internet server setup (SOLVED)
« Reply #13 on: June 14, 2017, 07:49:07 am »
it must be a bug, I solved the issue by getting into properties and changing the time to manual, rather than synchronizing to a server.

thanks for input from everyone.