Choose style:

Author Topic: Peppermint THINKS it's sending audio to Bluetooth headphones, but no sound.  (Read 1573 times)

0 Members and 1 Guest are viewing this topic.

Offline kataclysm

  • nOOb
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
I installed Peppermint Eight yesterday because, of all the live versions I tested, it performed the best with Bluetooth connectivity to my headphones.

Yesterday, I successfully paired, connected, and custom-named my headphones on Peppermint and listened to music through the headphones with high-fidelity sound. The sound was flawless. This happened both on the LiveCD version and after installing permanently.

Today my headphones will connect readily using the included Blueman Manager 2.0.4, and will even connect in High-Fidelity (A2DP Sink) mode by default. Through the headphones themselves, I hear the acknowledgement of the connection. But when I play audio, I hear nothing through the headphones.

Using VLC, I begin playing a song, and VLC reports that it is putting sound out to Audio Device>Red Headphones (which is the custom name I gave the headphones). The Audio Mixer shows the Red Headphones to be at 100% volume. VLC's volume is at 108%. If I switch VLC's Audio Device to "Built In Analog Stereo" instead of the headphones, music immediately starts playing through the laptop speakers.

To fix, I have tried running
Code: [Select]
pulseaudio -k
, but with no effect. (Other than having to reconnect the headphones, that is.)

What I have:
Asus UX305
Audio info from inxi:
Card-1 Intel Wildcat Point-LP High Definition Audio Controller
           driver: snd_hda_intel
Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic

OS: Peppermint 8
Kernel: 4.8.0-53-generic (64-bit)

How do I restore the audio from those halcyon times of 28 hours ago?

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1989
  • Karma: 341
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Try running alsamixer in a terminal. Press F6 and use the arrow keys to select your sound device. Make sure the levels haven't been turned down or muted. You can use the arrow keys to turn levels up, and M to mute/unmute levels.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26045
  • Karma: 2839
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Have you got the correct output device selected in PulseAudio Volume Control ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kataclysm

  • nOOb
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Okay, here goes:

Try running alsamixer in a terminal. Press F6 and use the arrow keys to select your sound device. Make sure the levels haven't been turned down or muted. You can use the arrow keys to turn levels up, and M to mute/unmute levels.

Ran Alsamixer.
Pressed F6. Choices:
- default
0 HDA Intel HDMI
1 HDA Intel PHC

If I choose "0, HDA Intel HDMI" there are 3 bars on the screen all set to 0 and not adjustable with the arrow keys. They don't seem interactable with any keyboard keys.

If I choose "1, HDA Intel PHC" there are 11 bars to arrow through. These were already set pretty high. I increased all of them to max except the "Mic Boo[st]" and "Beep." I also disabled Auto-Mute.

None of these things affected the stream of music that I had playing at the time.

Have you got the correct output device selected in PulseAudio Volume Control ?

So I am assuming you are referring to pavumixer, the one that comes up when you left-click the volume icon in the panel and select "Audio Mixer..."?

There are two tabs in pavumixer that seem relevant.
Playback tab: there is a line called "System Sounds" that is set to 103% volume and has no selectable output.

Below this is a line called VLC media player (LibVLC 2.2.2): audio stream on. This has a drop-down-ish rectangle next to it. Currently it is set to Red Headphones. If I switch it to Built-in Audio Analog Stereo, I hear music from the laptop speakers. If I set it to Built-in Digital Stereo (HDMI), there is no sound.

In the Output Devices tab:
The three choices (built-in, built-in, Red Headphones) also appear here on three separate lines. They all have drop-downs with only one choice (except Built-in Audio Analog Stereo, which lets you select a pair of wired headphones). It is very subtle, but there are three small checkboxes, one on the right side of each line, and next to Red Headphones the color is a slightly darker gray than the other two, so yes, I assume the correct audio device is selected. I select either of the other devices while music is playing but to no effect. So I am leaving it on "Red Headphones."

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1989
  • Karma: 341
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Check the Configuration tab. You might have to set other devices to "Off" if they're somehow interfering.

Offline kataclysm

  • nOOb
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
Check the Configuration tab. You might have to set other devices to "Off" if they're somehow interfering.

Checking now...

Okay, I set the Built-in Audio and Built-in Audio profiles to "Off" but no sound started coming out.

Interestingly, though, when I change the Red Headphones profile from High Fidelity Playback (A2DP Sink) to Headset Head Unit (HSP/HFP), I do hear music. Poor quality music, but it's something.

Now the Bluetooth Device manager is set to "Audio Profile: Headset Head Unit (HSP/HFP)" and when I try to change to A2DP Sink, I get the message "Failed to change profile to a2dp_sink" and I stop hearing any sound.

I can go back in to the Bluetooth Device manager and select Audio Sink from the choices at the top of the drop-down menu (Headset/Handsfree/Audio Sink) and the headphones disconnect, then reconnect by themselves, this time with High Fidelity Playback (A2DP Sink) automatically selected under "Profile." At that point I begin hearing high-quality music.

So that's very good.

Is there are script I can write that will go through that sequence every time? I'd be willing to run it manually every time I connected the headphones...
« Last Edit: June 09, 2017, 10:43:17 am by kataclysm »

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1989
  • Karma: 341
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
I don't know since I've never used Bluetooth. It sounds like a lot of hassle  :o

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26045
  • Karma: 2839
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
« Last Edit: June 09, 2017, 12:46:20 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kataclysm

  • nOOb
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 8
...maybe there'll be something here:
https://bugs.launchpad.net/ubuntu/+source/indicator-sound/+bug/1577197

Yep. It appears to be a bug in Pulseaudio. People have been confirming the same behavior over the course of the past year, with the most recent complaint from a couple of weeks ago. The posted workaround lists the same sequence of events I had to use to get the headphones to reconnect:

Quote
I have the same issue since upgrading to (Kubuntu) 16.04 with bluetooth audio not working to the A2DP device. However I found a temporary workaround - after it connects the audio player stops completely in its tracks, but if I change the audio configuration on the bluetooth audio device from A2DP to HSP/HFP audio starts working at low fidelity and if I then switch it back to A2DP the audio now works at high fidelity.

At least two people have written scripts to automate the process of going into the Configuration tab, switching to HSP, then switching to A2DP through the device manager. So I can either try to use theirs (one is Python and one is Perl) or make my own little Bash script to do it. That is until the PulseAudio bug itself is fixed...

Thanks.