Author Topic: MEGASync installation failed due to dependency  (Read 1956 times)

Offline josephgodwinke

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • Web Security is an illusion
    • View Profile
  • Peppermint version(s): 7 Respin x64
MEGASync installation failed due to dependency
« on: April 26, 2017, 12:18:48 am »
I am trying to install MEGASync Client -> megasync-Debian_7.0_amd64.deb but returns Dependency is not satisfiable: libcrypto++9 in terminal. I tried installing libcrypto++9 but it says it was replaced by libcrypto++9v5:i386 and libcrypto++9v5. So I installed 9v5 for amd64. I confirmed it was installed
Code: [Select]
apt-cache policy  libcrypto++9v5 it return its installed. Tried updating but no luck yet - cannot install.
Design, Development, Exploitation!

Offline VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5822
  • Karma: 1122
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: MEGASync installation failed due to dependency
« Reply #1 on: April 26, 2017, 03:26:52 am »
Welcome aboard, josephgodwinke !

Generally speaking, when I run across situations like that, I simply haxor the .deb file, remove the dependency  from the control file, and repackage it. 

I need to run.  If you're not comfortable doing the above, I'm sure someone else will provide a more conventional solution.

Have fun !   :)

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3233
  • Karma: 625
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: MEGASync installation failed due to dependency
« Reply #2 on: April 26, 2017, 04:02:48 am »
Hi josephgodwinke,

Welcome to the forums.

It would be better if you downloaded the Ubuntu .deb file for 16.04. You can get the 64bit version here
https://mega.nz/linux/MEGAsync/xUbuntu_16.04/amd64/megasync-xUbuntu_16.04_amd64.deb

or the 32bit version here
https://mega.nz/linux/MEGAsync/xUbuntu_16.04/i386/megasync-xUbuntu_16.04_i386.deb

Hope this helps

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

P10r x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: MEGASync installation failed due to dependency
« Reply #3 on: April 26, 2017, 04:03:52 am »
Hi josephgodwinke, welcome to the Peppermint Forum  ;).  You're using the wrong .deb file.  You need to use the one for Ubuntu 16.04 not Debian 7.  Make sure you download the correct version for your machine, 32-bit or 64-bit.  If it still gives you problems. let us know and well show you how to install it from the command line.  I hope this helps - good luck  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline josephgodwinke

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • Web Security is an illusion
    • View Profile
  • Peppermint version(s): 7 Respin x64
Re: MEGASync installation failed due to dependency
« Reply #4 on: April 26, 2017, 04:28:11 am »
Hi josephgodwinke,

Welcome to the forums.

It would be better if you downloaded the Ubuntu .deb file for 16.04. You can get the 64bit version here
https://mega.nz/linux/MEGAsync/xUbuntu_16.04/amd64/megasync-xUbuntu_16.04_amd64.deb

or the 32bit version here
https://mega.nz/linux/MEGAsync/xUbuntu_16.04/i386/megasync-xUbuntu_16.04_i386.deb

Hope this helps

Regards Zeb...

This worked! Actually All the answering posts before this one are correct @AndyInMokum

I guess i am mistaking peppermint for debian instead this is actually a fork of ubuntu. I am newbie Peppermint os user but I have used other linux distributions for 5 years now!
Design, Development, Exploitation!