Choose style:

Author Topic: XFCE Menu Lag, Fluxbox, Enlightenmeint  (Read 638 times)

0 Members and 1 Guest are viewing this topic.

Offline uberzilla

  • nOOb
  • *
  • Posts: 4
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
XFCE Menu Lag, Fluxbox, Enlightenmeint
« on: April 24, 2017, 02:10:41 pm »
Hello, I am an off and on user of Peppermint - one of those distro hoppers constantly looking to see what everyone is doing.

I have liked peppermint and have been testing windows managers. I have liked Enlightenment from using Bodhi, and have loaded it in Mageia 5 along with Fluxbox. I stumbled accross Fluxbox when I tried AntiX (which is now one of my go to distros).

One of the reasons for checking in to this forum is that I stumbled across an old forum post when googling to see if anyone has tried installing a windows manager in Peppermint. The thread regarded the XFCE menu and a lag when the system was started - the first time you activate the menu. The thread author stated he would see a 5 second lag on first usage. I noticed this too when using Peppermint - but also in Mint running XFCE. In all other distros I have tested in XFCE the menu has no lag on first activation. Has anyone else noticed this? Does anyone know the reason for this?

The second reason for checking into this forum is to see if anyone has tried installing Enlightenment or Fluxbox in Peppermint. I just like these two windows managers and the light ram usage.
« Last Edit: April 25, 2017, 06:22:14 am by PCNetSpec »

Offline scifidude79

  • Global Moderator
  • Hero
  • *****
  • Posts: 4029
  • Karma: 863
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: XFCE Menu Lag, Fluxbox, Enlightenmeint
« Reply #1 on: April 24, 2017, 02:19:49 pm »
I can confirm the menu lag on the Whisker Menu.  It lags for a second or two after I first boot up, but it's fine after that.
« Last Edit: April 25, 2017, 06:22:35 am by PCNetSpec »

Offline mac

  • Global Moderator
  • Veteran
  • *****
  • Posts: 1088
  • Karma: 336
    • View Profile
  • Peppermint version(s): Peppermint 7-8-9
Re: XFCE Menu Lag, Fluxbox, Enlightenmeint
« Reply #2 on: April 24, 2017, 03:38:47 pm »
Welcome to the forum, uberzilla.  You can install fluxbox via CLI.  In your terminal run
Code: [Select]
sudo apt install fluxbox
  You can then choose fluxbox or peppermint from the login screen (system tool icon upper right).  Like you, I used fluxbox in antiX a while back but have not used it in Pepperment (except to test it a bit) because Pepperment runs light & fast as is.  But, to each his / her own. Enjoy!    ;)

No problems with Whisker menu, here.

cheers
« Last Edit: April 25, 2017, 06:23:01 am by PCNetSpec »
Peppermint: Standing Out from the Cloud
Reg. Linux User #432835

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1727
  • Karma: 464
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 9 - 64bit
Re: XFCE Menu Lag, Fluxbox, Enlightenmeint
« Reply #3 on: April 25, 2017, 05:52:32 am »
Hi überzilla,


If you use the forum's search function and enter the search terms install fluxbox you will find a tutorial that I wrote concerning its installation and setup together with some example configuration files (to download) that are filled with comments explaining much of what the configuration options actually mean. To save you the effort, here is a link to my tutorial8)


If you have any questions about it, or fluxbox in general, please ask them in that tutorial thread to prevent having the fluxbox info scattered around the forum.  ;)


Regards,


-- Slim

« Last Edit: April 25, 2017, 06:23:21 am by PCNetSpec »
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25312
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: XFCE Menu Lag, Fluxbox, Enlightenmeint
« Reply #4 on: April 25, 2017, 06:31:52 am »
Okay, tested on 4 separate computers...

Reboot .. and as soon as desktop is reached, I hit the menu button .. the whiskermenu opens with ZERO lag :-\
(only tested the 64bit version thus far though)

We do have a slightly different menu structure to the standard Xfce one (and I **think** so do Mint), but I wouldn't expect that to cause a lag and if it did I'd expect it to be on every use.

Is this menu lag only at first BOOT, or first LOGIN ?
(ie. Does logging off/on cause the menu to lag on first use .. or does iit require a reboot before lag is seen on first menu use ?)

Can I have a screenshot of your menu when it first opens (ie. no submenu, just what it looks like when you click the menu button) .. host the image on:
https://imgur.com
then post a link here please.
« Last Edit: April 25, 2017, 06:38:39 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline scifidude79

  • Global Moderator
  • Hero
  • *****
  • Posts: 4029
  • Karma: 863
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: XFCE Menu Lag, Fluxbox, Enlightenmeint
« Reply #5 on: April 25, 2017, 11:20:13 am »
It's not even what I'd  call a lag, at least not on my desktop.  There's a half second to a second delay when I hit the menu button after first booting up the system.  Afterwards, it's fine, it pops up instantly.  On less powerful computers, such as my laptop, it's more noticeable.