Choose style:

Author Topic: (Solved) Dmenu set in xbindkeys.conf dmenu and whisker menu both pop-up.  (Read 1112 times)

0 Members and 1 Guest are viewing this topic.

Offline globetrotterdk

  • Jr. Member
  • **
  • Posts: 58
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint OS 7 64-bit
The subject says it all. I don't see any other Mod4+d keybinding other than the one I set for Dmenu, yet Whisker Menu insists on popping-up.
« Last Edit: April 19, 2017, 01:31:44 am by globetrotterdk »

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2002
  • Karma: 344
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Isn't that because you have to press the menu key so the menu pops up?

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1815
  • Karma: 474
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
The subject says it all. I don't see any other Mod4+d keybinding other than the one I set for Dmenu, yet Whisker Menu insists on popping-up.

Hi globetrotterdk,

How and where did you perform this "setting"? Could you post the output of the configuration file for us to see?

Regards,

-- Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline globetrotterdk

  • Jr. Member
  • **
  • Posts: 58
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint OS 7 64-bit
Hi Slim.
I actually used the keyboard shortcut tab of the Peppermint Control Center, but PCC modifies the xbindkeys.conf file in .config/peppermint-control-center. Here is the output of the file:
Code: [Select]
"dmenu_run -fn '40x50' -i -nb '#000000' -nf '#FFFFFF' -sb '#8DC7E0' -sf '#000000'"
    Mod4+d

"x-terminal-emulator"
    Control+Alt+t

"nemo"
    Mod4+e

"nemo"
    Control+Alt+f

"xfrun4"
    Mod4+r

"xfrun4"
    Alt+F2

"xfce4-popup-whiskermenu"
    Alt+F1

"xfce4-popup-whiskermenu"
    Control+Escape

"xfce4-popup-whiskermenu"
    Super_L

"peppermint-logout"
    Control+Alt+Delete

"scrot 'Screenshot_%Y-%m-%d_%H:%M:%S.png' -e 'mv $f ~/Desktop/'"
    Print

"scrot -u -b 'Windowshot_%Y-%m-%d_%H:%M:%S.png' -e 'mv $f ~/Desktop/'"
    Control+Print

"peppermint-scrot-helper.sh"
    Control+Shift+Print

"lxlock"
    Control+Alt+l

"amixer -q sset Master 3%+ unmute"
    XF86AudioRaiseVolume

"amixer -q sset Master 3%- unmute"
    XF86AudioLowerVolume

"amixer -q sset Master toggle"
    XF86AudioMute

"galculator"
    XF86Calculator

"nemo"
    XF86MyComputer

"sleep 2;xset dpms force off"
    Control+Shift+F7

"peppermint-logout"
    XF86PowerOff

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26325
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
This is the entry that's opening the whiskermenu with the "Win" key.
Code: [Select]
"xfce4-popup-whiskermenu"
    Super_L
Super_L and Mod4 are the same thing.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline globetrotterdk

  • Jr. Member
  • **
  • Posts: 58
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint OS 7 64-bit
Thanks. I was unaware of that.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26325
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
If this is now (SOLVED), can you please remember to mark it so ;)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec