Choose style:

Author Topic: ap-hotspot not working, worked in P4  (Read 5251 times)

0 Members and 1 Guest are viewing this topic.

Offline nberidze

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
ap-hotspot not working, worked in P4
« on: June 26, 2014, 12:22:59 pm »
My laptop is connected to the Internet by cable. With Peppermint 4, I used the ap-hotspot package to share my connection with one other computer, and it worked great out of the box, but after installing Peppermint 5, I can't get it to work. There is no message about hotspot active like it used to be. If I try ap-hotspot restart it tells me "Another process is already running". That's the same message I get when I try ap-hotspot stop. ap-hotspot debug tells me the same error message.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25095
  • Karma: 2778
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: ap-hotspot not working, worked in P4
« Reply #1 on: June 26, 2014, 01:58:32 pm »
Try terminating it with:
Code: [Select]
sudo killall ap-hotspot
then restarting it:
Code: [Select]
ap-hotspot
is there any output from the terminal
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline nberidze

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: ap-hotspot not working, worked in P4
« Reply #2 on: June 26, 2014, 02:02:30 pm »
Code: [Select]
aaaa@aaaa-HP-630-Notebook-PC ~ $ sudo killall ap-hotspot
ap-hotspot: no process found
aaaa@aaaa-HP-630-Notebook-PC ~ $ ap-hotspot start
egrep: /proc/3239/environ: No such file or directory
Another process is already running

Offline nberidze

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: ap-hotspot not working, worked in P4
« Reply #3 on: June 26, 2014, 02:09:12 pm »
I also tried these instructions http://forum.xda-developers.com/showthread.php?t=2009381
and got error message about the driver, nl80211. Could it be connected to this: http://osdir.com/ml/ubuntu-bugs/2014-03/msg04880.html

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25095
  • Karma: 2778
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: ap-hotspot not working, worked in P4
« Reply #4 on: June 27, 2014, 10:42:06 am »
You might want to take a look at the provided answer here:
http://askubuntu.com/questions/453877/wifi-hotspot-in-ubuntu-14-04

seems the version of hostapd in 14.04 (which Peppermint 5 is based on) may have some bugs.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline nberidze

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: ap-hotspot not working, worked in P4
« Reply #5 on: June 27, 2014, 04:10:53 pm »
This is a make or break issue for me. If P5 can't make my wireless card's driver work properly, I'm switching to another OS. My pregnant wife depends on this wifi connection. I thought we were past the stage where linux is synonymous with tinkering and unending bug reports, but apparently I was wrong.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25095
  • Karma: 2778
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: ap-hotspot not working, worked in P4
« Reply #6 on: June 27, 2014, 04:43:01 pm »
Try the above link/solution.
« Last Edit: June 27, 2014, 04:44:39 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline kendall

  • Developer
  • Member
  • *****
  • Posts: 535
  • Karma: 75
  • Peppermint Dev
    • View Profile
    • http://kendallweaver.com
Re: ap-hotspot not working, worked in P4
« Reply #7 on: June 28, 2014, 01:18:29 am »
This is a make or break issue for me. If P5 can't make my wireless card's driver work properly, I'm switching to another OS. My pregnant wife depends on this wifi connection. I thought we were past the stage where linux is synonymous with tinkering and unending bug reports, but apparently I was wrong.

And I don't blame you if you do go to another OS. We try to offer a good product for a large number of people, but there are occasionally issues that we either haven't worked through yet, or don't have the resources to work though. No OS can be all things to all people and threatening to leave one for another isn't going to change that. No OS will ever be synonymous with "no tinkering and no bug reports" but it doesn't mean that we won't try, and us trying doesn't mean that we're always going to succeed. One of the many lessons associated with building an OS is learning that no matter what you try, you can't do everything. Peppermint is not the ideal solution to everything and we know this. Your comment about "we" and being "past the stage where Linux is synonymous with tinkering and unending bug reports" is not doing anything to help anyone's situation, specifically your own.

That being said, there may be other solutions to your issue or there may be information that we haven't quite gotten a hold of yet. Regardless of whether you stay with Peppermint or not, we would still like to find a solution to your issue because your issue might affect others. If you do move to another OS and find a workable solution I would greatly appreciate you contributing that information to our community in some capacity. Likewise if we find a solution, we're going to post it regardless of whether or not there are future responses to this topic.

In your personal situation it pays to bear in mind that the majority of the people answering your questions are volunteering their time and experience to try and help you. They're not help desk employees nor do they get a bonus if they clear more of the queue than someone else. They're volunteers. I really hate to say this but a little respect goes a long way. The team we've put together here is actually very good at figuring out problems and very good at sharing when they do. No, we don't figure out everything, but we certainly do try. Please try and keep this in mind in the future.
Co-Founder and CTO of Peppermint. Developer, Photographer, and spicy food lover.

Peppermint is powered by VPS.NET Cloud Servers.

Offline nberidze

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: ap-hotspot not working, worked in P4
« Reply #8 on: June 28, 2014, 05:50:46 am »
Thank you. Yes, the solution worked. I downgraded hostapd as described in the link and put it on hold (no upgrades).

As mentioned previously I am very impressed by the work you have done on Peppermint, and it is the OS that best suits my needs right now, I like it very much. So thank you for your dedication and for following up questions from people like me. All my questions have been answered here. The problem  with the wifi was just that with the current hardware (and moving out in a few months, so not going to buy a separate router) it's best to let my laptop share connection via wifi, and without that working in P5, I would try some other OS, just to have that function, although I would prefer Peppermint. Now that it worked downgrading buggy hostapd, I'll stay with Peppermint, which is the best solution. Have a nice day and thanks again.  :)