Choose style:

Author Topic: "elf magic" grub message (SOLVED)  (Read 1482 times)

0 Members and 1 Guest are viewing this topic.

Offline rickc

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 10
    • View Profile
  • Peppermint version(s): 9
"elf magic" grub message (SOLVED)
« on: April 04, 2017, 07:01:41 am »
When I wiped windows and installed Peppermint to the whole HD, I couldn't boot - I was getting this "elf magic" grub error.   I fixed it with boot-repair.

I did some system updates yesterday and noticed they were grub updates.

Today, I've again had the same "elf magic" error. Again, it was easily fixed with boot-repair.

What is bizarre is that when I've logged in, the original wallpaper has been restored. How did that happen?

Is this something that is likely to happen again when one of the updates includes grub?   I'm tempted not to apply further grub updates, but I guess that then the system update will always show as needing attention...

Why did this happen on my machine on a fresh install?   Never experienced this on other machines (it's a Dell Latitude)

This not an urgent post at all - just curious!

Cheers
Rick  :)
« Last Edit: April 06, 2017, 05:11:06 am by rickc »

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25931
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "elf magic" grub message
« Reply #1 on: April 04, 2017, 08:38:31 am »
Is this a UEFI system ?

Have you disabled securebooot ?

Is "Legacy BIOS" or "CSM" enabled or disabled in the BIOS ?

What's the output from:
Code: [Select]
dpkg -l | grep grub
and
Code: [Select]
sudo fdisk -l
and
Code: [Select]
sudo blkid
and
Code: [Select]
efibootmgr -v
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline rickc

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 10
    • View Profile
  • Peppermint version(s): 9
Re: "elf magic" grub message
« Reply #2 on: April 04, 2017, 02:14:42 pm »
The bios are set to legacy mode. There is no secure boot option

Bit surprised to see an "extended" partition plus swap.  I didn't create them

Code: [Select]
rick@rick-Latitude-E5510 ~ $ dpkg -l | grep grub
ii  grub-common                                   2.02~beta2-36ubuntu3.9                     amd64        GRand Unified Bootloader (common files)
ii  grub-gfxpayload-lists                         0.7                                        amd64        GRUB gfxpayload blacklist
ii  grub-pc                                       2.02~beta2-36ubuntu3.9                     amd64        GRand Unified Bootloader, version 2 (PC/BIOS version)
ii  grub-pc-bin                                   2.02~beta2-36ubuntu3.9                     amd64        GRand Unified Bootloader, version 2 (PC/BIOS binaries)
ii  grub2-common                                  2.02~beta2-36ubuntu3.9                     amd64        GRand Unified Bootloader (common files for version 2)
Code: [Select]
rick@rick-Latitude-E5510 ~ $ sudo fdisk -l
[sudo] password for rick:
Disk /dev/sda: 223.6 GiB, 240057409536 bytes, 468862128 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xdfef03d3

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1  *         2048 452497407 452495360 215.8G 83 Linux
/dev/sda2       452499454 468860927  16361474   7.8G  5 Extended
/dev/sda5       452499456 468860927  16361472   7.8G 82 Linux swap / Solaris

Partition 2 does not start on physical sector boundary.


Code: [Select]
rick@rick-Latitude-E5510 ~ $ sudo blkid
/dev/sda1: UUID="0847fe37-24ab-42d3-ab57-52704385d472" TYPE="ext4" PARTUUID="dfef03d3-01"
/dev/sda5: UUID="dc474fcf-a9c7-420e-a3ae-86f1cd466fdb" TYPE="swap" PARTUUID="dfef03d3-05"
Code: [Select]
rick@rick-Latitude-E5510 ~ $ efibootmgr -v
The program 'efibootmgr' is currently not installed. You can install it by typing:
sudo apt install efibootmgr
Code: [Select]
rick@rick-Latitude-E5510 ~ $ sudo apt install efibootmgr
Code: [Select]
rick@rick-Latitude-E5510 ~ $ efibootmgr -v
efibootmgr: EFI variables are not supported on this system.
Cheers
Rick  :)
« Last Edit: April 04, 2017, 07:51:07 pm by AndyInMokum, Reason: Encapsulating output with [code]. »

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25931
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "elf magic" grub message
« Reply #3 on: April 04, 2017, 04:18:07 pm »
If you look here
http://www.daossoft.com/bios-tips/how-to-disable-secure-boot-in-bios-on-dell.html

does your BIOS screen look similar ?

If so, does "Secureboot" become visible if you disable legacy mode ?



Which OS did this PC come with ?

Did you repartition the drive ? .. including creating a new partition table ?



The thing that's baffling me (if you haven't manually changhttp://www.daossoft.com/bios-tips/how-to-disable-secure-boot-in-bios-on-dell.htmled the partition table) is if your BIOS mentions Legacy boot, that would normally mean UEFI is an option (?) and if it is, you'd normally have a GPT partition table, yet you haven't :-\
« Last Edit: April 04, 2017, 04:20:47 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: "elf magic" grub message
« Reply #4 on: April 04, 2017, 07:52:56 pm »
Hi rickc, How's it going?  For future reference, could you please remember to encapsulate terminal outputs with the Insert, Code # function.  For extra long outputs, please use the Spoiler, Sp function.  Chromium Browser and Google Chrome users, please don't combine the functions.  Only use one or the other  ;).  These preserve the original format of the output.  This makes it easier for future visitors to relate to their own issues.  These functions are found in the forum editor, above the,  :-[ Embarrassed and  the :'( Cry emoticon respectively.  Use the Preview button to see how it'll look in the forum.  This time, I've done it for you - many thanks  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline rickc

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 10
    • View Profile
  • Peppermint version(s): 9
Re: "elf magic" grub message
« Reply #5 on: April 05, 2017, 03:23:49 am »
If you look here
http://www.daossoft.com/bios-tips/how-to-disable-secure-boot-in-bios-on-dell.html

does your BIOS screen look similar ?

If so, does "Secureboot" become visible if you disable legacy mode ?



Which OS did this PC come with ?

Did you repartition the drive ? .. including creating a new partition table ?



The thing that's baffling me (if you haven't manually changhttp://www.daossoft.com/bios-tips/how-to-disable-secure-boot-in-bios-on-dell.htmled the partition table) is if your BIOS mentions Legacy boot, that would normally mean UEFI is an option (?) and if it is, you'd normally have a GPT partition table, yet you haven't :-\


The laptop originally shipped with W7 and was installed on a 340gb HD

I created an 80gb partition for linux, then decided to buy a SSD.   I extended the partition back to w7 only via w7. My local PC shop cloned the w7 os onto the new SSD

There is no option for secure boot, my bios is much simpler than the one you've shown

I was unable to boot into w7 unless I was in legacy mode, ie UEFI wouldn't boot windows

I was unable to dual boot - even with boot-repair it was impossible to boot into linux

I then used the "wipe all" install and was able to boot after using boot repair. I did not create a partition table

Rick

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25931
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "elf magic" grub message
« Reply #6 on: April 05, 2017, 08:05:31 am »
Here's the thing, GRUB is probably getting confused by your BIOS on one hand being UEFI but being configured for legacy mode.

It seems your PC was probably made in the early days when hardware manufacturers were making their hardware ready for Win8 but still installing Win7 and the UEFI standards were not really nailed down yet.

It would be probably be possible to enable UEFI and remove this confusion, but it would require you wipe the drive and start again (including reinstalling Windows).

Do you want to do this ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline rickc

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 10
    • View Profile
  • Peppermint version(s): 9
Re: "elf magic" grub message
« Reply #7 on: April 05, 2017, 08:33:21 am »
Here's the thing, GRUB is probably getting confused by your BIOS on one hand being UEFI but being configured for legacy mode.

It seems your PC was probably made in the early days when hardware manufacturers were making their hardware ready for Win8 but still installing Win7 and the UEFI standards were not really nailed down yet.

It would be probably be possible to enable UEFI and remove this confusion, but it would require you wipe the drive and start again (including reinstalling Windows).

Do you want to do this ?

Yeah, think this was made in early 2012

So long as my trusty usb boot repair will fix the boot following grub updates, I doubt I can be bothered to do more.  Of course, if I  manage to break my os then I would...

What would I need to do? Is it just a case of wiping with gparted, switching to eufi then reinstall peppermint?  Would I need to first install windows?

I am also thinking my local pc shop may have caused this as they installed w7 in legacy mode - when there was no good reason to do so as far as I can see

Cheers

Offline rickc

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 10
    • View Profile
  • Peppermint version(s): 9
Re: "elf magic" grub message
« Reply #8 on: April 05, 2017, 08:36:01 am »
Hi rickc, How's it going?  For future reference, could you please remember to encapsulate terminal outputs with the Insert, Code # function.  For extra long outputs, please use the Spoiler, Sp function.  Chromium Browser and Google Chrome users, please don't combine the functions.  Only use one or the other  ;).  These preserve the original format of the output.  This makes it easier for future visitors to relate to their own issues.  These functions are found in the forum editor, above the,  :-[ Embarrassed and  the :'( Cry emoticon respectively.  Use the Preview button to see how it'll look in the forum.  This time, I've done it for you - many thanks  ;).

Cheers Andy, will do

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25931
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "elf magic" grub message
« Reply #9 on: April 05, 2017, 11:56:27 am »
You'd need to change the HDD to a GPT partition table (which will WIPE THE DRIVE, so don't do it unless this is what you intend) .. then switch the BIOS to UEFI mode .. then look online for instructions for installing Win7 64bit in UEFI mode .. then once Win7 is installed and working  install Peppermint 7 64bit.

Quote
I am also thinking my local pc shop may have caused this as they installed w7 in legacy mode - when there was no good reason to do so as far as I can see

It was standard practice to install Win7 in legacy mode .. UEFI didn't really become "a thing" until Win8.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline rickc

  • Jr. Member
  • **
  • Posts: 55
  • Karma: 10
    • View Profile
  • Peppermint version(s): 9
Re: "elf magic" grub message
« Reply #10 on: April 05, 2017, 03:21:35 pm »
You'd need to change the HDD to a GPT partition table (which will WIPE THE DRIVE, so don't do it unless this is what you intend) .. then switch the BIOS to UEFI mode .. then look online for instructions for installing Win7 64bit in UEFI mode .. then once Win7 is installed and working  install Peppermint 7 64bit.

Quote
I am also thinking my local pc shop may have caused this as they installed w7 in legacy mode - when there was no good reason to do so as far as I can see

It was standard practice to install Win7 in legacy mode .. UEFI didn't really become "a thing" until Win8.

Thanks.   Would I need to install W7 first, or is it ok to go straight to linux  only?


Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25931
  • Karma: 2835
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: "elf magic" grub message
« Reply #11 on: April 05, 2017, 07:24:45 pm »
You **can** Install Linux before Windows, but after installing Windows you **may** find that Windows has become the primary boot option .. you'd need to either

a)boot Linux from the UEFI interface then fix the boot order with efibootmgr
or
b) Use something like EasyBCD to add Linux to the Windows bootloader.

It's generally easier to install Windows first .. but it's not a requirement

In fact if anything UEFI has made it easier to install Windows second, not harder.
« Last Edit: April 05, 2017, 07:26:52 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec