Choose style:

Author Topic: Peppermint 5 won't install?  (Read 12804 times)

0 Members and 1 Guest are viewing this topic.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25455
  • Karma: 2798
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Peppermint 5 won't install?
« Reply #15 on: June 29, 2014, 05:30:57 pm »
You'd need to host the image somewhere like
http://imgur.com
then post the link (surrounded by IMG tags)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ernest

  • nOOb
  • *
  • Posts: 14
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Trying to boot P5
Re: Peppermint 5 won't install?
« Reply #16 on: June 29, 2014, 05:42:25 pm »
Thank you here's the screen




Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25455
  • Karma: 2798
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Peppermint 5 won't install?
« Reply #17 on: June 29, 2014, 06:21:01 pm »
OK, in /etc/modprobe.d/blacklist-firwire.conf there are 2 commented out lines

#blacklist firewire-ohci
#blacklist firewire-sbp2

so try adding BOTH as kernel boot parameters:

firewire-ohci.blacklist=yes firewire-sbp2.blacklist=yes



For reference, here's the whole default blacklist-firewire.conf contents:
Code: [Select]
# Select the legacy firewire stack over the new CONFIG_FIREWIRE one.

blacklist ohci1394
blacklist sbp2
blacklist dv1394
blacklist raw1394
blacklist video1394

#blacklist firewire-ohci
#blacklist firewire-sbp2



I doubt if this'll help as its a debugging parameter which needs the kernel compiling in a specific way .. but can't hurt to try

Try thiis as a kernel boot parameter:

ohci1394_dma=early
« Last Edit: June 29, 2014, 06:31:21 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ernest

  • nOOb
  • *
  • Posts: 14
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Trying to boot P5
Re: Peppermint 5 won't install?
« Reply #18 on: June 29, 2014, 07:19:21 pm »
Sorry I saw that "ohci1394_dma=early" just now, coming back.  Tried every possible combination and found out that only

blacklist=firewire_ohci lets P5 boot until that point on the pic.

"firewire_ohci.blacklist=yes" or blacklist=firewire_ohci + blacklist=firewire_sbp2 lets booting stop earlier and screen remains black.

blacklist=firewire_sbp2 alone would stop booting with lines on the screen, which then starts to colour up with greenish "fog" starting from the bottom.

When trying blacklist=firewire_ohci + nomodeset booting stops at the same line (after "starting configure network device") but with different msg:

"pcmcia_socket pcmcia_socket1: unable to apply power"

Appreciate your help, it is because I KNOW peppermint, that I'd like to install P5

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25455
  • Karma: 2798
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Peppermint 5 won't install?
« Reply #19 on: June 29, 2014, 07:32:01 pm »
Quote
"pcmcia_socket pcmcia_socket1: unable to apply power"

That *may* be useful .. maybe we need to find a way to disable the pcmcia slot if it's not used (or maybe populate it if it's empty)?

This seems like the power to the iEEE1394 and PCMCIA slots are linked somehow .. at this point I'm thinking out loud, but it gives us something to look into.

I'll do some more searching tomorrow .. getting late over here.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ernest

  • nOOb
  • *
  • Posts: 14
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Trying to boot P5
Re: Peppermint 5 won't install?
« Reply #20 on: June 29, 2014, 07:37:27 pm »
Thank you very much indeed, I do not take help like this for granted.

Meanwhile I did try "ohci1394_dma=early" also in combination with blacklist=firewire_ohci, it did not alter anything.

Have a good rest, so long..

Offline yarn

  • nOOb
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 4
Re: Peppermint 5 won't install?
« Reply #21 on: June 30, 2014, 05:05:31 am »
Quote
Try removing "quiet splash" from the kernel boot line and see if the scrolling text gives you a clue to where the boot is stalling.




The DVD drive stops responding at this point.

Offline yarn

  • nOOb
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 4
Re: Peppermint 5 won't install?
« Reply #22 on: July 04, 2014, 05:40:40 am »
Any help?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25455
  • Karma: 2798
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Peppermint 5 won't install?
« Reply #23 on: July 04, 2014, 06:55:53 am »
Try ernests

blacklist=firewire_ohci
and/or
firewire-ohci.blacklist=yes

boot parameter(s) along with removing "quiet splash" and see if it gets any further.

if it does .. post the last message on screen both before and after hitting Esc
« Last Edit: July 04, 2014, 06:57:30 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ernest

  • nOOb
  • *
  • Posts: 14
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Trying to boot P5
Re: Peppermint 5 won't install?
« Reply #24 on: July 04, 2014, 11:37:42 am »
Thank you for trying.

If you look at my postings above you will see, that I already did all that you suggest.

In fact since a couple of years I used "firewire_ohci.blacklist=yes", without that I could not have booted P4.

It is a bug, well known and since years not corrected. If I'm right it came along with a new version of "udev", but the boot parameter provided a work around.

I'm just disappointed that as of Ubuntu 14 the boot parameter is obviously ignored by the new kernel.

Wasn't it one of the great advantages of Ubuntu that it would work "out of the box" without giving trouble unlike some MS products?

Looks to me like a regression.

Friendly greetings..

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25455
  • Karma: 2798
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Peppermint 5 won't install?
« Reply #25 on: July 06, 2014, 04:16:11 pm »
What happens if you replace "quiet splash" with "recovery nomodeset" .. then when at the recovery screen choose to resume booting ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ernest

  • nOOb
  • *
  • Posts: 14
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Trying to boot P5
Re: Peppermint 5 won't install?
« Reply #26 on: July 07, 2014, 05:59:04 pm »
Thank you PCNetSpec, I will try that combination.

Just a little short of time right now, will inform tomorrow.

Friendly greetings..

Offline Ernest

  • nOOb
  • *
  • Posts: 14
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Trying to boot P5
Re: Peppermint 5 won't install?
« Reply #27 on: July 09, 2014, 10:07:17 am »
I tried with "recovery nomodeset", but only to see the same result, firewire_ohci failure.

Now I looked a bit into the "bug-division" and of course found the reason:

BUG #981936, if you look at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/981936 you will see that this bug dates back to 2012.

I remember having used firewire_ohci.blacklist=yes ever since Ubuntu 11, meaning the bug occured even before that.

As the work around by applying the boot parameter doesn't work anymore, I won't be able to use new versions of Linux distros based on Ubuntu.

May be they simply find, that there is not enough Acer TM8200 users out there to bother with a solution.

Sad thing, would have loved to get your new shining P5 to work. Appreciate your efforts in trying to help, because at Ubuntu forum they simply ignored my plea for help.

Offline yarn

  • nOOb
  • *
  • Posts: 20
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 4
Re: Peppermint 5 won't install?
« Reply #28 on: July 10, 2014, 05:38:06 am »
Code: [Select]
line 7: cant open /dev/sr0: No medium found
It keeps repeating this. How to fix?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25455
  • Karma: 2798
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Peppermint 5 won't install?
« Reply #29 on: July 10, 2014, 08:59:21 am »
In the past whenever I've see that from a LiveUSB stick, I've just given it a while and it's continued.

I have no idea why some machines decide they need to look in the CD/DVD drive for so long (?) .. another option is to disconnect the optical drive during installation, then reconnect it afterwards.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec