Choose style:

Author Topic: Slow to reboot after adding cifs mount to fstab  (Read 384 times)

0 Members and 1 Guest are viewing this topic.

Offline rlischer

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Slow to reboot after adding cifs mount to fstab
« on: March 20, 2017, 06:54:51 pm »
I added a mount point for my Airport Time Capsule to fstab and now it takes about a minute to reboot (slow log out, fast coming back up). All drives are SSD and it used to reboot and be back to login within a few seconds.  The mount does work.

//192.168.200.223/Data /home/myusername/TimeCapsuleMount cifs password=somehugepassword,sec=ntlm,uid=myusername 0 0

Thanks!




Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 17391
  • Karma: 2080
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 (64bit)
Re: Slow to reboot after adding cifs mount to fstab
« Reply #1 on: March 20, 2017, 07:16:37 pm »
Am I right in assuming you're connecting wirelessly ?

Can you test with a wired connection and see if the shutdown delay is gone ?

do you know if your "Airport" supports NFS ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline rlischer

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow to reboot after adding cifs mount to fstab
« Reply #2 on: March 20, 2017, 07:19:27 pm »
I am not wireless.  Sorry, I forgot that point.  I'll check on the NSF.

Offline rlischer

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow to reboot after adding cifs mount to fstab
« Reply #3 on: March 20, 2017, 07:24:24 pm »
It does not seem to support NFS.

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 17391
  • Karma: 2080
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 (64bit)
Re: Slow to reboot after adding cifs mount to fstab
« Reply #4 on: March 20, 2017, 07:31:07 pm »
Can you shut down your PC and when the shutdown hangs, hit the "Esc" key .. is there any message onscreen ?

Which line is it hanging on ? (last line)

Also can you tell me a bit about the remote hardware .. so I can try check if it supports NFS.
« Last Edit: March 20, 2017, 07:36:15 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec


Offline rlischer

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow to reboot after adding cifs mount to fstab
« Reply #5 on: March 20, 2017, 07:38:55 pm »
It says "Stopped Network Manager Wait Online".  Hardware is:
http://www.apple.com/shop/product/ME182LL/A/airport-time-capsule-3tb


Offline rlischer

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow to reboot after adding cifs mount to fstab
« Reply #6 on: March 20, 2017, 07:50:11 pm »
It's fixed now.  I did this:

gedit /etc/systemd/system.conf

edit:
DefaultTimeoutStartSec=5s
DefaultTimeoutStopSec=5s

Thanks!


Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 17391
  • Karma: 2080
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 (64bit)
Re: Slow to reboot after adding cifs mount to fstab
« Reply #7 on: March 20, 2017, 07:56:32 pm »
Okay that's one way of doing it :)

I was going to say let's check if the Airport does support NFS (which systemd seems to handle MUCH better than CIFS) .. but feel free to ignore what follows ;)



Can we just test something .. manually unmount the share
Code: [Select]
sudo umount /home/myusername/TimeCapsuleMount
now make sure nfs support is installed
Code: [Select]
sudo apt-get install nfs-common
now let's see if it will mount as an NFS share
Code: [Select]
sudo mount -t nfs -o rsize=8192,wsize=8192,timeo=14,intr 192.168.200.223:/Data /home/myusername/TimeCapsuleMount
Remember to change "myusername" in those commands.

Now check if /home/myusername/TimeCapsuleMount contains anything ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline rlischer

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow to reboot after adding cifs mount to fstab
« Reply #8 on: March 20, 2017, 08:02:53 pm »
It waited a minute and said "mount.nfs: Connection timed out"


Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 17391
  • Karma: 2080
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 (64bit)
Re: Slow to reboot after adding cifs mount to fstab
« Reply #9 on: March 20, 2017, 08:07:07 pm »
Oh well, guess you're right it doesn't support NFS.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec


Offline rlischer

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow to reboot after adding cifs mount to fstab
« Reply #10 on: March 20, 2017, 08:07:38 pm »
Thanks for the help!

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 17391
  • Karma: 2080
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8 (64bit)
Re: Slow to reboot after adding cifs mount to fstab
« Reply #11 on: March 20, 2017, 08:10:08 pm »
No worries .. not that I did much :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline rlischer

  • nOOb
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow to reboot after adding cifs mount to fstab
« Reply #12 on: March 20, 2017, 09:11:06 pm »
Warning to all.  This messed with my settings and I could not get changes to save, like wallpaper, display settings etc...

Code: [Select]
sudo gedit /etc/systemd/system.conf
remove '#' and change timings in the following lines:

Code: [Select]
DefaultTimeoutStartSec=5s
DefaultTimeoutStopSec=5s

Then run:
Code: [Select]
sudo systemctl daemon-reload

It made root the owner of /home/myusername/.config/dconf

I fixed my config permissions this with:
Code: [Select]
sudo chown -R myusername:myusername /home/myusername/.config

« Last Edit: March 22, 2017, 07:27:49 pm by rlischer »