Author Topic: grub-efi-amd64-signed failed to install  (Read 8405 times)

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2199
  • Karma: 458
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: grub-efi-amd64-signed failed to install
« Reply #15 on: March 19, 2017, 03:05:21 pm »
If you've changed anything in the firmware/BIOS/EFI/whatever settings, it should be fine to reinstall now (let the installer wipe everything automatically) and hopefully it'll work. If not, why not make a tiny bit of space and install that GNOME distro alongside, which should give you a GRUB that can boot both?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: grub-efi-amd64-signed failed to install
« Reply #16 on: March 19, 2017, 03:06:47 pm »
For some reason it thinks you have a 32bit UEFI

If you're 100% sure you've run Peppermint 7 64bit on this system before.....


Try this:-

Boot to the LiveUSB (and make sure you have an active internet connection) and run these commands in sequence:
Code: [Select]
sudo mount /dev/mmcblk0p2 /mntthen
Code: [Select]
sudo mount /dev/mmcblk0p1 /mnt/boot/efithen
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; donethen
Code: [Select]
sudo chroot /mntthen
Code: [Select]
grub-install /dev/mmcblk0 --target=x86_64-efithen
Code: [Select]
update-grubthen hit Ctrl+D to exit the chroot environment. (the prompt should change back to $)

Close the terminal and shut down the PC

Remove the LiveUSB

Turn ON the PC

did it boot ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Banjo

  • Jr. Member
  • **
  • Posts: 40
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8 (64-bit)
Re: grub-efi-amd64-signed failed to install
« Reply #17 on: March 19, 2017, 03:38:34 pm »
For some reason it thinks you have a 32bit UEFI

If you're 100% sure you've run Peppermint 7 64bit on this system before.....


Try this:-

Boot to the LiveUSB (and make sure you have an active internet connection) and run these commands in sequence:
Code: [Select]
sudo mount /dev/mmcblk0p2 /mntthen
Code: [Select]
sudo mount /dev/mmcblk0p1 /mnt/boot/efithen
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; donethen
Code: [Select]
sudo chroot /mntthen
Code: [Select]
grub-install /dev/mmcblk0 --target=x86_64-efithen
Code: [Select]
update-grubthen hit Ctrl+D to exit the chroot environment. (the prompt should change back to $)

Close the terminal and shut down the PC

Remove the LiveUSB

Turn ON the PC

did it boot ?

Yay, it's working. Thank you to everyone for the help. I have no idea WHY it wasn't working, but it is now. I started cheering and my wife thought it was for the race on TV. Nope. Haha.

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5898
  • Karma: 1160
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: grub-efi-amd64-signed failed to install
« Reply #18 on: March 19, 2017, 03:40:31 pm »
Yay, it's working [...] I started cheering and my wife thought it was for the race on TV.

LoL !  :D

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: grub-efi-amd64-signed failed to install
« Reply #19 on: March 19, 2017, 03:49:37 pm »
Great news :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Banjo

  • Jr. Member
  • **
  • Posts: 40
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8 (64-bit)
Re: grub-efi-amd64-signed failed to install
« Reply #20 on: July 03, 2017, 07:10:56 pm »
For some reason it thinks you have a 32bit UEFI

If you're 100% sure you've run Peppermint 7 64bit on this system before.....


Try this:-

Boot to the LiveUSB (and make sure you have an active internet connection) and run these commands in sequence:
Code: [Select]
sudo mount /dev/mmcblk0p2 /mntthen
Code: [Select]
sudo mount /dev/mmcblk0p1 /mnt/boot/efithen
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; donethen
Code: [Select]
sudo chroot /mntthen
Code: [Select]
grub-install /dev/mmcblk0 --target=x86_64-efithen
Code: [Select]
update-grubthen hit Ctrl+D to exit the chroot environment. (the prompt should change back to $)

Close the terminal and shut down the PC

Remove the LiveUSB

Turn ON the PC

did it boot ?
Now that I tried upgrading the same laptop to Peppermint 8, its giving me the same errors, except when I enter the above line of:
Code: [Select]
grub-install /dev/mmcblk0 --target=x86_64-efiI get the following error:
Code: [Select]
grub-install: error: /usr/lib/grub/x86_64-efi/modinfo.sh doesn't exist. Please specify --target or --directory.Any ideas how to fix this?

Offline mblk

  • Newly Subscribed
  • *
  • Posts: 1
  • Karma: 0
  • New To PeppermintOS
    • View Profile
Re: grub-efi-amd64-signed failed to install
« Reply #21 on: October 18, 2020, 09:42:20 am »
Hello. Let me first say I've had Pepp 7 installed on this computer several different times flawlessly. I had recently had Ubuntu GNOME 16.10 on here, but realized Pepp 7 was best for this computer (HP Stream 11), so I was going to reinstall it. I went through the install process as usual letting the installer partition the hard drive with the "Erase and install Peppermint" option as its the only OS on this computer. Each and every time I try to run the LiveUSB to install, I get the following error message:

Code: [Select]
The 'grub-efi-amd64-signed' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot.
I tried installing the Ubuntu GNOME again from LiveUSB the same exact way as I did with Pepp , and that one went perfect. I just want Pepp 7 instead, and have never had this problem before on this computer. I did a bunch of googling and tried many different things, and even found another similar post on this forum, but I'm confused as to whether that issue is the same as mine. I hope someone can point me in the right direction as I'm beating my head against the wall with this one. Thanks.

I would just like to add, I ran into this problem installing on a Windows Surface Pro 3. Tried the same USB on an old 2008 Macbook Pro with the same result. Didn't matter if I installed alongside or erased all partitions. Turns out my issue was the settings I chose when flashing the USB with Rufus. The settings that worked for me: Change Patition Scheme from 'MBR' to 'GPT' and select 'Write in DD Image Mode' when the popup opens after clicking start.