Choose style:

Author Topic: grub-efi-amd64-signed failed to install  (Read 5624 times)

0 Members and 1 Guest are viewing this topic.

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1949
  • Karma: 336
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: grub-efi-amd64-signed failed to install
« Reply #15 on: March 19, 2017, 06:05:21 pm »
If you've changed anything in the firmware/BIOS/EFI/whatever settings, it should be fine to reinstall now (let the installer wipe everything automatically) and hopefully it'll work. If not, why not make a tiny bit of space and install that GNOME distro alongside, which should give you a GRUB that can boot both?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25502
  • Karma: 2808
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: grub-efi-amd64-signed failed to install
« Reply #16 on: March 19, 2017, 06:06:47 pm »
For some reason it thinks you have a 32bit UEFI

If you're 100% sure you've run Peppermint 7 64bit on this system before.....


Try this:-

Boot to the LiveUSB (and make sure you have an active internet connection) and run these commands in sequence:
Code: [Select]
sudo mount /dev/mmcblk0p2 /mnt
then
Code: [Select]
sudo mount /dev/mmcblk0p1 /mnt/boot/efi
then
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then
Code: [Select]
sudo chroot /mnt
then
Code: [Select]
grub-install /dev/mmcblk0 --target=x86_64-efi
then
Code: [Select]
update-grub
then hit Ctrl+D to exit the chroot environment. (the prompt should change back to $)

Close the terminal and shut down the PC

Remove the LiveUSB

Turn ON the PC

did it boot ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Banjo

  • Jr. Member
  • **
  • Posts: 40
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8 (64-bit)
Re: grub-efi-amd64-signed failed to install
« Reply #17 on: March 19, 2017, 06:38:34 pm »
For some reason it thinks you have a 32bit UEFI

If you're 100% sure you've run Peppermint 7 64bit on this system before.....


Try this:-

Boot to the LiveUSB (and make sure you have an active internet connection) and run these commands in sequence:
Code: [Select]
sudo mount /dev/mmcblk0p2 /mnt
then
Code: [Select]
sudo mount /dev/mmcblk0p1 /mnt/boot/efi
then
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then
Code: [Select]
sudo chroot /mnt
then
Code: [Select]
grub-install /dev/mmcblk0 --target=x86_64-efi
then
Code: [Select]
update-grub
then hit Ctrl+D to exit the chroot environment. (the prompt should change back to $)

Close the terminal and shut down the PC

Remove the LiveUSB

Turn ON the PC

did it boot ?

Yay, it's working. Thank you to everyone for the help. I have no idea WHY it wasn't working, but it is now. I started cheering and my wife thought it was for the race on TV. Nope. Haha.

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5262
  • Karma: 942
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: grub-efi-amd64-signed failed to install
« Reply #18 on: March 19, 2017, 06:40:31 pm »
Yay, it's working [...] I started cheering and my wife thought it was for the race on TV.

LoL !  :D

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25502
  • Karma: 2808
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: grub-efi-amd64-signed failed to install
« Reply #19 on: March 19, 2017, 06:49:37 pm »
Great news :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Banjo

  • Jr. Member
  • **
  • Posts: 40
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8 (64-bit)
Re: grub-efi-amd64-signed failed to install
« Reply #20 on: July 03, 2017, 10:10:56 pm »
For some reason it thinks you have a 32bit UEFI

If you're 100% sure you've run Peppermint 7 64bit on this system before.....


Try this:-

Boot to the LiveUSB (and make sure you have an active internet connection) and run these commands in sequence:
Code: [Select]
sudo mount /dev/mmcblk0p2 /mnt
then
Code: [Select]
sudo mount /dev/mmcblk0p1 /mnt/boot/efi
then
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then
Code: [Select]
sudo chroot /mnt
then
Code: [Select]
grub-install /dev/mmcblk0 --target=x86_64-efi
then
Code: [Select]
update-grub
then hit Ctrl+D to exit the chroot environment. (the prompt should change back to $)

Close the terminal and shut down the PC

Remove the LiveUSB

Turn ON the PC

did it boot ?
Now that I tried upgrading the same laptop to Peppermint 8, its giving me the same errors, except when I enter the above line of:
Code: [Select]
grub-install /dev/mmcblk0 --target=x86_64-efi
I get the following error:
Code: [Select]
grub-install: error: /usr/lib/grub/x86_64-efi/modinfo.sh doesn't exist. Please specify --target or --directory.
Any ideas how to fix this?