Choose style:

Author Topic: keyboard bindings  (Read 505 times)

0 Members and 1 Guest are viewing this topic.

Offline Annis Monadjem

  • nOOb
  • *
  • Posts: 10
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
keyboard bindings
« on: March 04, 2017, 04:41:37 am »
Hi,

How do I create a key binding using special keys: F2 - F12 ? In particular I would like to set Alt-F2 to open the Application Finder (xfce4-appfinder) . Currently I have managed to set it with a Alt-F key binding (which is what I don't want).

I am familiar with creating basic key bindings in Peppermint 7.

I have installed Peppermint 7 yesterday and I'm very new to using it.

I have searched and tried without success the following:

1) Peppermint Control Center -> Keyboard Shortcuts -> it does not allow me to enter special keys e.g. F2. I noticed that all key bindings that have been set with F2, ..., F12 are not working too.

2) I have played around with setting/resetting these files but did not find a solution:
~/.config/peppermint-control-center/xbindkeys.conf
~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml

I'll be grateful for any guidance, suggestions or perhaps complete solutions from you.

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1964
  • Karma: 341
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: keyboard bindings
« Reply #1 on: March 04, 2017, 07:58:25 am »
Hi, you're on the right lines. In the file xbindkeys.conf

Code: [Select]
"xfce4-appfinder"
    Alt+F2

is the format. You need to reboot for it to work, I think.

Offline Annis Monadjem

  • nOOb
  • *
  • Posts: 10
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: keyboard bindings
« Reply #2 on: March 04, 2017, 10:42:25 am »
@murraymint: Thank for suggesting to reboot the system - it did the work!   ;D