Choose style:

Author Topic: [SOLVED] Peppermint 7 Fresh Install Won't Boot  (Read 2653 times)

0 Members and 1 Guest are viewing this topic.

Offline minhtung91

  • nOOb
  • *
  • Posts: 22
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
[SOLVED] Peppermint 7 Fresh Install Won't Boot
« on: March 01, 2017, 12:47:25 am »
Hi everyone,
I've tried Peppermint 7 on the live CD and liked it a lot but after installing, I received this error during booting. Please help!!
Code: [Select]
Gave up waiting for root device. Common problems:
  Boot args (cat /proc/cmdline)
    Check rootdelay= (did the system wait long enough?)
    Check root= (did the system wait for the right device?)
  Missing modules (cat /proc/modules; ls /dev)
ALERT! UUID=<drive-uuid> does not exist.   
Dropping to a shell!

BusyBox v.1.22.1 (Ubuntu 1:1.20.0-15ubuntu1) built-in shell (ash)   
Enter 'help' for list of built-in commands. 
(initramfs)
« Last Edit: March 03, 2017, 07:47:43 pm by minhtung91 »

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Peppermint 7 Fresh Install Won't Boot
« Reply #1 on: March 01, 2017, 03:03:40 am »
Hi minhtung91, welcome to the Peppermint Forum  ;).  We need a little more information about your system.  Boot up Peppermint 7 from the live CD you made.  Enter, (copy & paste) the following command into a terminal window and post the output back to the forum:
Code: [Select]
inxi -Fz
Once we have this information, we can start to quickly work on resolving your issue  ;).
« Last Edit: March 01, 2017, 03:49:07 am by AndyInMokum »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Online VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5256
  • Karma: 941
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Peppermint 7 Fresh Install Won't Boot
« Reply #2 on: March 01, 2017, 05:28:40 am »
Interesting !  I haven't 'seen' anyone get dumped into a BusyBox prompt in years.

Might need to run the above command from a Live CD, if GRUB isn't seeing any disks ...


EDIT

I see Andy mentioned that (3:30 AM here - working on my first pot of coffee).    :)

Might want to run a 'blkid' too, so you can see the real UUIDs.
« Last Edit: March 01, 2017, 05:38:20 am by VinDSL, Reason: Addendum »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25462
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Peppermint 7 Fresh Install Won't Boot
« Reply #3 on: March 01, 2017, 08:13:35 am »
Yeah looks like the UUID('s) of your partition(s) changed for some reason or another .. can you boot to the LiveCD/USB and post the output from:
Code: [Select]
sudo fdisk -l
and
Code: [Select]
sudo blkid
then we may need to get the contents of /etc/fstab from the hard drive (not the LiveCD/USB)

The other possibility is that your hard drive just takes a long time to initialise, and the timeout is being reached.
« Last Edit: March 01, 2017, 08:15:10 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline minhtung91

  • nOOb
  • *
  • Posts: 22
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Peppermint 7 Fresh Install Won't Boot
« Reply #4 on: March 01, 2017, 12:35:17 pm »
Thanks a lot for your help! These are what I got from executing the commands you guys suggested
Code: [Select]
peppermint@peppermint ~ $ inxi -Fz
System:    Host: peppermint Kernel: 4.4.0-51-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Seven
Machine:   System: LENOVO (portable) product: 4383 v: Lenovo G575
           Mobo: LENOVO model: Inagua
           Bios: LENOVO v: 41CN26WW(V2.02) date: 09/14/2011
CPU:       Dual core AMD E-450 APU with Radeon HD Graphics (-MCP-) cache: 1024 KB
           clock speeds: max: 1650 MHz 1: 1320 MHz 2: 1320 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 6320]
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.04hz
           GLX Renderer: Gallium 0.4 on AMD PALM (DRM 2.43.0, LLVM 3.8.0)
           GLX Version: 3.0 Mesa 11.2.0
Audio:     Card Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-51-generic
Network:   Card-1: Qualcomm Atheros AR8152 v2.0 Fast Ethernet driver: atl1c
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter
           driver: bcma-pci-bridge
           IF: wlp3s0b1 state: down mac: <filter>
Drives:    HDD Total Size: 335.6GB (2.0% used)
           ID-1: /dev/sda model: WDC_WD3200BPVT size: 320.1GB
           ID-2: USB /dev/sdb model: USB_2.0_FD size: 15.5GB
Partition: ID-1: / size: 1.8G used: 60M (4%) fs: overlay dev: N/A
           ID-2: swap-1 size: 3.87GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
           ID-3: swap-2 size: 0.93GB used: 0.00GB (0%) fs: swap dev: /dev/zram0
           ID-4: swap-3 size: 0.93GB used: 0.00GB (0%) fs: swap dev: /dev/zram1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 56.2C mobo: 0.0C gpu: 57.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 176 Uptime: 4 min Memory: 621.7/3552.9MB
           Client: Shell (bash) inxi: 2.2.35
Code: [Select]
peppermint@peppermint ~ $ sudo fdisk -l
Disk /dev/ram0: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/ram1: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/ram2: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/ram3: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/ram4: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/ram5: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/ram6: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/ram7: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/ram8: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/ram9: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/ram10: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/ram11: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/ram12: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/ram13: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/ram14: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/ram15: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/loop0: 1.1 GiB, 1152995328 bytes, 2251944 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 298.1 GiB, 320072933376 bytes, 625142448 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xe246160e

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1  *         2048 617582591 617580544 294.5G 83 Linux
/dev/sda2       617584638 625141759   7557122   3.6G  5 Extended
/dev/sda5       617584640 625141759   7557120   3.6G 82 Linux swap / Solari

Partition 2 does not start on physical sector boundary.




Disk /dev/sdb: 14.5 GiB, 15514730496 bytes, 30302208 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xf61e8aa1

Device     Boot Start      End  Sectors  Size Id Type
/dev/sdb1  *     2048 30302207 30300160 14.5G  b W95 FAT32


Disk /dev/zram0: 888.2 MiB, 931364864 bytes, 227384 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes


Disk /dev/zram1: 888.2 MiB, 931364864 bytes, 227384 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Code: [Select]
peppermint@peppermint ~ $ sudo blkid
/dev/sda1: UUID="d52579d5-7b84-48d9-a9d9-521b44442902" TYPE="ext4" PARTUUID="e246160e-01"
/dev/sdb1: UUID="4FAD-E72A" TYPE="vfat" PARTUUID="f61e8aa1-01"
/dev/loop0: TYPE="squashfs"
/dev/sda5: UUID="81437372-60fa-4b24-9f87-6f3ec191c259" TYPE="swap" PARTUUID="e246160e-05"
/dev/zram0: UUID="ec7b54b8-8443-467f-9b6c-32f5415b7e39" TYPE="swap"
/dev/zram1: UUID="30d7d991-90b6-4204-82d5-2fee2e0488a3" TYPE="swap"

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25462
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Peppermint 7 Fresh Install Won't Boot
« Reply #5 on: March 01, 2017, 01:02:15 pm »
Boot to the LiveCD/USB. open a terminal and run these commands in sequence:
Code: [Select]
sudo mount /dev/sda1 /mnt
then
Code: [Select]
for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
then
Code: [Select]
sudo chroot /mnt
then
Code: [Select]
grub-install /dev/sda
then
Code: [Select]
update-grub
Now hit Ctrl+D on the keyboard to exit the chroot environment

Now reboot to see if Peppermint starts.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline minhtung91

  • nOOb
  • *
  • Posts: 22
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Peppermint 7 Fresh Install Won't Boot
« Reply #6 on: March 01, 2017, 01:10:22 pm »
Thank you! But I am getting the same error during boot...

Offline minhtung91

  • nOOb
  • *
  • Posts: 22
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Peppermint 7 Fresh Install Won't Boot
« Reply #7 on: March 01, 2017, 01:14:07 pm »
This is what I got
Code: [Select]
peppermint@peppermint ~ $ sudo mount /dev/sda1 /mnt
peppermint@peppermint ~ $ for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
peppermint@peppermint ~ $ sudo chroot /mnt
root@peppermint / # grub-install /dev/sda
Installing for i386-pc platform.
grub-install: warning: Sector 32 is already in use by the program `FlexNet'; avoiding it.  This software may cause boot or other problems in future.  Please ask its authors not to store data in the boot track.
Installation finished. No error reported.
root@peppermint / # update-grub
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found background image: grub-background.png
Found linux image: /boot/vmlinuz-4.4.0-51-generic
Found initrd image: /boot/initrd.img-4.4.0-51-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
done

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25462
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Peppermint 7 Fresh Install Won't Boot
« Reply #8 on: March 01, 2017, 01:41:00 pm »
See here
https://ubuntuforums.org/showthread.php?t=2214517

Now from the LiveCD/USB run:
Code: [Select]
sudo dd if=/dev/zero of=/dev/sda bs=512 count=1 seek=32
then follow the instructions in my last posting again.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline minhtung91

  • nOOb
  • *
  • Posts: 22
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Peppermint 7 Fresh Install Won't Boot
« Reply #9 on: March 01, 2017, 01:52:22 pm »
Hi PCNetSpec,
Code: [Select]
peppermint@peppermint ~ $ sudo mount /dev/sda1 /mnt
mount: /dev/sda1 is already mounted or /mnt busy
       /dev/sda1 is already mounted on /mnt
peppermint@peppermint ~ $ for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
peppermint@peppermint ~ $ sudo chroot /mnt
root@peppermint / # grub-install /dev/sda
Installing for i386-pc platform.
Installation finished. No error reported.
root@peppermint / # update-grub
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found background image: grub-background.png
Found linux image: /boot/vmlinuz-4.4.0-51-generic
Found initrd image: /boot/initrd.img-4.4.0-51-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
done
root@peppermint / # exit
Rebooting now lands me in a black screen with a blinking cursor before I get dropped to a BusyBox again. Peppermint still doesn't start.
« Last Edit: March 01, 2017, 01:54:39 pm by minhtung91 »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25462
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Peppermint 7 Fresh Install Won't Boot
« Reply #10 on: March 01, 2017, 02:13:40 pm »
If I were you (and because you haven't made any changes) I'd just reinstall now you've got rid of FlexNet on the bootsector
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline minhtung91

  • nOOb
  • *
  • Posts: 22
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Peppermint 7 Fresh Install Won't Boot
« Reply #11 on: March 01, 2017, 03:25:04 pm »
I just did a reinstall (erase disk + install) but the problem still persists...

Offline ColonelPanic

  • nOOb
  • *
  • Posts: 22
  • Karma: 4
    • View Profile
    • Linux Linx 2016
  • Peppermint version(s): 7
Re: Peppermint 7 Fresh Install Won't Boot
« Reply #12 on: March 01, 2017, 03:40:01 pm »
Please post the result of the Boot Info Script.
 Boot your live Peppermint and install boot-info-script and pastebinit:
Code: [Select]
sudo apt-get install boot-info-script
Code: [Select]
sudo apt-get install pastebinit
Then run the script:
 
Code: [Select]
sudo bootinfoscript
When you run the boot info script it will create a "results.txt"
Post the contents of results.txt to the pastebin with the command:
Code: [Select]
pastebinit results.txt
Post the resulting URL link here to the fourm.
« Last Edit: March 01, 2017, 03:48:37 pm by ColonelPanic »
AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI

Offline minhtung91

  • nOOb
  • *
  • Posts: 22
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Peppermint 7 Fresh Install Won't Boot
« Reply #13 on: March 01, 2017, 03:55:04 pm »
Here is the pastebin URL
http://pastebin.com/aRwnABAh

Offline ColonelPanic

  • nOOb
  • *
  • Posts: 22
  • Karma: 4
    • View Profile
    • Linux Linx 2016
  • Peppermint version(s): 7
Re: Peppermint 7 Fresh Install Won't Boot
« Reply #14 on: March 01, 2017, 04:29:15 pm »
There is nothing in your Boot Info that appears incorrect. It is all as it should be.
AMD A8-3870 with Radeon HD Graphics 6550D, 8GB DDR3, Ralink RT2561/RT61 802.11g PCI