Choose style:

Author Topic: Slow Boot...Hangs for long after selecting Peppermint at Grub Menu  (Read 2808 times)

0 Members and 1 Guest are viewing this topic.

Offline Capper33

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Hi, I have installed Peppermint 7 on an external hard drive. Ie works fine, but it takes very long to boot after selecting peppermint at the Grub Menu...probably about 4/5 minutes. It boots normally when I try on my laptop. Here are my specs:

Code: [Select]
MS-7529 ~ $ inxi -Fz
System:    Host: hgm-MS-7529 Kernel: 4.4.0-62-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Seven
Machine:   Mobo: MICRO-STAR model: G31M3-F V2(MS-7529) v: 1.0
           Bios: American Megatrends v: V1.5 date: 08/13/2009
CPU:       Dual core Pentium E5200 (-MCP-) cache: 2048 KB
           clock speeds: max: 2520 MHz 1: 2520 MHz 2: 2520 MHz
Graphics:  Card: Intel 82G33/G31 Express Integrated Graphics Controller
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1024x768@85.00hz
           GLX Renderer: Mesa DRI Intel G33 GLX Version: 1.4 Mesa 12.0.6
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-62-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
           IF: ens33 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1040.2GB (0.9% used)
           ID-1: /dev/sda model: ST1000DM003 size: 1000.2GB
           ID-2: USB /dev/sdb model: MHT2040AT size: 40.0GB
Partition: ID-1: / size: 33G used: 5.2G (17%) fs: ext4 dev: /dev/sdb1
           ID-2: swap-1 size: 4.28GB used: 0.00GB (0%) fs: swap dev: /dev/sdb5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 37.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 161 Uptime: 12 min Memory: 549.9/3942.2MB
           Client: Shell (bash) inxi: 2.2.35

Thanks
« Last Edit: February 18, 2017, 12:26:06 pm by Capper33 »

Offline mac

  • Global Moderator
  • Veteran
  • *****
  • Posts: 1088
  • Karma: 336
    • View Profile
  • Peppermint version(s): Peppermint 7-8-9
Re: Slow Boot...Stays Hangs for long after selecting Peppermint at Grub Menu
« Reply #1 on: February 17, 2017, 02:52:57 pm »
Hi Capper33 and Welcome to the forum!   ;)

Open a terminal, run the following command and paste the results back here.
Code: [Select]
pluma /etc/default/grub
Do the same with...
Code: [Select]
systemd-analyze
and...
Code: [Select]
systemd-analyze blame | head -n 20

Have you tried updating grub?  If not, in your terminal run...
Code: [Select]
sudo update-grub
then reboot and see if it makes any difference.

cheers
mac
Peppermint: Standing Out from the Cloud
Reg. Linux User #432835

Offline Capper33

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow Boot...Stays Hangs for long after selecting Peppermint at Grub Menu
« Reply #2 on: February 17, 2017, 05:33:11 pm »
Thanks:

Result for:

pluma /etc/default/grub

Code: [Select]
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

« Last Edit: February 17, 2017, 06:17:51 pm by AndyInMokum »

Offline Capper33

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow Boot...Stays Hangs for long after selecting Peppermint at Grub Menu
« Reply #3 on: February 17, 2017, 05:34:39 pm »
Code: [Select]
hgm@hgm-MS-7529 ~ $ systemd-analyze
Startup finished in 7.201s (kernel) + 46.316s (userspace) = 53.518s
« Last Edit: February 17, 2017, 06:18:11 pm by AndyInMokum, Reason: Encapsulating output with [code]. »

Offline Capper33

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow Boot...Stays Hangs for long after selecting Peppermint at Grub Menu
« Reply #4 on: February 17, 2017, 05:36:02 pm »
Code: [Select]
hgm@hgm-MS-7529 ~ $ systemd-analyze blame | head -n 20
         15.701s apparmor.service
         12.741s dev-sdb1.device
          9.627s mintsystem.service
          9.542s NetworkManager-wait-online.service
          8.050s grub-common.service
          7.380s networking.service
          6.737s irqbalance.service
          6.704s ondemand.service
          6.057s NetworkManager.service
          5.295s lightdm.service
          4.345s console-setup.service
          3.598s systemd-tmpfiles-setup.service
          3.359s ModemManager.service
          3.306s accounts-daemon.service
          3.188s nmbd.service
          3.001s samba-ad-dc.service
          2.595s systemd-tmpfiles-setup-dev.service
          2.542s systemd-udevd.service
          2.403s plymouth-start.service
          1.994s keyboard-setup.service
hgm@hgm-MS-7529 ~ $


« Last Edit: February 17, 2017, 06:16:33 pm by AndyInMokum, Reason: Encapsulating output with [code]. »

Offline Capper33

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow Boot...Stays Hangs for long after selecting Peppermint at Grub Menu
« Reply #5 on: February 17, 2017, 05:49:19 pm »
I did update the grub just now, but still the same problem.

I should also point out that I get the same long boot (described above) when I boot a live usb session. It also just hangs where you get those red spider webs for 4 or 5 min . When I use that same usb on my laptop, it boots normally.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Slow Boot...Stays Hangs for long after selecting Peppermint at Grub Menu
« Reply #6 on: February 17, 2017, 06:26:41 pm »
Hi Capper33, welcome to the Peppermint Forum.  It's nice to meet you  ;).  For future reference, could you please remember to encapsulate terminal outputs with the Insert, Code # function.  For extra long outputs, please use the Spoiler, Sp function.  If you're a Chromium Browser and/or Google Chrome users, please don't combine the functions.  For some reasons, doing so messes up the format.  Only use one or the other  ;).  These preserve the original format of the output.  This makes it easier for future visitors to relate to their own issues.  These functions are found in the forum editor, above the,  :-[ Embarrassed and  the :'( Cry emoticon respectively.  Use the Preview button to see how it'll look in the forum.  This time, I've done it for you - many thanks  ;).[/b], welcome to the Peppermint Forum.  It's nice to meet you  ;).  For future reference, could you please remember to encapsulate terminal outputs with the Insert, Code # function.  For extra long outputs, please use the Spoiler, Sp function.  Chromium Browser and Google Chrome users, please don't combine the functions.  Only use one or the other  ;).  These functions preserve the original format of the output.  This makes it easier for future visitors to relate to their own issues.  These functions are found in the forum editor, above the,  :-[ Embarrassed and  the :'( Cry emoticon respectively.  Use the Preview button to see how it'll look in the forum.  This time, I've done it for you - many thanks  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline mac

  • Global Moderator
  • Veteran
  • *****
  • Posts: 1088
  • Karma: 336
    • View Profile
  • Peppermint version(s): Peppermint 7-8-9
Re: Slow Boot...Stays Hangs for long after selecting Peppermint at Grub Menu
« Reply #7 on: February 17, 2017, 06:54:13 pm »
Okay, try this...
Boot to you BIOS and, under the Advanced tab, look for Integrated Peripherals (or the equivalent...some BIOS are different).  Under Integrated Peripherals see if you find Onboard SATA Mode.....[AHCI].  If so, change the [AHCI] to [Native IDE].  Exit and boot  your external HD. 

Questions for you...

1) You ran those commands booted from your external HD Peppermint install, correct?
2) How did you install Peppermint to the external HD?

While running Peppermint open your terminal and run...
Code: [Select]
blkid
then
Code: [Select]
df -h
Post the results.

When you say
Quote
It boots normally when I try on my laptop
is that a separate install on the laptop or are you using the same external HD?
« Last Edit: February 17, 2017, 07:50:53 pm by mac »
Peppermint: Standing Out from the Cloud
Reg. Linux User #432835

Offline Capper33

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow Boot...Stays Hangs for long after selecting Peppermint at Grub Menu
« Reply #8 on: February 18, 2017, 01:59:07 am »
Questions for you...

"1) You ran those commands booted from your external HD Peppermint install, correct?
2) How did you install Peppermint to the external HD?"


answer 1 - Yes, ran commands booted from external HD Peppermint install
    "        2 - I booted from a live usb, on the pc that is giving me this booting problem, chose the try peppermint option,     
and when booted in, I clicked the install peppermint icon, and chose the option to install peppermint on the drive (custom install) - wiping everything already there. This PC's hard drive with windows 10 was disconnected when I did the install.



Offline Capper33

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow Boot...Stays Hangs for long after selecting Peppermint at Grub Menu
« Reply #9 on: February 18, 2017, 02:01:28 am »
Code: [Select]
hgm@hgm-MS-7529 ~ $ blkid
/dev/sda1: UUID="f37412bc-a528-4fb0-a6e4-4751afe1302d" TYPE="ext4" PARTUUID="8352d179-01"
/dev/sda5: UUID="1d0ac509-fc71-4d06-915f-7b9bb0fab0b2" TYPE="swap" PARTUUID="8352d179-05"
hgm@hgm-MS-7529 ~ $


Offline Capper33

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow Boot...Stays Hangs for long after selecting Peppermint at Grub Menu
« Reply #10 on: February 18, 2017, 02:03:43 am »
Code: [Select]
hgm@hgm-MS-7529 ~ $ df -h
Filesystem      Size  Used Avail Use% Mounted on
udev            2.0G     0  2.0G   0% /dev
tmpfs           395M  6.3M  388M   2% /run
/dev/sda1        33G  5.4G   26G  18% /
tmpfs           2.0G   20M  2.0G   1% /dev/shm
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           2.0G     0  2.0G   0% /sys/fs/cgroup
tmpfs           395M   12K  395M   1% /run/user/1000
hgm@hgm-MS-7529 ~ $

Offline Capper33

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow Boot...Stays Hangs for long after selecting Peppermint at Grub Menu
« Reply #11 on: February 18, 2017, 02:05:21 am »
Quote
When you say
Quote

    It boots normally when I try on my laptop

is that a separate install on the laptop or are you using the same external HD?
Last Edit: February 17, 2017, 07:50:53 pm by mac

I am using the same external HD.

Offline Capper33

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow Boot...Stays Hangs for long after selecting Peppermint at Grub Menu
« Reply #12 on: February 18, 2017, 02:22:28 am »
Quote
Okay, try this...
Boot to you BIOS and, under the Advanced tab, look for Integrated Peripherals (or the equivalent...some BIOS are different).  Under Integrated Peripherals see if you find Onboard SATA Mode.....[AHCI].  If so, change the [AHCI] to [Native IDE].  Exit and boot  your external HD.

In Bios, I went to advance tab, found integrated peripherals, but did not find onboard SATA mode (AHCI)
However, found there on-chip Ata devices; there, on-chip Sata controller was enabled, while on-chip IDE controller was disabled. I enabled on-chip IDE controller, and then tried booting again, but the same problem persisted.

Offline mac

  • Global Moderator
  • Veteran
  • *****
  • Posts: 1088
  • Karma: 336
    • View Profile
  • Peppermint version(s): Peppermint 7-8-9
Re: Slow Boot...Stays Hangs for long after selecting Peppermint at Grub Menu
« Reply #13 on: February 18, 2017, 07:44:52 am »
Well, Capper33, nothing jumps out at me here.  Since it boots well  on your laptop, I 'm thinking the problem is with your PC's USB.  Can you try a different USB port?

One more thing to look at .... run
Code: [Select]
lsusb -v
Please post the results using the spoiler function as it could be rather lengthy. 
« Last Edit: February 18, 2017, 08:09:08 am by mac »
Peppermint: Standing Out from the Cloud
Reg. Linux User #432835

Offline Capper33

  • nOOb
  • *
  • Posts: 15
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Slow Boot...Stays Hangs for long after selecting Peppermint at Grub Menu
« Reply #14 on: February 18, 2017, 11:57:40 am »
Another thing that might be relevant is the fact that I got the "black screen" when I installed linux mint on this same hard drive (in this same PC) before. I was unable to resolve the black screen, therefore I tried linux peppermint (finding peppermint was a good thing that came from that).