Author Topic: Add autostart NumLock (SOLVED)  (Read 1833 times)

Offline sbrazh

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint seven
Add autostart NumLock (SOLVED)
« on: January 22, 2017, 02:36:25 am »
Graphics mode to Add numlockx I have not found. In this case, when using the entrance Lightdm , is usually installed numlockx and sudo nano /etc/lightdm/lightdm.conf . Next row to insert greeter-setup-script=/usr/bin/numlockx on. But there is no file /etc/lightdm/lightdm.conf. What can be done? Thank you. Sorry for my English)
« Last Edit: January 22, 2017, 10:52:25 am by sbrazh »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Add autostart NumLock
« Reply #1 on: January 22, 2017, 03:02:41 am »
There *should* be a:-
/etc/lightdm/lightdm.conf
file .. are you saying that file is missing ?



Here's the easiest way to enable the numlock at login in Peppermint (5/6/7)...

Install numlockx
Code: [Select]
sudo apt-get install numlockxNow go to:-

menu > Preferences > Default applications for LXSession > Autostart (tab)

In the text box to the right of the "+Add" button, enter the command:
Code: [Select]
/usr/bin/numlockx onand click the +Add button.

Lof off/on to test.
« Last Edit: January 22, 2017, 03:29:17 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Slim.Fatz

  • Global Moderator
  • Veteran
  • *****
  • Posts: 2393
  • Karma: 633
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Add autostart NumLock
« Reply #2 on: January 22, 2017, 03:32:15 am »
Hi PCNetSpec,

Do you mean

Code: [Select]
/etc/lightdm/lightdm-gtk-greeter.conf
(which I do have)? Because I too do not have

Code: [Select]
/etc/lightdm/lightdm.conf
 :-\

Regards,

-- Slim
Respect science, respect nature, respect each other.

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Add autostart NumLock
« Reply #3 on: January 22, 2017, 04:16:49 am »
Hmm .. you're right, it seems it's only created if you chose "Autologin" when installing.

You can create one if you want.....

Here's one that will log you in automatically (obviously you'd need to change "autologin-user=mark" for your username):-
Code: [Select]
[Seat:*]
autologin-guest=false
autologin-user=mark
autologin-user-timeout=0
and here's one that WON'T auto login:-
Code: [Select]
[Seat:*]
autologin-guest=false
autologin-user=
autologin-user-timeout=0

BUT in either case adding the line the OP mentioned will NOT autostart numlockx .. that should be done as I mentioned.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline scifidude79

  • Hero
  • *****
  • Posts: 4029
  • Karma: 870
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Add autostart NumLock
« Reply #4 on: January 22, 2017, 06:23:36 am »
All you should have to do is install numlockx, and it should automatically start without doing anything further.  That's how it is on my system, and that's how it was with Peppermint 6 for me also.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Add autostart NumLock
« Reply #5 on: January 22, 2017, 06:41:46 am »
@scifidude

Are you on a desktop PC ? .. or using a USB keyboard on a laptop ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Add autostart NumLock
« Reply #6 on: January 22, 2017, 07:02:48 am »
Another method of enabling the numlock on a laptop would be to edit
Code: [Select]
sudo pluma /etc/X11/Xsession.d/55numlockxfind the line that reads
Code: [Select]
            [ ! -x $ltd ] || ! $ltd || NUMLOCK=offand change it to
Code: [Select]
            [ ! -x $ltd ] || ! $ltd || NUMLOCK=onSAVE the file .. reboot to test
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline scifidude79

  • Hero
  • *****
  • Posts: 4029
  • Karma: 870
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Add autostart NumLock
« Reply #7 on: January 22, 2017, 07:10:40 am »
@scifidude

Are you on a desktop PC ? .. or using a USB keyboard on a laptop ?

Desktop.  But, it does the same thing on my laptop and my other desktop.

This is from the description of numlockx in Synaptic:

Quote
The package automatically installs session script to enable numlock on session start.

I'm guessing that script was added at some point and that's what makes it work.

Offline sbrazh

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint seven
Re: Add autostart NumLock
« Reply #8 on: January 22, 2017, 08:00:03 am »
Thank you to all the participants of the discussion topics.
The option with the Default applications for LXSession works if  to use auto-login.  The connection of the Numlock takes place after login. If you log on with a password, at the time of entering the password the Numlock is still disabled.

I created /etc/lightdm/lightdm.conf
And on the recommendation of  PCNetSpec:
[Seat:*]
autologin-guest=false
autologin-user=
autologin-user-timeout=0


At the end of the text added a line:
greeter-setup-script=/usr/bin/numlockx on
Rebooted and everything worked as it should) . The numeric keypad is enabled until the screen appears enter the system.

Thank you very much for the help PCNetSpec. Thanks to other participants of a topic.





Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Add autostart NumLock
« Reply #9 on: January 22, 2017, 10:35:37 am »
You're most welcome sbrazh :)

If you now consider this topic (SOLVED), can you please mark it so by editing the FIRST post in this topic and changing the "Subject" line to:-

Subject: Add autostart NumLock (SOLVED)

Thanks in advance :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline sbrazh

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint seven
Re: Add autostart NumLock
« Reply #10 on: January 22, 2017, 10:54:26 am »
You're most welcome sbrazh :)

If you now consider this topic (SOLVED), can you please mark it so by editing the FIRST post in this topic and changing the "Subject" line to:-

Subject: Add autostart NumLock (SOLVED)

Thanks in advance :)
Yes, of course. Thank you)