Choose style:

Author Topic: PM5 no hibernation available. [SOLVED]  (Read 5774 times)

0 Members and 1 Guest are viewing this topic.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
PM5 no hibernation available. [SOLVED]
« on: June 24, 2014, 12:25:37 am »
A very good Amsterdam morning to everyone.  I just finished installing Peppermint OS Five 64bit.  I prepared the 750GB HDD by using GParted into 3 separate partitions.  /, /home and /swap/ and /home are  formatted to ext4.  The installation went as expected except "Ubiquity" wanted to use sdc as the MBR rather than the usual sda. That may confuse some people.  The installation was thankfully - uneventful.  Peppermint boots up fine, except it searches for Btrfs files.  When hibernate is selected, it is greyed out.  Below are the outputs from
Code: [Select]
sudo fdisk -ls
and
Code: [Select]
gksu gedit /etc/fstab
respectively.
Spoiler (click here to view / hide)
andy@AMILO-Li3710 ~ $ sudo fdisk -ls

Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00014ada

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048    41945087    20971520   83  Linux
/dev/sda2        41945088  1448372223   703213568   83  Linux
/dev/sda3      1448372224  1465147391     8387584   82  Linux swap / Solaris
andy@AMILO-Li3710 ~ $
[close]
Spoiler (click here to view / hide)
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdc1 during installation
UUID=6c388af5-333f-41ee-99c6-a99d2b253940 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sdc2 during installation
UUID=5539ed90-41fc-44aa-9ac9-031b07683339 /home           ext4    defaults        0       2
# swap was on /dev/sdc3 during installation
UUID=ae3a9530-f3c0-4834-8d69-725b1321d997 none            swap 
[close]
I have no idea why the swap space isn't being recognized and used to hibernate.  I'm sure I'm not going to be unique with this one  ;).  Hope everyone is enjoying Peppermint OS Five  - very cool 8)!

Update:  I have checked all the UUIDs and  the swap partition matches in /etc/fstab and blkid.  It was also the same in /etc/initramfs-tools/conf.d/resume.  I rebuilt the initramfs.  This has not changed anything.  I am still unable to hibernate.
« Last Edit: June 24, 2014, 07:54:39 am by AndyInMokum »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: PM5 no hibernation available.
« Reply #1 on: June 24, 2014, 04:49:23 am »
If you're not using the btrfs file system you can stop it searchng for it by uninstalling btrfs-tools:
Code: [Select]
sudo apt-get remove btrfs-tools



Hibernation....

Can you explain what exactly happens when you run:
Code: [Select]
sudo pm-hibernate

I'm currently having an issue resuming from hibernate, but it DOES actually enter hibernation properly .. as show in the
/var/log/pm-suspend.log
(probably needs a quirk applying)

Is your problem a "resume" issue too .. or an actual failure to hibernate in the first place.

If the latter .. that log file may give clues.



[EDIT]

I'm a little confused why fstab says that the partitions where on /dev/sdc at installation .. can you shed any light on that ?

What's the output from:
Code: [Select]
sudo blkid
?
« Last Edit: June 24, 2014, 05:26:40 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: PM5 no hibernation available.
« Reply #2 on: June 24, 2014, 06:57:32 am »
Yeah. hi Mark.  I setup three logical partitions with GParted installed on a thumbdrive.  With GParted open, the MBR is sda and the partitions are, /dev/sda1, /dev/sda2 and /dev/sda3.  When I installed Peppermint OS Five 64bit, Ubiquity reads the MBR to be sdc with the pre-made partitons being read as, /dev/sdc1, /dev/sdc2 and /dev/sdc3 respectively.  The md5sum checked out fine and I've install three times.  One time Ubiquity wanted to use sdb for the MBR.  I was hoping you could shed some light on it

As for the Hibernation, When the hibernation function is selected from the "panel xfce4-power-manager icon:, the option is greyed out.  If hibernation is selected from the logout screen I receive the following error. 
Quote
GDBus.Error:org.freedesktop.DBus.Error.AccessDenied: Operation not permitted
It isn't a resume error.  Hibernate is just not available as an option.  There is nothing recorded in the /var/log/pm-suspend.log.

The output for blkidis below:
Spoiler (click here to view / hide)
andy@AMILO-Li3710 ~ $ blkid
/dev/sda1: LABEL="/" UUID="6c388af5-333f-41ee-99c6-a99d2b253940" TYPE="ext4"
/dev/sda2: LABEL="/home" UUID="5539ed90-41fc-44aa-9ac9-031b07683339" TYPE="ext4"
/dev/sda3: UUID="ae3a9530-f3c0-4834-8d69-725b1321d997" TYPE="swap"
andy@AMILO-Li3710 ~ $
[close]
Its a mystery  :-\.
« Last Edit: June 24, 2014, 07:08:48 am by AndyInMokum »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: PM5 no hibernation available.
« Reply #3 on: June 24, 2014, 07:26:43 am »
Was the USB stick still inserted when you installed ?

and is the HDD set as the primary boot device in the BIOS ?

Actually this is not that important, it's getting it right now, and GRUB favours UUID's over "device" paths anyway



What happens if you open a terminal and run:
Code: [Select]
sudo pm-hibernate
does it hibernate  and resume properly ?



If that works properly, read on....

It seems for some reason they've intentionally disabled hibernate (in policykit-desktop-privileges) from the lxsession-logout screen (probably why it also doesn't work in xfce4-power-manager).. there are 2 workaround here:
https://bugs.launchpad.net/ubuntu/+source/lxsession/+bug/1300798
« Last Edit: June 24, 2014, 07:34:26 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: PM5 no hibernation available.
« Reply #4 on: June 24, 2014, 07:44:15 am »
Was the USB stick still inserted when you installed ?

and is the HDD set as the primary boot device in the BIOS ?

Actually this is not that important, it's getting it right now, and GRUB favours UUID's over "device" paths anyway



What happens if you open a terminal and run:
Code: [Select]
sudo pm-hibernate
does it hibernate  and resume properly ?



If that works properly, read on....

It seems for some reason they've intentionally disabled hibernate (in policykit-desktop-privileges) from the lxsession-logout screen (probably why it also doesn't work in xfce4-power-manager).. there are 2 workaround here:
https://bugs.launchpad.net/ubuntu/+source/lxsession/+bug/1300798
Yes, the USB stick was left in during the whole of the installation.  The HDD is the only device I permanently keep in the BIOS boot order.  Everything else is disabled. 

sudo pm-hibernate works correctly.  Why one earth disable it in, policykit-desktop-privileges?  I'll try the work arounds.  Many thanks.
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: PM5 no hibernation available.
« Reply #5 on: June 24, 2014, 07:52:10 am »
No problem .. please let us know if either of the workaround works ;)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: PM5 no hibernation available. [SOLVED]
« Reply #6 on: June 24, 2014, 07:54:00 am »
Was the USB stick still inserted when you installed ?

and is the HDD set as the primary boot device in the BIOS ?

Actually this is not that important, it's getting it right now, and GRUB favours UUID's over "device" paths anyway



What happens if you open a terminal and run:
Code: [Select]
sudo pm-hibernate
does it hibernate  and resume properly ?



If that works properly, read on....

It seems for some reason they've intentionally disabled hibernate (in policykit-desktop-privileges) from the lxsession-logout screen (probably why it also doesn't work in xfce4-power-manager).. there are 2 workaround here:
https://bugs.launchpad.net/ubuntu/+source/lxsession/+bug/1300798
Yes, the USB stick was left in during the whole of the installation.  The HDD is the only device I permanently keep in the BIOS boot order.  Everything else is disabled. 

sudo pm-hibernate works correctly.  Why one earth disable it in, policykit-desktop-privileges?  I'll try the work arounds.  Many thanks.

Perfect, the work around you suggested works great.  The Hibernate function is still not available from the panel icon though.  You live and learn.  Many thanks again  ;).
« Last Edit: June 24, 2014, 07:59:30 am by AndyInMokum »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: PM5 no hibernation available. [SOLVED]
« Reply #7 on: June 24, 2014, 08:04:08 am »
Which one .. there were 2 workarounds with slightly different syntax on that page.

What's the contents of your:
Code: [Select]
gedit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
file ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: PM5 no hibernation available. [SOLVED]
« Reply #8 on: June 24, 2014, 08:26:32 am »
Which one .. there were 2 workarounds with slightly different syntax on that page.

What's the contents of your:
Code: [Select]
gedit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
file ?

The workaround I used because
Code: [Select]
sudo pm-hibernate
worked was to  create the file,
Code: [Select]
gedit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
I then filled the file with:
Spoiler (click here to view / hide)
[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes
[close]

Note: the line Action=org.freedesktop.login1.hibernate is used instead of line Action=org.freedesktop.upower.hibernate.  This appears to be the best option for the moment.
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: PM5 no hibernation available. [SOLVED]
« Reply #9 on: June 24, 2014, 08:43:20 am »
Thanks for clarifying :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline nberidze

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: PM5 no hibernation available. [SOLVED]
« Reply #10 on: June 26, 2014, 12:32:33 pm »
When I do sudo pm-hibernate, it goes into hibernation, but I can't bring it out of it. It's a HP 630 laptop.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: PM5 no hibernation available. [SOLVED]
« Reply #11 on: June 26, 2014, 01:27:30 pm »
Can you post the output from:
Code: [Select]
free -m
and
Code: [Select]
sudo lshw -C display
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline nberidze

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: PM5 no hibernation available. [SOLVED]
« Reply #12 on: June 26, 2014, 01:44:04 pm »
Code: [Select]
free -m

aaaa@aaaa-HP-630-Notebook-PC ~ $ free -m
             total       used       free     shared    buffers     cached
Mem:          1847       1078        768        139         39        543
-/+ buffers/cache:        495       1351
Swap:         1898          0       1898

and

Code: [Select]
aaaa@aaaa-HP-630-Notebook-PC ~ $ sudo lshw -C display
  *-display               
       description: VGA compatible controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:44 memory:90000000-903fffff memory:80000000-8fffffff ioport:4000(size=64)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: PM5 no hibernation available. [SOLVED]
« Reply #13 on: June 27, 2014, 11:37:40 am »
Obviously your problem might be completely different from mine .. but mine turned out to be related to having an SD card in the slot during resume.

If I took it out, the PC resumed properly.

What might help you debug.....

Run:
Code: [Select]
sudo gedit /etc/default//grub
find the line that reads

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and change it to

GRUB_CMDLINE_LINUX_DEFAULT=""

SAVE the file.

now update the GRUB bootloader configs with:
Code: [Select]
sudo update-grub
hibernate with:
Code: [Select]
sudo pm-hibernate

then see what's the last thing on the screen during the resume .. if it "appears" to stop just after saying something about having disabled the console, thy hitting Ctrl+Alt+F1 and see if there's any additional text that may help
(mine seemed to be freezing whilst trying to mount the SD card .. so I now need to work out a fix .. but at least I know what it is)

Undo the GRUB changes by changing that line back to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and running:
Code: [Select]
sudo update-grub
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline nberidze

  • Jr. Member
  • **
  • Posts: 60
  • Karma: 1
  • New Forum User
    • View Profile
  • Peppermint version(s): 5
Re: PM5 no hibernation available. [SOLVED]
« Reply #14 on: June 28, 2014, 06:31:09 am »
That was exactly what it was. I tried to hibernate without the SDHC card in the slot, and it worked! But when I inserted the card, it froze, like before. The last message (switching to console with Ctrl-Alt-F1) was "Running /scripts/local-premount".

Thanks a lot for looking into this. Have a nice day!  :)