Choose style:

Author Topic: "Time and Date" doesn't work(solved)  (Read 825 times)

0 Members and 1 Guest are viewing this topic.

Offline Pikolo

  • Trusted User
  • Member
  • *****
  • Posts: 138
  • Karma: 25
    • View Profile
  • Peppermint version(s): 8
"Time and Date" doesn't work(solved)
« on: January 07, 2017, 06:56:13 pm »
I've recently found myself traveling for holidays and back, switching the timezone back and forth.

Unfortunately, the Time and Date application(included in Peppermint Settings Panel) failed me twice. It only actually switches the time zone after suspend to disk/reboot. And even that doesn't consistently work.
I am dual booting, but I have not touched Windows for a few months now. I think the laptop keeps the time as UTC, but I don't know how to check that.

This is annoying. Is there a way to make it synchronize when you lock the new timezone?

My inxi will show you a fairly tweaked system, so that might be the source of the problem:
Code: [Select]
pshem@PiLenovo ~ $ inxi -Fz
System:    Host: PiLenovo Kernel: 4.8.0-32-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Seven
Machine:   System: LENOVO product: 20257 v: IdeaPad S210 Touch
           Mobo: LENOVO model: Ideapad S210 v: 31900003Std
           Bios: LENOVO v: 80CN15WW date: 04/10/2013
CPU:       Dual core Intel Core i3-3217U (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 1800 MHz 1: 1231 MHz 2: 1292 MHz 3: 1220 MHz
           4: 1186 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.97hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile
           GLX Version: 3.0 Mesa 13.0.2 - padoka PPA
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.8.0-32-generic
Network:   Card-1: Intel Centrino Wireless-N 2230 driver: iwlwifi
           IF: wlp2s0 state: up mac: <filter>
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (12.5% used)
           ID-1: /dev/sda model: ST500LT012 size: 500.1GB
Partition: ID-1: / size: 47G used: 33G (73%) fs: ext4 dev: /dev/sda7
           ID-2: swap-1 size: 4.17GB used: 0.21GB (5%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 58.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 243 Uptime: 10 days Memory: 2141.8/3830.2MB
           Client: Shell (bash) inxi: 2.2.35
Kernel 4.8(avaliable in mintupdate, under View - Linux kernels) solved the recurring "vanishing fonts" problem I described months ago. I don't think I've reached 10 days of uptime before!
Mesa shouldn't have anything to do with this problem, it's just a stable PPA game company support asked me to use.
« Last Edit: January 07, 2017, 08:06:25 pm by Pikolo »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: "Time and Date" doesn't work
« Reply #1 on: January 07, 2017, 07:10:59 pm »
If you mean just the clock...

Righ-click the clock .. select "Properties" .. in the "Timezone" field, type the first letter of the "area"

Such as "a" for America, etc

or "e" for Europe, etc.

then hit the DOWN arrow key on your keyboard

You should see a drop menu where you can set the clock timezone.



Sadly the panel applets don't pick up a full system timezone change unless/until the panel is restarted
Code: [Select]
xfce4-panel -r
or log off/on.

with any luck this will be fixed in PM8.
« Last Edit: January 07, 2017, 07:14:17 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Pikolo

  • Trusted User
  • Member
  • *****
  • Posts: 138
  • Karma: 25
    • View Profile
  • Peppermint version(s): 8
Re: "Time and Date" doesn't work
« Reply #2 on: January 07, 2017, 08:05:16 pm »
Thank you very much for clarifying this. Restarting the panel worked.
Is the timezone kept separately for the clock and the rest of the system? I find it puzzling

Good luck fixing that for PM8!