Choose style:

Author Topic: xfce whisker menu is launching a bit slow - how to improve speed? [SOLVED]  (Read 6867 times)

0 Members and 1 Guest are viewing this topic.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: xfce whisker menu is launching a bit slow - how to improve speed?
« Reply #30 on: January 13, 2017, 02:23:06 am »
Hi harishpathangay, how's it going  :)?  It's great to know you've resolved your issue 8).  For future reference, could you please remember to mark the topic as [SOLVED] in the subject line of the original post.  I've done this for you this time.  Many thanks  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

harishpathangay

  • Guest
Re: xfce whisker menu is launching a bit slow - how to improve speed? [CLOSED]
« Reply #31 on: January 13, 2017, 07:52:34 am »
hi,
It is not solved. I do not want others to spend time either. I have brought things to attention of people.
but definitely I would say closed.

thanks,
harish pathangay

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25692
  • Karma: 2820
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: xfce whisker menu is launching a bit slow - how to improve speed? [SOLVED]
« Reply #32 on: January 13, 2017, 08:34:50 am »
If you're running one of the default icon sets, try running:
Code: [Select]
sudo update-icon-caches /usr/share/icons/Peppermix-7 /usr/share/icons/Peppermix-7-Brown /usr/share/icons/Peppermix-7-Pink /usr/share/icons/Peppermix-7-Red /usr/share/icons/Numix /usr/share/icons/Numix-Circle
and see if that makes a difference ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

harishpathangay

  • Guest
Re: xfce whisker menu is launching a bit slow - how to improve speed? [SOLVED]
« Reply #33 on: January 13, 2017, 01:16:59 pm »
hi pcnetspec,
yes i am using default icon sets.
i did update icon cache as suggested and reboot.
still no improvement.

thanks,
harish pathangay

harishpathangay

  • Guest
Re: xfce whisker menu is launching a bit slow - how to improve speed? [SOLVED]
« Reply #34 on: January 14, 2017, 01:36:14 am »
hi,
the title is misleading. the slowness is observed not only in whisker menu but also the normal traditional simple menu.
i did one another test. removed all the *.desktop files from usr/share/applications folder.
rebooted. the menu got fast. it was taking only 1 sec instead of 6 sec. number of applications are definitely impacting the popup of the menu.
to give you some numbers: it is 381 items as desktop files in applications folder.

Another interesting Note: the slowness is not only on menu pop-up. it is also observed in file managers.
go to /usr/share/applications folder - i observe the slowness to load the display of files.
copy the *.desktop files from usr/shareapplications folder to home folder. navigate to home folder - again observed the slowness.

i think 385 *.desktop files are going to slow down any system eventually. 
any body have that much desktop files in application folders, try and let me know?

Also i tried another test:
In Whisker Menu there is a setting not to show icons, just show names and descriptions.
i even tried that setting. this was to make sure loading of icons is not creating the slowness.
rebooted the system. the menu was still slow only.

i think just 381 items in a list is just too much not only for menu but also for file managers.

thanks,
harish p
« Last Edit: January 14, 2017, 01:50:32 am by harishpathangay »

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1777
  • Karma: 469
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: xfce whisker menu is launching a bit slow - how to improve speed? [SOLVED]
« Reply #35 on: January 14, 2017, 03:46:33 am »
Hi harishpathangay,

Yes, the huge number of items must be loaded into the menu "table" and when the number becomes large enough then eventually any system will get slowed down. As I said in my Reply #20:

Quote
I also personally believe that such large, complex DEs (such as Plasma, Gnome, etc.) are best used in Linux distros that have been designed from the start to work with them. Peppermint Seven is a hybrid that has been built and finely "tuned" to work optimally with the DE that is found when you do a fresh installation. It has not been tested, designed and "tuned" to work (optimally) with any of these other DEs. It might, and probably will, work with them -- but not optimally.

Regards,

-- Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

harishpathangay

  • Guest
Re: xfce whisker menu is launching a bit slow - how to improve speed? [SOLVED]
« Reply #36 on: January 14, 2017, 04:07:20 am »
Hi,
I am completely, totally, utterly, blatantly [add more adjectives from other languages also] in blame for multiple DE mess that I got into.
Planning to delete all the unwanted DE specific application *.desktop files alone from that folder as of now.
I do have to admit that I am a fan of LxQt DE and will keep that with PM 7.

thanks,
harish p

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25692
  • Karma: 2820
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: xfce whisker menu is launching a bit slow - how to improve speed? [SOLVED]
« Reply #37 on: January 15, 2017, 09:41:22 am »
I could be wrong, but I doubt the system would have much difficulty reading 381 simple text files pretty quickly .. I mean the system has to read and act on thousands of more complex ones during boot.

I'd think it more likely that some are corrupt, formatted incorrectly, or spanning bad sectors on your hard drive.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

harishpathangay

  • Guest
Re: xfce whisker menu is launching a bit slow - how to improve speed? [SOLVED]
« Reply #38 on: January 15, 2017, 02:13:59 pm »
how to check for bad sectors in pm?
i cannot check it after booting or mounting from the same file system. right?
should i do it from live cd?

it has been long time i did such a test. any case it is helpful to know how to do it. i can run it once a month, just to be safe from a failing HD.

thanks,
harish p

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1777
  • Karma: 469
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: xfce whisker menu is launching a bit slow - how to improve speed? [SOLVED]
« Reply #39 on: January 15, 2017, 04:06:17 pm »
Hi harishpathangay,

You would do this just as you would from any Linux distro. One good thing to install is the package smartmontools (in the repos). Then read up on how to use it (the internet is full of information about how to use it and interpret its output).  ;)

Regards,

-- Slim
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline pehoko

  • Jr. Member
  • **
  • Posts: 33
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
I have same problem - Peppermint 7 works very slowly compared to 6 installed on same PC.  Windows open/close  slow, browser chrome - very slow, any program launch/close takes minimum 10 seconds to complete.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25692
  • Karma: 2820
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
You're posting in a topic marked as (SOLVED) .. it's unlikely to get much attention, so you'd probably be better off opening a new topic pehoko ;)
(plus your problem sounds different to this one .. more system wide than just the whiskermenu)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Ly

  • Member
  • ***
  • Posts: 200
  • Karma: 16
  • New Forum User
    • View Profile
i'm having this porblem too (didn't pay much attention sisnce it's not that annoying xD )
the only tweaks i did :
-Installing Paper icon theme (some of the icons on the whisker menu are "blank" like all of the game icons and pixlr ones, others work just fine)
-Arc theme
-Breeze mouse cursor.
-Plank.

i don't have many apps installed (Oracle Java,Eclipse,Brackets,Libreoffice,LaTeX and others but i don't think their numbers exceed 15-20 apps, and since peppermint is really light on apps i don't think this is an issue)
i'm not really sure of this, but i think that this "problem" started when i installed TImeShift (i configured it to save a snapshot every week) but i'm pretty sure that's not the issue.
Maybe the theme or the "non available" icons...

Offline scifidude79

  • Global Moderator
  • Hero
  • *****
  • Posts: 4029
  • Karma: 863
    • View Profile
  • Peppermint version(s): Peppermint 9
It's generally a better idea to post issues in a new thread, rather than in a thread marked as "Solved."  When people see that, they assume someone already provided an answer, so they may not look at the thread.