Author Topic: [SOLVED] Acer Aspire-3630 - resoloution Silicon Integrated Systems [SiS] 661/741  (Read 3964 times)

Offline LegerD

  • Newly Subscribed
  • *
  • Posts: 14
  • Karma: 2
  • Refugee Laptop Project
    • View Profile
  • Peppermint version(s): 6 & 7 Respin both in 32 &64 Bit
Hello Nerds,

today I have to ask you for some help:

Have installed Peppemint 7 Respin 32 Bit on an Acer Aspire-3630 Type 3634WLM from 2004.
In general this is working fine, but one little thing is buggy: screen resoloution on the Graphics Card: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter

When testing the laptop with the iso CD it runs super smooth with 1024 x 768 pixels.
But after the installation the resoloution falls behind to 640 x 480.

I have made inxi outputs of both situations:

Testing with CD runs 1024 x 768:

Code: [Select]
System:   Host:peppermint Kernel:4.4.0-51-generic i686 (32 bit gcc:5.4.0) Desktop:N/A
          Distro:Peppermint Seven
Machine:  System:Acer product:Aspire 3630
          Mobo:Acer model:Lugano Bios:Acer v:3A22 date:03/20/06
CPU:      Single coreIntel Celeron M (-UP-)cache:1024 KB
          flags:(nx pae sse sse2) bmips:3200 speed:1600 MHz (max)
Graphics: Card:Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter
          bus-ID:01:00.0
          Display Server:X.Org 1.18.4 drivers:vesa (unloaded: fbdev) Resolution:1024x768@61.00hz
          GLX Renderer:Gallium 0.4 on llvmpipe (LLVM 3.8, 128 bits)
          GLX Version:3.0 Mesa 11.2.0 Direct Rendering:Yes
Audio:    CardSilicon Integrated Systems [SiS] SiS7012 AC'97 Sound Controller
          driver:snd_intel8x0 ports:1c00 1800 bus-ID:00:02.7
          Sound:Advanced Linux Sound Architecture v:k4.4.0-51-generic
Network:  Card-1:Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet
          driver:sis900 port:2000 bus-ID:00:04.0
          IF:enp0s4 state:up speed:100 Mbps duplex:full mac:00:16:36:55:63:16
          Card-2:Intel PRO/Wireless 2200BG [Calexico2] Network Connection
          driver:ipw2200 v:1.2.2kmprq bus-ID:00:0b.0
          IF:wlp0s11 state:dormant mac:00:0e:35:28:c5:d9
Drives:   HDD Total Size:164.0GB (3.9% used) ID-1:/dev/sda model:SAMSUNG_HM160HC size:160.0GB temp:33C
          ID-2:USB /dev/sdb model:Flash_Disk size:4.0GB temp:0C
Partition:ID-1:/ size:991M used:22M (3%) fs:overlay dev:N/A
          ID-2:swap-1 size:1.04GB used:0.00GB (0%) fs:swap dev:/dev/sda6
          ID-3:swap-2 size:1.04GB used:0.00GB (0%) fs:swap dev:/dev/zram0
RAID:     No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:  System Temperatures: cpu:50.0C mobo:N/A
          Fan Speeds (in rpm): cpu:N/A
Info:     Processes:153 Uptime:23 min Memory:295.3/1980.1MB Init:systemd runlevel:5 Gcc sys:N/A
          Client:Shell (bash 4.3.461) inxi:2.2.35


After installtion the resolution falls behint to 640 x 480 due to a false driver:

Code: [Select]
System:    Host: funker-Aspire-3630 Kernel: 4.4.0-51-generic i686 (32 bit)
           Desktop: N/A Distro: Peppermint Seven
Machine:   System: Acer product: Aspire 3630
           Mobo: Acer model: Lugano
           Bios: Acer v: 3A22 date: 03/20/06
CPU:       Single core Intel Celeron M (-UP-) cache: 1024 KB
           speed: 1600 MHz (max)
Graphics:  Card: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter
           Display Server: X.org 1.18.4 drivers: fbdev (unloaded: vesa)
           tty size: 70x24 Advanced Data: N/A for root
Audio:     Card Silicon Integrated Systems [SiS] SiS7012 AC'97 Sound Controller
           driver: snd_intel8x0
           Sound: ALSA v: k4.4.0-51-generic
Network:   Card-1: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet
           driver: sis900
           IF: enp0s4 state: up speed: 100 Mbps duplex: full
           mac: <filter>
           Card-2: Intel PRO/Wireless 2200BG [Calexico2] Network Connection
           driver: ipw2200
           IF: wlp0s11 state: dormant mac: <filter>
Drives:    HDD Total Size: 164.0GB (2.8% used)
           ID-1: /dev/sda model: SAMSUNG_HM160HC size: 160.0GB
           ID-2: USB /dev/sdb model: Flash_Disk size: 4.0GB
Partition: ID-1: / size: 61G used: 3.4G (6%) fs: ext4 dev: /dev/sda6
           ID-2: swap-1 size: 1.04GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 56.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 149 Uptime: 2:00 Memory: 191.7/966.1MB
           Client: Shell (sudo) inxi: 2.2.35


I learned from search, that i have to use the vesa driver.

Found also this tutorial (sorry it is in GERMAN)
http://axebase.net/blog/2014/08/23/sis-671-in-lubuntu-14-04xorg-1-15/

but i did not manage to make it work, since i did not find the x11 config file to patch.

Can someone please "translate" this stuff into some nice words for me so that I can make this SIS grafics card work by replacing the driver?
Sounds like Peppermint has a different X-Server or something and I need a how-to-Translation to this situation.

THANK YOU in advance for any help!

Best regards from Germany

Peter

« Last Edit: December 15, 2016, 12:11:24 pm by LegerD »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
What's the output from:
Code: [Select]
lsmodand
Code: [Select]
sudo lshw -C display
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline LegerD

  • Newly Subscribed
  • *
  • Posts: 14
  • Karma: 2
  • Refugee Laptop Project
    • View Profile
  • Peppermint version(s): 6 & 7 Respin both in 32 &64 Bit
Hi PCNetSpec!

Thanks for showing up.

here you are:

Code: [Select]
funker-Aspire-3630 ~ $ lsmod
Module                  Size  Used by
nls_utf8               16384  0
ufs                    73728  0
qnx4                   16384  0
hfsplus                94208  0
hfs                    57344  0
minix                  32768  0
ntfs                  102400  0
msdos                  20480  0
jfs                   180224  0
xfs                   888832  0
libcrc32c              16384  1 xfs
nls_iso8859_1          16384  0
uas                    20480  0
usb_storage            57344  1 uas
snd_intel8x0           36864  2
snd_ac97_codec        106496  1 snd_intel8x0
ac97_bus               16384  1 snd_ac97_codec
ipw2200               143360  0
libipw                 36864  1 ipw2200
snd_pcm                94208  2 snd_ac97_codec,snd_intel8x0
lib80211               16384  1 libipw
cfg80211              499712  2 libipw,ipw2200
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            28672  1 snd_seq_midi
snd_seq                57344  2 snd_seq_midi_event,snd_seq_midi
pcmcia                 57344  0
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
joydev                 20480  0
input_leds             16384  0
snd_timer              32768  2 snd_pcm,snd_seq
serio_raw              16384  0
snd                    69632  11 snd_ac97_codec,snd_intel8x0,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_seq_device
yenta_socket           45056  0
soundcore              16384  1 snd
pcmcia_rsrc            20480  1 yenta_socket
pcmcia_core            24576  3 pcmcia,pcmcia_rsrc,yenta_socket
shpchp                 32768  0
i2c_sis96x             16384  0
mac_hid                16384  0
parport_pc             32768  0
ppdev                  20480  0
lp                     20480  0
parport                45056  3 lp,ppdev,parport_pc
autofs4                40960  2
btrfs                1003520  0
xor                    28672  1 btrfs
raid6_pq              102400  1 btrfs
psmouse               118784  0
sis900                 28672  0
mii                    16384  1 sis900
pata_acpi              16384  0
fjes                   28672  0
sis_agp                16384  1


and:

Code: [Select]
funker-Aspire-3630 ~ $ sudo lshw -C display
[sudo] password for funker:
  *-display UNCLAIMED     
       description: VGA compatible controller
       product: 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 32 bits
       clock: 66MHz
       capabilities: pm agp agp-3.0 vga_controller cap_list
       configuration: latency=0
       resources: memory:e8000000-efffffff memory:e2100000-e211ffff ioport:9000(size=128)

i hope this is correct and helps you helping me.
Best regards

Peter

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Any chance you can also post those outputs from a Live session for comparison ?
(sorry, should have asked that earlier)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline LegerD

  • Newly Subscribed
  • *
  • Posts: 14
  • Karma: 2
  • Refugee Laptop Project
    • View Profile
  • Peppermint version(s): 6 & 7 Respin both in 32 &64 Bit
Hello PCNetSpec,

no Problem. THX for suporting mz issue!

BTW i installed with the settings
 online update  OFF
 proprietarz Driver Download sound card, grafics, MP3 etc. ON

After install i made the usual update with the tool.

Here you are

Code: [Select]
peppermint@peppermint ~ $ lsmod
Module                  Size  Used by
nls_iso8859_1          16384  1
uas                    20480  0
usb_storage            57344  2 uas
snd_intel8x0           36864  2
snd_ac97_codec        106496  1 snd_intel8x0
ac97_bus               16384  1 snd_ac97_codec
snd_pcm                94208  2 snd_ac97_codec,snd_intel8x0
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            28672  1 snd_seq_midi
pcmcia                 57344  0
yenta_socket           45056  0
snd_seq                57344  2 snd_seq_midi_event,snd_seq_midi
pcmcia_rsrc            20480  1 yenta_socket
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_pcm,snd_seq
pcmcia_core            24576  3 pcmcia,pcmcia_rsrc,yenta_socket
snd                    69632  11 snd_ac97_codec,snd_intel8x0,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_seq_device
input_leds             16384  0
joydev                 20480  0
soundcore              16384  1 snd
serio_raw              16384  0
ipw2200               143360  0
shpchp                 32768  0
libipw                 36864  1 ipw2200
lib80211               16384  1 libipw
cfg80211              499712  2 libipw,ipw2200
mac_hid                16384  0
i2c_sis96x             16384  0
zram                   24576  1
lz4_compress           16384  1 zram
parport_pc             32768  0
ppdev                  20480  0
lp                     20480  0
parport                45056  3 lp,ppdev,parport_pc
autofs4                40960  2
overlay                40960  1
nls_utf8               16384  1
isofs                  40960  1
dm_mirror              24576  0
dm_region_hash         20480  1 dm_mirror
dm_log                 20480  2 dm_region_hash,dm_mirror
psmouse               118784  0
sis900                 28672  0
mii                    16384  1 sis900
sis_agp                16384  1
pata_acpi              16384  0
fjes                   28672  0
peppermint@peppermint ~ $

and

Code: [Select]
peppermint@peppermint ~ $ sudo lshw -C display
  *-display UNCLAIMED     
       description: VGA compatible controller
       product: 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 32 bits
       clock: 66MHz
       capabilities: pm agp agp-3.0 vga_controller cap_list
       configuration: latency=0
       resources: memory:e8000000-efffffff memory:e2100000-e211ffff ioport:9000(size=128)
peppermint@peppermint ~ $

sorry for any typos - american keyboard with german letters on it   :D

Offline LegerD

  • Newly Subscribed
  • *
  • Posts: 14
  • Karma: 2
  • Refugee Laptop Project
    • View Profile
  • Peppermint version(s): 6 & 7 Respin both in 32 &64 Bit
Hi All!

Has Anyone some hint for me on this issue?   :'(
All help highly appreciated!  :D

I learned from this post: https://forum.peppermintos.com/index.php/topic,4744.msg47588.html#msg47588
that the release notes suggest to boot the machine with "try" mode and then hit the "install" button on the Desktop.
From my usual routine i walked the other way  choosing "install now!" on the DVD boot prompt.

@PCNetSpec,: Please tell me, should I try to re-install via the other method "Try-->Desktop-->Install"  again?   :-\

Thank you very much1

Peter
« Last Edit: December 14, 2016, 04:05:14 am by LegerD »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Open a terminal and run:
Code: [Select]
sudo pluma /etc/X11/xorg.confwhen a BLANK file opens, make it read
Code: [Select]
Section "Monitor"
Identifier "Plug and play"
Option "DPMS"
HorizSync 30-82
VertRefresh 50-75
EndSection

Section "Device"
Identifier "Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter"
Driver "vesa"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter"
Monitor "Plug and play"
DefaultDepth 24
Option "AllowGLXWithComposite" "on"
SubSection "Display"
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection
SAVE the file, and exit pluma.

REBOOT.

Now see if you can switch resolutions ?



If for some reason the PC won't boot .. boot to a LiveCD/LiveUSB and delete /etc/X11/xorg.conf from the hard drive (not in the live session where it won't exist) and reboot back to the hard drive and you'll be back where you are now.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline LegerD

  • Newly Subscribed
  • *
  • Posts: 14
  • Karma: 2
  • Refugee Laptop Project
    • View Profile
  • Peppermint version(s): 6 & 7 Respin both in 32 &64 Bit
[SOLVED]

Hello PCNetSpec

The machine is working fine with the high resoloution now! DONE!    8) 8) 8)

I want to say "thank you" for your kind support to my issue.
So I can "deliver" it back to its Ethiopian owner.

I will also take this also as a chance to donate some money to the peppermint project in the name of my refugee-"customers".
You all are doing a great job here and you deserve a bich "THX !!!" for that.  :) :)

Best regards

Peter


Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3233
  • Karma: 625
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Hi LegerD,

Glad to here the problem is now resolved and thanks for trying to mark the Topic [SOLVED]

You will however need to go back to your first post and click Modify and place the [SOLVED] at the end of the Subject line.

That way when people search they will see your original post with [SOLVED] at the end.

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

P10r x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k

Offline LegerD

  • Newly Subscribed
  • *
  • Posts: 14
  • Karma: 2
  • Refugee Laptop Project
    • View Profile
  • Peppermint version(s): 6 & 7 Respin both in 32 &64 Bit
Hello Zebedeeboss

Thx for reminding me to try again.
I now made it to set the  [SOLVED] in the thread title.
My first try was not successful and I was wondering if i was too stupid and gave up.
But your post made my try it a second time and now i found out:

Obvieously i did not made it work first time due to the fact hat i had fully used the maximum thread length in the field.
Now I modified the title to shorten it and it worked to set it  [SOLVED].

I have to work on my skills in short writing   :D :D :D

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3233
  • Karma: 625
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
yw :)
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

P10r x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Hi LegerD, glad it worked out for you, and you're most welcome :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec