Author Topic: Keyboard acting weird  (Read 2498 times)

Offline miguelcosta

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 2
  • New Forum User
    • View Profile
Keyboard acting weird
« on: November 17, 2016, 03:23:02 pm »
Hello all,i7 and my keyboard still acts weird: when I am in a middle of a sentence the cursor just goes to the middle of the  sentence again or just go up 2 or 3 lines randomly ( usually back), or it highlights some words without reason, etc

I had this issue before installing linux ( was running WIN 8.1) so must be something hardware related? I was hoping to have it fixed after the OS installation but its the same..

Code: [Select]
System:    Host: david-300E4C-300E5C-300E7C Kernel: 4.4.0-47-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Seven
Machine:   System: SAMSUNG product: 300E4C/300E5C/300E7C v: 0.1
           Mobo: SAMSUNG model: NP300E5C-S08PT v: FAB1
           Bios: Phoenix v: P02RAP date: 08/21/2012
CPU:       Dual core Intel Core i3-3110M (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 2400 MHz 1: 1398 MHz 2: 1405 MHz 3: 1394 MHz
           4: 1418 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller
           Card-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M]
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1366x768@60.06hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile
           GLX Version: 3.0 Mesa 11.2.0
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-47-generic
Network:   Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter
           driver: ath9k
           IF: wlp2s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (27.7% used)
           ID-1: /dev/sda model: ST500LM012_HN size: 500.1GB
Partition: ID-1: / size: 455G used: 126G (30%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 3.98GB used: 0.29GB (7%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 65.0C mobo: 29.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 206 Uptime: 6:16 Memory: 2629.2/3654.9MB
           Client: Shell (bash) inxi: 2.2.35

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Keyboard acting weird
« Reply #1 on: November 17, 2016, 04:07:09 pm »
is it because you brush the touchpad .. therefore moving the cursor ?

If so, we can disable the touchpad whilst typing .. open a terminal and post the output from:
Code: [Select]
xinput --list
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline miguelcosta

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 2
  • New Forum User
    • View Profile
Re: Keyboard acting weird
« Reply #2 on: November 17, 2016, 04:48:27 pm »
Thank You, here it is:

Code: [Select]
Virtual core pointer                    id=2 [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              id=4 [slave  pointer  (2)]
⎜   ↳ Toshiba Toshiba 2.4G Wireless Mouse      id=10 [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                id=13 [slave  pointer  (2)]
⎣ Virtual core keyboard                    id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard              id=5 [slave  keyboard (3)]
    ↳ Power Button                            id=6 [slave  keyboard (3)]
    ↳ Video Bus                                id=7 [slave  keyboard (3)]
    ↳ Video Bus                                id=8 [slave  keyboard (3)]
    ↳ Power Button                            id=9 [slave  keyboard (3)]
    ↳ WebCam SC-13HDL11939N                    id=11 [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            id=12 [slave  keyboard (3)]

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Keyboard acting weird
« Reply #3 on: November 17, 2016, 05:34:08 pm »
Here's a tutorial from the, User Submitted Tutorials section in the forum Home page.  It'll guide you through how to disable your touch pad and set a delay while typing.  The default delay is 2.5 seconds: Disabling and setting a delay on a laptop touchpad.  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Keyboard acting weird
« Reply #4 on: November 17, 2016, 05:36:12 pm »
I'm not sure whether "syndaemon" works with "Elantech" touchpads Andy (?)

Can't hurt to try though .. miguel, if you run:
Code: [Select]
syndaemon -i 2.5 -ddoes the touchpad stop working for 2.5 seconds when you start typing ?
« Last Edit: November 17, 2016, 05:39:19 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline miguelcosta

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 2
  • New Forum User
    • View Profile
Re: Keyboard acting weird
« Reply #5 on: November 17, 2016, 06:16:06 pm »
I'm not sure whether "syndaemon" works with "Elantech" touchpads Andy (?)

Can't hurt to try though .. miguel, if you run:
Code: [Select]
syndaemon -i 2.5 -ddoes the touchpad stop working for 2.5 seconds when you start typing ?

ii run the command and nothing happens

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Keyboard acting weird
« Reply #6 on: November 17, 2016, 06:37:48 pm »
Oh well, it was worth a try.  When a solution is found, I'll make a tutorial for future users - good luck with it  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5902
  • Karma: 1160
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Keyboard acting weird
« Reply #7 on: November 17, 2016, 06:39:53 pm »
Ever tried this, Andy ?

LINK:  https://launchpad.net/ubuntu/xenial/amd64/gpointing-device-settings/1.5.1-6ubuntu2

I'm upgrading my 'Road Warrior' right now, and was thinking about installing it for shiggles.

Might take care of the OP's prob, too ...

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Keyboard acting weird
« Reply #8 on: November 17, 2016, 10:10:22 pm »
Yeah, I just tried it.  Too many dependency issues to mess around with.  I hate them because I've no idea if messing with them is going bork my machine.  I've been caught like that before :'(.
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline miguelcosta

  • Jr. Member
  • **
  • Posts: 32
  • Karma: 2
  • New Forum User
    • View Profile
Re: Keyboard acting weird
« Reply #9 on: November 18, 2016, 03:01:40 am »
OK Thank You both I can live with it for now though its really annoying since I work a lot with text editors and it decreases my productivity/speed

Cheers,
Miguel

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Keyboard acting weird
« Reply #10 on: November 18, 2016, 07:30:50 am »
What's the output from
Code: [Select]
xinput --list-props "ETPS/2 Elantech Touchpad"
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5902
  • Karma: 1160
  • Team Peppermint
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Keyboard acting weird
« Reply #11 on: November 18, 2016, 07:57:28 am »
I can live with it for now though its really annoying since I work a lot with text editors and it decreases my productivity/speed [...]

I feel your pain !

In my experience, touchpads on Linux distros are ... touchy, e.g. uber sensitive and overly responsive.

I went on a business trip, a couple of years ago, immediately after doing a fresh install, and didn't have time to mess with my touchpad.  It drove me crazy !  No matter how careful I was, I couldn't keep my thumbs off of the touchpad while typing.

My ghetto fix was to resort to placing a credit card over the touchpad while I was typing.  LoL !   ;D

Anyway, there are any number of ways of fixing this 'problem'.  It's a universal irritation for mobile users.  The trick is finding the one that works the best for you, and your rig.