Choose style:

Author Topic: Newbie couldn't connect to wifi until 2nd reboot.  (Read 960 times)

0 Members and 1 Guest are viewing this topic.

Offline simonkbike

  • nOOb
  • *
  • Posts: 2
  • Karma: 0
  • New Forum User
    • View Profile
Newbie couldn't connect to wifi until 2nd reboot.
« on: October 20, 2016, 01:30:06 pm »
Hi,
A first time user of Linux, I've resurrected an old Dell mini 910 notebook (Atom N270 cpu 1GB ram + 16Gb SSD) out of the back of the cupboard to do a job.  It worked pretty well when fired up on a Live USB stick so I went ahead and installed over my old XP. 

I re-booted after installation as requested but then couldn't get it to connect to either of my wifi routers.  As a last resort, I fired up the mobile hotspot on my mobile phone.  The SSID didn't come up but it worked when i added as a hidden wifi.  I was a bit confused so I rebooted again all worked as expected.

So although I don't have a problem now, just wanted to ask for comments.  Unsure whether this was "normal" (re-boot after every change) as that's not what I'd expected from Linux cheerleaders, or perhaps I didn't do quite what I should have.

Cheers
Simon.



Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Newbie couldn't connect to wifi until 2nd reboot.
« Reply #1 on: October 20, 2016, 01:30:06 pm »
To help us help you, ALL new requests for technical support should include basic system information.

If you haven't already done so, please open a terminal (Ctrl+Alt+T) and run the following command:
Code: [Select]
inxi -Fz
then copy what was returned in the terminal and post it back here.

This was an automated response but please don't ignore it, providing this information now is highly likely to save time for both you and any prospective respondents and aid in the diagnosis of your problem  .. Thanks in advance :)

Note - Please rest assured there is nothing in the output from that command that could be construed as a 'security risk', the '-z' option makes sure of that by filtering out your MAC address.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline simonkbike

  • nOOb
  • *
  • Posts: 2
  • Karma: 0
  • New Forum User
    • View Profile
Re: Newbie couldn't connect to wifi until 2nd reboot.
« Reply #2 on: October 20, 2016, 07:49:14 pm »
Sorry:
Code: [Select]
System:    Host: simon-dell-910 Kernel: 4.4.0-24-generic i686 (32 bit)
           Desktop: N/A Distro: Peppermint Seven
Machine:   Mobo: Dell model: CN0J14 v: A04 Bios: Dell v: A04 date: 12/29/2008
CPU:       Single core Intel Atom N270 (-HT-) cache: 512 KB
           clock speeds: max: 1600 MHz 1: 1600 MHz 2: 1067 MHz
Graphics:  Card: Intel Mobile 945GSE Express Integrated Graphics Controller
           Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1024x600@60.03hz
           GLX Renderer: Mesa DRI Intel 945GME x86/MMX/SSE2
           GLX Version: 1.4 Mesa 11.2.0
Network:   Card-1: Broadcom BCM4312 802.11b/g LP-PHY driver: b43-pci-bridge
           IF: wlan0 state: up mac: <filter>
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169
           IF: enp4s0 state: down mac: <filter>
« Last Edit: October 21, 2016, 02:28:22 am by AndyInMokum, Reason: Encapsulating output with [code]. »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Newbie couldn't connect to wifi until 2nd reboot.
« Reply #3 on: October 20, 2016, 08:27:47 pm »
Hi Simon, and welcome to the forum :)

No you wouldn't have had to fully reboot, just restart the network-manager by either:-

a) disabling/enabling networking from the network-manager system tray applet

b) running:
Code: [Select]
sudo systemctl restart network-manager
or
Code: [Select]
sudo service network-manager restart

c) log off/on
« Last Edit: October 20, 2016, 08:29:41 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec