Author Topic: Light Firefox - wrong font color (SOLVED)  (Read 1744 times)

Offline cost

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 2
  • Supersonic
    • View Profile
  • Peppermint version(s): Peppermint 7
Light Firefox - wrong font color (SOLVED)
« on: October 19, 2016, 07:04:57 am »
On YouTube (and maybe other websites) search bar,  the font is white on white background --> can't see anything I type in

It happens when I use a dark theme (Dark Peppermint Theme, my favorite) 

I'm aware it's not Peppermint fault, I googled a little bit and didn't find any solutions (I've already unchecked "use system colors" from Preferences > Colors")

my os: P7 64bit


Do you know any workaround to fix this issue?
« Last Edit: October 19, 2016, 08:10:59 am by cost »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Light Firefox - wrong font color
« Reply #1 on: October 19, 2016, 07:04:57 am »
To help us help you, ALL new requests for technical support should include basic system information.

If you haven't already done so, please open a terminal (Ctrl+Alt+T) and run the following command:
Code: [Select]
inxi -Fzthen copy what was returned in the terminal and post it back here.

This was an automated response but please don't ignore it, providing this information now is highly likely to save time for both you and any prospective respondents and aid in the diagnosis of your problem  .. Thanks in advance :)

Note - Please rest assured there is nothing in the output from that command that could be construed as a 'security risk', the '-z' option makes sure of that by filtering out your MAC address.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline scifidude79

  • Hero
  • *****
  • Posts: 4029
  • Karma: 870
    • View Profile
  • Peppermint version(s): Peppermint 9
Re: Light Firefox - wrong font color
« Reply #2 on: October 19, 2016, 07:09:20 am »
Menu > Preferences > Firefox Themer

Make sure it's set to "Force Light Theme," not "System Default Theme."  This tool was created by PCNetSpec during P7 beta testing to solve this very issue, which has plagued Firefox users for a long time due to how FF implements GTK+ themes.

That should solve your issue.  If it does, you can ignore the auto response for this for now, unless you have a deeper issue that that.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Light Firefox - wrong font color
« Reply #3 on: October 19, 2016, 07:18:55 am »
The only other option would be to use a Firefox COMPLETE theme known to work such as FT DeepDark:
https://addons.mozilla.org/en-US/firefox/addon/ft-deepdark/?src=cb-dl-users

I originally approached the author of FT DeepDark and asked if we could use it out of the box for Peppermint 7, but he regretfully declined :(
« Last Edit: October 19, 2016, 07:25:21 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline cost

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 2
  • Supersonic
    • View Profile
  • Peppermint version(s): Peppermint 7
Re: Light Firefox - wrong font color
« Reply #4 on: October 19, 2016, 07:30:33 am »
Menu > Preferences > Firefox Themer

Make sure it's set to "Force Light Theme," not "System Default Theme."  This tool was created by PCNetSpec during P7 beta testing to solve this very issue, which has plagued Firefox users for a long time due to how FF implements GTK+ themes.

That should solve your issue.  If it does, you can ignore the auto response for this for now, unless you have a deeper issue that that.

thanks scifidude, but it didn't solve it :(

The only other option would be to use a Firefox COMPLETE theme known to work such as FT DeepDark:
https://addons.mozilla.org/en-US/firefox/addon/ft-deepdark/?src=cb-dl-users

I originally approached the author of FT DeepDark and asked if we could use it out of the box for Peppermint 7, but he regretfully declined :(

I will try that one or maybe I just switch back to a light theme, thanks anyway  ;)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Light Firefox - wrong font color
« Reply #5 on: October 19, 2016, 07:35:55 am »
scifidude79's solution should work .. as long as you select "Force Light Theme" then click the "OK" button, THEN CLOSE ALL RUNNING INSTANCES OF FIREFOX AND REOPEN THEM.

This is how Peppermint 7 is set out of the box .. you can choose whatever system theme you want, Firefox will always use the "Peppermix 7 Light" theme.
« Last Edit: October 19, 2016, 07:39:35 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline cost

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 2
  • Supersonic
    • View Profile
  • Peppermint version(s): Peppermint 7
Re: Light Firefox - wrong font color
« Reply #6 on: October 19, 2016, 07:45:07 am »
I did it (force light theme), even if it was already set it by default - i even rebooted my laptop   :D

but I'm using Light FF, not FF, idk if this is the problem

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Light Firefox - wrong font color
« Reply #7 on: October 19, 2016, 07:49:20 am »
It probably is (the themer is specifically for the /usr/bin/firefox executable) .. where do I find "Light Firefox", and I'll take a look.

[EDIT]

Does:
Code: [Select]
env GTK_THEME=Peppermix-Light-7 /usr/local/lib/light/lightstart Firefox Light with the light theme ?
« Last Edit: October 19, 2016, 08:05:21 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline cost

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 2
  • Supersonic
    • View Profile
  • Peppermint version(s): Peppermint 7
Re: Light Firefox - wrong font color
« Reply #8 on: October 19, 2016, 08:12:00 am »

Does:
Code: [Select]
env GTK_THEME=Peppermix-Light-7 /usr/local/lib/light/lightstart Firefox Light with the light theme ?

yes it does, now it's fixed  8)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Light Firefox - wrong font color (SOLVED)
« Reply #9 on: October 19, 2016, 08:19:36 am »
Okay, run:
Code: [Select]
sudo pluma /usr/local/share/applications/mozilla-light.desktopfind the line that currently reads
Code: [Select]
Exec=/usr/local/lib/light/lightand change it to
Code: [Select]
Exec=env GTK_THEME=Peppermix-Light-7 /usr/local/lib/light/lightSAVE the file and exit pluma.

Now the menu item

menu > Internet > Light

Should also start it with the light theme applied.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline cost

  • Jr. Member
  • **
  • Posts: 44
  • Karma: 2
  • Supersonic
    • View Profile
  • Peppermint version(s): Peppermint 7
Re: Light Firefox - wrong font color (SOLVED)
« Reply #10 on: October 19, 2016, 08:29:26 am »
Done, it works from the menu too, I'd marked it as solved bit early though  :D

Great help from this forum, which is the reason Peppermint is the best distro :D

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Light Firefox - wrong font color (SOLVED)
« Reply #11 on: October 19, 2016, 08:42:24 am »
:)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec