Author Topic: Nemo and settings not working right on new install - [SOLVED]  (Read 1317 times)

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3233
  • Karma: 625
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Nemo and settings not working right on new install - [SOLVED]
« on: September 11, 2016, 11:30:48 pm »
EDIT: RESOLVED BY re - installed and all working
Hi
System as below
Spoiler (click here to view / hide)
[close]
in nemo preferences I cannot set anything, it ignores my settings.     ie default view   click on list view nd it simply reverts back to Icon view.
Behaviour - ignore per folder view gets ticked and then the tick is not there.
Regards Zeb...
« Last Edit: October 16, 2016, 09:21:00 am by zebedeeboss »
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

P10r x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3233
  • Karma: 625
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Nemo and settings not working right on new install
« Reply #1 on: September 12, 2016, 12:05:42 am »
Hi

Too may other things going wrong - it must simply have been a wrong install....    going to re-install again.  Will report back if still issues

Thanks Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

P10r x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3233
  • Karma: 625
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Nemo and settings not working right on new install - [RE-OCCURED]
« Reply #2 on: October 15, 2016, 11:08:11 pm »
Hi
This has happened again
I cannot change any of Nemo's settings.
unlike last time everything else is working ok.
How to fix without a total re-install like last time

Spoiler (click here to view / hide)
[close]
Regards Zeb...
« Last Edit: October 15, 2016, 11:11:47 pm by zebedeeboss »
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

P10r x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Nemo and settings not working right on new install - [RE-OCCURED]
« Reply #3 on: October 16, 2016, 06:34:36 am »
what's the output from:
Code: [Select]
whoamiand
Code: [Select]
ls -l ~/.config/dconf/user
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3233
  • Karma: 625
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Nemo and settings not working right on new install - [RE-OCCURED]
« Reply #4 on: October 16, 2016, 08:05:17 am »
Hi

Code: [Select]
zebedee@i7-peppermint ~ $ whoami
zebedee
zebedee@i7-peppermint ~ $ ls -l ~/.config/dconf/user
-rw-r--r-- 1 root root 1212 Oct 16 06:47 /home/zebedee/.config/dconf/user
zebedee@i7-peppermint ~ $

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

P10r x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Nemo and settings not working right on new install - [RE-OCCURED]
« Reply #5 on: October 16, 2016, 08:54:02 am »
That shouldn't be owned by root .. run:
Code: [Select]
sudo chmod 664 /home/zebedee/.config/dconf/userthen
Code: [Select]
sudo chown zebedee:zebedee /home/zebedee/.config/dconf/user
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3233
  • Karma: 625
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Nemo and settings not working right on new install - [RE-OCCURED]
« Reply #6 on: October 16, 2016, 09:09:27 am »
commands ran ok

Code: [Select]
zebedee@i7-peppermint ~ $ whoami
zebedee
zebedee@i7-peppermint ~ $ ls -l ~/.config/dconf/user
-rw-rw-r-- 1 zebedee zebedee 1256 Oct 16 17:04 /home/zebedee/.config/dconf/user
zebedee@i7-peppermint ~ $

Still the same...  edit  I wont make changes

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

P10r x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Nemo and settings not working right on new install - [RE-OCCURED]
« Reply #7 on: October 16, 2016, 09:11:37 am »
what's the output from:
Code: [Select]
ls -l ~/.config | grep dconf
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3233
  • Karma: 625
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Nemo and settings not working right on new install - [RE-OCCURED]
« Reply #8 on: October 16, 2016, 09:13:57 am »
Code: [Select]
zebedee@i7-peppermint ~ $ ls -l ~/.config | grep dconf
drwxr-xr-x 2 root    root    4096 Oct 16 17:04 dconf
zebedee@i7-peppermint ~ $
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

P10r x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Nemo and settings not working right on new install - [RE-OCCURED]
« Reply #9 on: October 16, 2016, 09:17:35 am »
Run:
Code: [Select]
sudo chmod 775 ~/.config/dconfthen
Code: [Select]
sudo chown zebedee:zebedee ~/.config/dconfnow test.
« Last Edit: October 16, 2016, 09:25:52 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3233
  • Karma: 625
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Nemo and settings not working right on new install - [RE-OCCURED]
« Reply #10 on: October 16, 2016, 09:20:42 am »
Hi  That worked

changed the 2nd command though

Code: [Select]
zebedee@i7-peppermint ~ $ sudo chmod zebedee:zebedee ~/.config/dconf
chmod: invalid mode: ‘zebedee:zebedee’
Try 'chmod --help' for more information.
zebedee@i7-peppermint ~ $ sudo chown zebedee:zebedee ~/.config/dconf
zebedee@i7-peppermint ~ $ ls -l ~/.config | grep dconf
drwxrwxr-x 2 zebedee zebedee 4096 Oct 16 17:04 dconf
zebedee@i7-peppermint ~ $

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

P10r x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Nemo and settings not working right on new install - [SOLVED]
« Reply #11 on: October 16, 2016, 09:24:22 am »
yep, fixed above too :-[
« Last Edit: October 16, 2016, 09:26:31 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec