Author Topic: P7: Removing Samba made shutdown very slow ( from 2 secs to 58 secs)  (Read 2962 times)

Offline berliner58

  • Member
  • ***
  • Posts: 68
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Since I don't share files with Windows OS , I thought I would remove Samba to maybe speed up the boot.

My PC needed 32 seconds to boot (  from grub-menu until the login screen of Peppermint shows ).

After uninstalling Samba
Code: [Select]
sudo apt-get remove samba system-config-samba
the boot still takes 32 seconds, but the shutdown takes about 58 seconds.

Is there a way to fix this ?

inxi -Fz:
Spoiler (click here to view / hide)
[close]
« Last Edit: October 09, 2016, 08:13:48 am by berliner58 »
P8 x64 Desktop Dual core Pentium E5400 (-MCP-) RAM: 8GB

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
P7: Removing Samba made shutdown very slow ( from 2 secs to 58 secs)
« Reply #1 on: October 09, 2016, 08:12:15 am »
To help us help you, ALL new requests for technical support should include basic system information.

If you haven't already done so, please open a terminal (Ctrl+Alt+T) and run the following command:
Code: [Select]
inxi -Fzthen copy what was returned in the terminal and post it back here.

This was an automated response but please don't ignore it, providing this information now is highly likely to save time for both you and any prospective respondents and aid in the diagnosis of your problem  .. Thanks in advance :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: P7: Removing Samba made shutdown very slow ( from 2 secs to 58 secs)
« Reply #2 on: October 09, 2016, 08:37:39 am »
Is it always slow to shut down now .. or was it just for the single shutdown after you removed it ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline berliner58

  • Member
  • ***
  • Posts: 68
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: P7: Removing Samba made shutdown very slow ( from 2 secs to 58 secs)
« Reply #3 on: October 09, 2016, 08:58:09 am »
I booted several times after uninstall of Samba and the shutdown was always that long, therefore I  re-installed Samba with
Code: [Select]
sudo apt-get install samba system-config-samba
Now boot needs  32 seconds as always.

Shutdown needs 2 seconds.

Strange.

Befor I mark the thread as closed I got another question:

Is there a chance to speed up boot time ?

I have seen that I should upload dmesg but I cannot find a comfortable file hoster.
Until I have one, I put the relevant part into the spoiler here and remove it then.
dmesg:
Spoiler (click here to view / hide)
[close]
P8 x64 Desktop Dual core Pentium E5400 (-MCP-) RAM: 8GB

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: P7: Removing Samba made shutdown very slow ( from 2 secs to 58 secs)
« Reply #4 on: October 09, 2016, 12:11:06 pm »
Uploading dmesg output is best done somewhere like
http://pastebin.com/
than posting a link.

That said nothing jumps out from your dmesg contents, so post the output from
Code: [Select]
systemd-analyze blameand
Code: [Select]
systemd-analyze critical-chain
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline berliner58

  • Member
  • ***
  • Posts: 68
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: P7: Removing Samba made shutdown very slow ( from 2 secs to 58 secs)
« Reply #5 on: October 09, 2016, 12:56:31 pm »
Thank you, PCNetSpec

dmesg
http://pastebin.com/xVjALpwS

systemd-analyze blame
Spoiler (click here to view / hide)
[close]
systemd-analyze critical-chain
Spoiler (click here to view / hide)
[close]

         
« Last Edit: October 09, 2016, 01:05:28 pm by berliner58 »
P8 x64 Desktop Dual core Pentium E5400 (-MCP-) RAM: 8GB

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: P7: Removing Samba made shutdown very slow ( from 2 secs to 58 secs)
« Reply #6 on: October 09, 2016, 03:36:20 pm »
Are you using wireless ?

Do things speed up if you disable DHCP on your unused wired profile in networkmanager ?

ONLY on the unused wired profile set:-

IPv4 tab
Method: Disabled

IPv6 tab
Method: Ignore
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline berliner58

  • Member
  • ***
  • Posts: 68
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: P7: Removing Samba made shutdown very slow ( from 2 secs to 58 secs)
« Reply #7 on: October 09, 2016, 03:55:36 pm »
My PC has no wireless device.
I only use Ethernet cable which goes to a DSL-Router which is from my Internet-provider.

I have to look into the unused wired profile in the networkmanager. Don't know where to find it and how to do it, but I will try and disable DHCP.
Edit: Have found it. There is no wireless profile at all as expected.  I  modified the DHCP settings as advised and will now restart and test.

I have seen that the network-manager eats too much time at boot.

I am ready to uninstall Apparmor too. Have seen in other threads that people do it and maybe it will speed up boot in my PC too.
« Last Edit: October 09, 2016, 04:00:27 pm by berliner58 »
P8 x64 Desktop Dual core Pentium E5400 (-MCP-) RAM: 8GB

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: P7: Removing Samba made shutdown very slow ( from 2 secs to 58 secs)
« Reply #8 on: October 09, 2016, 04:00:06 pm »
NO, don't disable DHCP for your wired connection if that's the one you use

But you could try setting a static IP address.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline berliner58

  • Member
  • ***
  • Posts: 68
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: P7: Removing Samba made shutdown very slow ( from 2 secs to 58 secs)
« Reply #9 on: October 09, 2016, 04:06:20 pm »
I see.  So I enable DHCP for wired again.

I don't know how to set a static IP-address in my PC.
I have done that before in the Fritzbox and the DSL-Router I have now offers that too, but that is the router and not the PC, so I have to search for instructions first.
P8 x64 Desktop Dual core Pentium E5400 (-MCP-) RAM: 8GB

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: P7: Removing Samba made shutdown very slow ( from 2 secs to 58 secs)
« Reply #10 on: October 09, 2016, 04:13:35 pm »
Do you know the IP address of your router ?

You can find this by right-clicking the networkmanager tray icon and selecting "Connection Information" .. the "Default Route" will normally be your routers IP address.

From the same place, can you also state the current "IP Address"
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline berliner58

  • Member
  • ***
  • Posts: 68
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: P7: Removing Samba made shutdown very slow ( from 2 secs to 58 secs)
« Reply #11 on: October 09, 2016, 04:22:41 pm »
I see many addresses there.
for IP4:
IP-address
Broadcast address
Subnet Mask
Vorgaberoute (route which it must go I guess)
Primary DNS  :  (is identical with above Vorgaberoute address)

P8 x64 Desktop Dual core Pentium E5400 (-MCP-) RAM: 8GB

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: P7: Removing Samba made shutdown very slow ( from 2 secs to 58 secs)
« Reply #12 on: October 09, 2016, 04:51:19 pm »
So what are they ?

It's not a security risk to post these in public .. they're only your LOCAL network addresses, not the internet facing one
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline berliner58

  • Member
  • ***
  • Posts: 68
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 8
Re: P7: Removing Samba made shutdown very slow ( from 2 secs to 58 secs)
« Reply #13 on: October 10, 2016, 12:55:13 am »
Good to know.

Here is the connection info, there are 2 tabs, the first one is this:


The second tab is this:


I have Bitmask installed, but I think the IP which Bitmask uses doesn't make a difference in the connection settings of the network manager.
P8 x64 Desktop Dual core Pentium E5400 (-MCP-) RAM: 8GB

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: P7: Removing Samba made shutdown very slow ( from 2 secs to 58 secs)
« Reply #14 on: October 11, 2016, 03:37:14 pm »
Okay, click the networkmanager icon by the clock and select "Edit Connections"

highlight the connection called "Kabelznetwerkverbindund 1" and click the "Edit" button.

Now (ignoring the "Connection name:" field, which you should leave as is) make the IPv6 tab look like this:-


and the IPv4 tab look like this:-


and click "Save"

and reboot to test.





To UNDO .. just set:-

IPv4
Method: Automatic (DHCP)

and

IPv6
Method: Automatic

and save.
« Last Edit: October 11, 2016, 03:38:45 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec