Choose style:

Author Topic: WiFi LED indicator blinking whilst online (SOLVED)  (Read 3128 times)

0 Members and 1 Guest are viewing this topic.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26325
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: WiFi LED indicator blinking whilst online
« Reply #15 on: October 05, 2016, 10:31:49 am »
Okay do these 3 commands stop the blinking
Code: [Select]
sudo su
echo none | tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
echo none | tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null
and what's the output from
Code: [Select]
cat /etc/rc.local
« Last Edit: October 05, 2016, 10:33:30 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline acer

  • Member
  • ***
  • Posts: 242
  • Karma: 28
    • View Profile
  • Peppermint version(s): Peppermint 9R x86/ 10 x64
Re: WiFi LED indicator blinking whilst online
« Reply #16 on: October 05, 2016, 11:00:55 am »
The 3 commands don't stop the blinking.

Output from:
Code: [Select]
cat /etc/rc.local
Code: [Select]
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

exit 0

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26325
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: WiFi LED indicator blinking whilst online
« Reply #17 on: October 05, 2016, 11:30:17 am »
but
Code: [Select]
echo none | sudo tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
echo none | sudo tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null
does stop the blinking ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline acer

  • Member
  • ***
  • Posts: 242
  • Karma: 28
    • View Profile
  • Peppermint version(s): Peppermint 9R x86/ 10 x64
Re: WiFi LED indicator blinking whilst online
« Reply #18 on: October 05, 2016, 11:38:44 am »
but
Code: [Select]
echo none | sudo tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
echo none | sudo tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null
does stop the blinking ?

Yes, it's been fine for a while now, until reboot, but I won't go there LOL

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26325
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: WiFi LED indicator blinking whilst online
« Reply #19 on: October 05, 2016, 11:46:38 am »
well I'm baffled why
Code: [Select]
echo none | sudo tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
echo none | sudo tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null
would work at a normal command prompt ($)
but
Code: [Select]
echo none | tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
echo none | tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null
wouldn't work at an elevated command prompt (#)

Can you reboot (important that you reboot first) .. then whilst it's blinking post the output from:
Code: [Select]
cat /sys/class/leds/ath5k-phy0::tx/trigger
and
Code: [Select]
cat /sys/class/leds/ath5k-phy0::rx/trigger
then run:
Code: [Select]
echo none | sudo tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
and
Code: [Select]
echo none | sudo tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null
so it stops blinking, then post the output again from:
Code: [Select]
cat /sys/class/leds/ath5k-phy0::tx/trigger
and
Code: [Select]
cat /sys/class/leds/ath5k-phy0::rx/trigger
again
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline acer

  • Member
  • ***
  • Posts: 242
  • Karma: 28
    • View Profile
  • Peppermint version(s): Peppermint 9R x86/ 10 x64
Re: WiFi LED indicator blinking whilst online
« Reply #20 on: October 05, 2016, 12:21:16 pm »
After reboot:
Code: [Select]
cat /sys/class/leds/ath5k-phy0::tx/trigger
Code: [Select]
none kbd-scrollock kbd-numlock kbd-capslock kbd-kanalock kbd-shiftlock kbd-altgrlock kbd-ctrllock kbd-altlock kbd-shiftllock kbd-shiftrlock kbd-ctrlllock kbd-ctrlrlock ADP1-online usb-gadget usb-host cpu0 cpu1 cpu2 cpu3 rfkill0 rfkill1 phy0rx [phy0tx] phy0assoc phy0radio

Code: [Select]
cat /sys/class/leds/ath5k-phy0::rx/trigger
Code: [Select]
none kbd-scrollock kbd-numlock kbd-capslock kbd-kanalock kbd-shiftlock kbd-altgrlock kbd-ctrllock kbd-altlock kbd-shiftllock kbd-shiftrlock kbd-ctrlllock kbd-ctrlrlock ADP1-online usb-gadget usb-host cpu0 cpu1 cpu2 cpu3 rfkill0 rfkill1 [phy0rx] phy0tx phy0assoc phy0radio

Commands run in terminal:
Code: [Select]
echo none | sudo tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
Code: [Select]
echo none | sudo tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null

Post command output from:
Code: [Select]
cat /sys/class/leds/ath5k-phy0::tx/trigger
Code: [Select]
[none] kbd-scrollock kbd-numlock kbd-capslock kbd-kanalock kbd-shiftlock kbd-altgrlock kbd-ctrllock kbd-altlock kbd-shiftllock kbd-shiftrlock kbd-ctrlllock kbd-ctrlrlock ADP1-online usb-gadget usb-host cpu0 cpu1 cpu2 cpu3 rfkill0 rfkill1 phy0rx phy0tx phy0assoc phy0radio

and

Code: [Select]
cat /sys/class/leds/ath5k-phy0::rx/trigger
Code: [Select]
[none] kbd-scrollock kbd-numlock kbd-capslock kbd-kanalock kbd-shiftlock kbd-altgrlock kbd-ctrllock kbd-altlock kbd-shiftllock kbd-shiftrlock kbd-ctrlllock kbd-ctrlrlock ADP1-online usb-gadget usb-host cpu0 cpu1 cpu2 cpu3 rfkill0 rfkill1 phy0rx phy0tx phy0assoc phy0radio
« Last Edit: October 05, 2016, 12:27:50 pm by acer »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26325
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: WiFi LED indicator blinking whilst online
« Reply #21 on: October 05, 2016, 01:16:10 pm »
So the only difference is "none" changes to "[none]" .. well running those commands at an elevated prompt worked for me  :-\

Sod it, let's try it anyway...

First let's backup rc.local
Code: [Select]
sudo cp -v /etc/rc.local /etc/rc.local.bak
Now run:
Code: [Select]
sudo pluma /etc/rc.local
when it opens, make it read
Code: [Select]
!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

echo none | tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
echo none | tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null

exit 0
SAVE the file .. reboot to test.
« Last Edit: October 05, 2016, 01:17:46 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline acer

  • Member
  • ***
  • Posts: 242
  • Karma: 28
    • View Profile
  • Peppermint version(s): Peppermint 9R x86/ 10 x64
Re: WiFi LED indicator blinking whilst online
« Reply #22 on: October 05, 2016, 01:37:17 pm »
ok mate, thanks  ;D
Done Exactly as you requested but it's still blinking after reboot.

The other thing I noticed between the before and after outputs is [phy0tx] changed to phy0tx and [phy0rx] changed to phy0rx (end of each transmit/receive trigger)
Might that have something to do with the issue or was that expected?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26325
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: WiFi LED indicator blinking whilst online
« Reply #23 on: October 05, 2016, 01:40:00 pm »
Were you running these 3 commands
Code: [Select]
sudo su
echo none | tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
echo none | tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null
in sequence, one after the other, and in the same terminal window ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline acer

  • Member
  • ***
  • Posts: 242
  • Karma: 28
    • View Profile
  • Peppermint version(s): Peppermint 9R x86/ 10 x64
Re: WiFi LED indicator blinking whilst online
« Reply #24 on: October 05, 2016, 01:54:23 pm »
Yes, straight after the sudo su command the text changed colour to elevated priviledges
Then I entered each command followed by the [enter] key.
« Last Edit: October 05, 2016, 01:57:51 pm by acer »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26325
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: WiFi LED indicator blinking whilst online
« Reply #25 on: October 05, 2016, 02:02:19 pm »
okay let's leave sudo in, does
Code: [Select]
sudo su
echo none | sudo tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
echo none | sudo tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null
stop the blinking ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline acer

  • Member
  • ***
  • Posts: 242
  • Karma: 28
    • View Profile
  • Peppermint version(s): Peppermint 9R x86/ 10 x64
Re: WiFi LED indicator blinking whilst online
« Reply #26 on: October 05, 2016, 02:06:21 pm »
Yes!!  ;D

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26325
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: WiFi LED indicator blinking whilst online
« Reply #27 on: October 05, 2016, 02:32:46 pm »
What's the output from:
Code: [Select]
ifconfig
?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline acer

  • Member
  • ***
  • Posts: 242
  • Karma: 28
    • View Profile
  • Peppermint version(s): Peppermint 9R x86/ 10 x64
Re: WiFi LED indicator blinking whilst online
« Reply #28 on: October 05, 2016, 02:47:08 pm »
What's the output from:
Code: [Select]
ifconfig
?

Spoiler (click here to view / hide)
enp2s0    Link encap:Ethernet  HWaddr 00:1f:16:42:47:85 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1935 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1935 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:183688 (183.6 KB)  TX bytes:183688 (183.6 KB)

wlp3s0    Link encap:Ethernet  HWaddr 00:23:4d:98:15:07 
          inet addr:192.168.1.83  Bcast:xxx.xxx.x.255  Mask:255.xxx.xxx.0
          inet6 addr: fe80::223:4dff:fe98:1507/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:20203 errors:0 dropped:0 overruns:0 frame:0
          TX packets:19972 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:22934230 (22.9 MB)  TX bytes:3383303 (3.3 MB)
[close]
« Last Edit: October 07, 2016, 08:45:55 am by acer »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26325
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: WiFi LED indicator blinking whilst online
« Reply #29 on: October 05, 2016, 02:48:12 pm »
Run:
Code: [Select]
sudo pluma /etc/network/if-up.d/ath5k-led-trigger
make it read:
Code: [Select]
#!/bin/sh -e

# Only care about the wireless interface "wlp3s0"
if [ "$IFACE" != "wlp3s0" ]; then
    exit 0
fi           

# Also exit, if ath5k-phy0::tx directory doesn't exist.
if [ ! -d "/sys/class/leds/ath5k-phy0::tx" ]; then
    exit 0
fi

# Echo the triggers
echo none > "/sys/class/leds/ath5k-phy0::tx/trigger"
echo none > "/sys/class/leds/ath5k-phy0::rx/trigger"
SAVE the file and exit pluma.

Back in the terminal run:
Code: [Select]
sudo chmod +x /etc/network/if-up.d/ath5k-led-trigger
now reboot to test.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec