Choose style:

Author Topic: WiFi LED indicator blinking whilst online (SOLVED)  (Read 3110 times)

0 Members and 1 Guest are viewing this topic.

Offline acer

  • Member
  • ***
  • Posts: 242
  • Karma: 28
    • View Profile
  • Peppermint version(s): Peppermint 9R x86/ 10 x64
WiFi LED indicator blinking whilst online (SOLVED)
« on: October 04, 2016, 02:02:27 pm »
One annoyance I've put up with is a blinking led on wifi.
Any way to sort this, I've asked before but that was a usb wifi - now given away.
Wifi works ok now after I found one of the internal antenae connectors had come loose from the wifi card.. ::)

output from:
Code: [Select]
sudo lshw -C network
Spoiler (click here to view / hide)
  *-network               
       description: Ethernet interface
       product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 02
       serial: 00:1f:16:42:47:85
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:28 ioport:3000(size=256) memory:d3010000-d3010fff memory:d3000000-d300ffff memory:d6200000-d621ffff
  *-network
       description: Wireless interface
       product: AR242x / AR542x Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 01
       serial: 00:23:4d:98:15:07
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath5k driverversion=4.4.0-38-generic firmware=N/A ip=192.168.1.83 latency=0 link=yes multicast=yes wireless=IEEE 802.11bg
       resources: irq:17 memory:d5100000-d510ffff
[close]

Thanks in advance  ;D
« Last Edit: October 05, 2016, 03:22:54 pm by acer »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26305
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
WiFi LED indicator blinking whilst online
« Reply #1 on: October 04, 2016, 02:02:27 pm »
To help us help you, ALL new requests for technical support should include basic system information.

If you haven't already done so, please open a terminal (Ctrl+Alt+T) and run the following command:
Code: [Select]
inxi -Fz
then copy what was returned in the terminal and post it back here.

This was an automated response but please don't ignore it, providing this information now is highly likely to save time for both you and any prospective respondents and aid in the diagnosis of your problem  .. Thanks in advance :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline acer

  • Member
  • ***
  • Posts: 242
  • Karma: 28
    • View Profile
  • Peppermint version(s): Peppermint 9R x86/ 10 x64
Re: WiFi LED indicator blinking whilst online
« Reply #2 on: October 04, 2016, 02:03:56 pm »
Code: [Select]
System:    Host: HP-Laptop Kernel: 4.4.0-38-generic i686 (32 bit) Desktop: N/A
           Distro: Peppermint Seven
Machine:   System: Hewlett-Packard product: HP G60 Notebook PC v: PCID
           Mobo: Hewlett-Packard model: 3617 v: 09.67
           Bios: Hewlett-Packard v: F.65 date: 12/15/2010
CPU:       Dual core Intel Core2 Duo T5800 (-MCP-) cache: 2048 KB
           clock speeds: max: 2000 MHz 1: 1600 MHz 2: 1200 MHz
Graphics:  Card: NVIDIA G98M [GeForce 9200M GS]
           Display Server: X.Org 1.18.3 drivers: nouveau (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.11hz
           GLX Renderer: Gallium 0.4 on NV98 GLX Version: 3.0 Mesa 11.2.0
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-38-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169
           IF: enp2s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express)
           driver: ath5k
           IF: wlp3s0 state: up mac: <filter>
Drives:    HDD Total Size: 60.0GB (14.7% used)
           ID-1: /dev/sda model: Corsair_Force_LS size: 60.0GB
Partition: ID-1: / size: 51G used: 4.5G (10%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 4.26GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 41.0C mobo: 41.0C gpu: 43.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 173 Uptime: 22 min Memory: 404.4/4009.5MB
           Client: Shell (bash) inxi: 2.2.35

Offline acer

  • Member
  • ***
  • Posts: 242
  • Karma: 28
    • View Profile
  • Peppermint version(s): Peppermint 9R x86/ 10 x64
Re: WiFi LED indicator blinking whilst online
« Reply #3 on: October 04, 2016, 02:28:09 pm »
oh and..
Code: [Select]
lspci -vnn | grep -i net

Spoiler (click here to view / hide)
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 02)
   Subsystem: Hewlett-Packard Company RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [103c:360b]
03:00.0 Ethernet controller [0200]: Qualcomm Atheros AR242x / AR542x Wireless Network Adapter (PCI-Express) [168c:001c] (rev 01)
   Subsystem: Hewlett-Packard Company AR242x / AR542x Wireless Network Adapter (PCI-Express) [103c:137b]
[close]

and
Code: [Select]
lsmod
Spoiler (click here to view / hide)
Module                  Size  Used by
ctr                    16384  3
ccm                    20480  3
arc4                   16384  2
hp_wmi                 16384  0
sparse_keymap          16384  1 hp_wmi
gpio_ich               16384  0
snd_hda_codec_hdmi     49152  1
snd_hda_codec_conexant    20480  1
snd_hda_codec_generic    69632  1 snd_hda_codec_conexant
snd_hda_intel          36864  2
ath5k                 139264  0
uvcvideo               77824  0
ath                    24576  1 ath5k
videobuf2_vmalloc      16384  1 uvcvideo
videobuf2_memops       16384  1 videobuf2_vmalloc
snd_hda_codec         118784  4 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_codec_generic,snd_hda_intel
videobuf2_v4l2         28672  1 uvcvideo
drbg                   28672  1
mac80211              659456  1 ath5k
videobuf2_core         36864  2 uvcvideo,videobuf2_v4l2
ansi_cprng             16384  0
v4l2_common            16384  1 videobuf2_v4l2
snd_hda_core           61440  5 snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep              16384  1 snd_hda_codec
xts                    16384  1
gf128mul               16384  1 xts
dm_crypt               24576  1
coretemp               16384  0
snd_pcm                94208  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
videodev              155648  4 uvcvideo,v4l2_common,videobuf2_core,videobuf2_v4l2
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            28672  1 snd_seq_midi
input_leds             16384  0
media                  24576  2 uvcvideo,videodev
joydev                 20480  0
snd_seq                57344  2 snd_seq_midi_event,snd_seq_midi
serio_raw              16384  0
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
lpc_ich                20480  0
snd_timer              32768  2 snd_pcm,snd_seq
cfg80211              499712  3 ath,ath5k,mac80211
snd                    69632  15 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_conexant,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
shpchp                 32768  0
soundcore              16384  1 snd
binfmt_misc            20480  1
mac_hid                16384  0
ip6t_REJECT            16384  1
nf_reject_ipv6         16384  1 ip6t_REJECT
nf_log_ipv6            16384  5
xt_hl                  16384  22
ip6t_rt                16384  3
nf_conntrack_ipv6      20480  8
nf_defrag_ipv6         28672  1 nf_conntrack_ipv6
ipt_REJECT             16384  1
nf_reject_ipv4         16384  1 ipt_REJECT
nf_log_ipv4            16384  5
nf_log_common          16384  2 nf_log_ipv4,nf_log_ipv6
xt_LOG                 16384  10
xt_limit               16384  13
xt_tcpudp              16384  18
xt_addrtype            16384  4
nf_conntrack_ipv4      16384  8
nf_defrag_ipv4         16384  1 nf_conntrack_ipv4
xt_conntrack           16384  16
ip6table_filter        16384  1
ip6_tables             20480  1 ip6table_filter
nf_conntrack_netbios_ns    16384  0
nf_conntrack_broadcast    16384  1 nf_conntrack_netbios_ns
nf_nat_ftp             16384  0
nf_nat                 24576  1 nf_nat_ftp
parport_pc             32768  0
nf_conntrack_ftp       16384  1 nf_nat_ftp
nf_conntrack           98304  8 nf_nat_ftp,nf_conntrack_netbios_ns,nf_nat,xt_conntrack,nf_conntrack_broadcast,nf_conntrack_ftp,nf_conntrack_ipv4,nf_conntrack_ipv6
ppdev                  20480  0
iptable_filter         16384  1
lp                     20480  0
ip_tables              20480  1 iptable_filter
parport                45056  3 lp,ppdev,parport_pc
x_tables               24576  13 ip6table_filter,xt_hl,ip_tables,xt_tcpudp,xt_limit,xt_conntrack,xt_LOG,iptable_filter,ip6t_rt,ipt_REJECT,ip6_tables,xt_addrtype,ip6t_REJECT
autofs4                40960  2
ums_realtek            20480  0
uas                    20480  0
usb_storage            57344  2 uas,ums_realtek
hid_generic            16384  0
usbhid                 49152  0
hid                    98304  3 hid_generic,usbhid
nouveau              1339392  3
mxm_wmi                16384  1 nouveau
i2c_algo_bit           16384  1 nouveau
ttm                    90112  1 nouveau
drm_kms_helper        135168  1 nouveau
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
ahci                   36864  2
fb_sys_fops            16384  1 drm_kms_helper
r8169                  77824  0
psmouse               118784  0
libahci                32768  1 ahci
drm                   311296  6 ttm,drm_kms_helper,nouveau
mii                    16384  1 r8169
fjes                   28672  0
wmi                    20480  3 hp_wmi,mxm_wmi,nouveau
video                  36864  1 nouveau
[close]
« Last Edit: October 04, 2016, 03:36:44 pm by acer »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26305
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: WiFi LED indicator blinking whilst online
« Reply #4 on: October 04, 2016, 04:10:00 pm »
Does running these 2 commands stop it flashing
Code: [Select]
echo none | sudo tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
then
Code: [Select]
echo none | sudo tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null

For my reference:
https://askubuntu.com/questions/88103/wireless-led-doesnt-stop-blinking-on-an-hp-dv5-with-an-atheros-ar5007
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline acer

  • Member
  • ***
  • Posts: 242
  • Karma: 28
    • View Profile
  • Peppermint version(s): Peppermint 9R x86/ 10 x64
Re: WiFi LED indicator blinking whilst online
« Reply #5 on: October 05, 2016, 03:15:18 am »
Quote

Unfortunately, this driver doesn't have an option to turn that blinking off, but you should be able to control the leds via the sys interface and put the commands in a startup script:

    Test the commands from the command line:

    echo none | sudo tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
    echo none | sudo tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null

    This should completely turn off led triggering on data transfer. If you want it to reflect your radio status (on/off), you can try this instead (I'm afraid I cannot test this):

    echo none | sudo tee "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
    echo phy0radio | sudo tee "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null

    [If phy0radio doesn't work, you can run cat /sys/class/leds/ath5k-phy0::rx/trigger to get a list of supported triggers for the led you can try.]

    Once you know which commands to use, run them automatically when the wireless interface comes up:

        Create and open a new file in gedit from the command line:

        gksu gedit /etc/network/if-up.d/ath5k-led-trigger

        Now paste the following into the file (replace the value to echo and your wireless interface name if necessary):

        #!/bin/sh -e
        # Called whenever an interface comes up. Sets led triggers for
        # tx and rx of the ath5k module.

        # Only care about the wireless interface "wlan0"
        if [ "$IFACE" != "wlan0" ]; then
            exit 0
        fi           

        # Also exit, if /sys is not yet mounted (not sure
        # if that's even possible, but checking shouldn't hurt).
        if [ ! -d "/sys/class/leds/ath5k-phy0::tx/trigger" ]; then
            exit 0
        fi

        # Echo the two triggers
        echo none > "/sys/class/leds/ath5k-phy0::tx/trigger"
        echo none > "/sys/class/leds/ath5k-phy0::rx/trigger"

        Save, quit gedit, back at the command line make the script executable:

        sudo chmod +x /etc/network/if-up.d/ath5k-led-trigger

Next time you reboot, the blinking should be gone. If anyone else knows of a better way to run those two echos on system start (Upstart job?), feel free to comment or suggest an edit. :-)

ok, I tried the commands that you gave and the blinking stopped but, on reboot it was the back ::)
I then tried the 2nd batch of commands and creating the start-up script from your reference link page quoted above
with exactly the same result, no blinking after command input but, once script generated and system rebooted, blinking returned. ???

How do I undo/remove the non working start-up script..?
Code: [Select]
gksu gedit /etc/network/if-up.d/ath5k-led-trigger
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
The thing is, when the system wifi is on and functioning as intended, the wifi LED should blue.
When the wifi is off, the LED should be orange.
What I'm getting is an orange with blue blinking LED when the wifi is connected and working.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26305
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: WiFi LED indicator blinking whilst online
« Reply #6 on: October 05, 2016, 07:25:09 am »
Quote
How do I undo/remove the non working start-up script..?

Code: [Select]
sudo rm -v /etc/network/if-up.d/ath5k-led-trigger

I knew that startup script would no longer work, that's why I didn't ask you to try it and marked the link as for "MY" reference.



Try adding those 2 lines just above the "exit 0" line in
Code: [Select]
sudo pluma /etc/rc.local
I don't know if this'll work as it may get run before networking comes up, but only one way to find out.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline acer

  • Member
  • ***
  • Posts: 242
  • Karma: 28
    • View Profile
  • Peppermint version(s): Peppermint 9R x86/ 10 x64
Re: WiFi LED indicator blinking whilst online
« Reply #7 on: October 05, 2016, 07:43:50 am »
Try adding those 2 lines just above the "exit 0" line in
Code: [Select]
sudo pluma /etc/rc.local
I don't know if this'll work as it may get run before networking comes up, but only one way to find out.

do you mean these:
Code: [Select]
        # Only care about the wireless interface "wlan0"
        if [ "$IFACE" != "wlan0" ]; then

ot the other two lines above 'exit 0'?

Offline acer

  • Member
  • ***
  • Posts: 242
  • Karma: 28
    • View Profile
  • Peppermint version(s): Peppermint 9R x86/ 10 x64
Re: WiFi LED indicator blinking whilst online
« Reply #8 on: October 05, 2016, 07:53:00 am »
Ok, just tried this one and rebooted, no change to LED, still blinking.
Code: [Select]
        # Only care about the wireless interface "wlan0"
        if [ "$IFACE" != "wlan0" ]; then

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26305
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: WiFi LED indicator blinking whilst online
« Reply #9 on: October 05, 2016, 08:37:35 am »
No (remove those lines) .. now do these 3 commands run in sequence stop the LED blinking ?
Code: [Select]
sudo su
echo none "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
echo none "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null
?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline acer

  • Member
  • ***
  • Posts: 242
  • Karma: 28
    • View Profile
  • Peppermint version(s): Peppermint 9R x86/ 10 x64
Re: WiFi LED indicator blinking whilst online
« Reply #10 on: October 05, 2016, 08:53:47 am »
ok, undone the previous and inserted the commands into the CLI/Terminal, rebooted AND...

Still the same..
blinking leds

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26305
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: WiFi LED indicator blinking whilst online
« Reply #11 on: October 05, 2016, 09:44:55 am »
Please stop getting ahead of me .. I didn't ask if they'd survive a reboot, I simply asked if THOSE 3 COMMANDS stopped the blinking ?
« Last Edit: October 05, 2016, 10:14:49 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 1999
  • Karma: 344
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: WiFi LED indicator blinking whilst online
« Reply #12 on: October 05, 2016, 09:53:21 am »

ok, I tried the commands that you gave and the blinking stopped but, on reboot it was the back ::)

This is the point where it was on track, before the diversion :)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26305
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: WiFi LED indicator blinking whilst online
« Reply #13 on: October 05, 2016, 10:15:24 am »
Yes but I've changed the commands, so wanted to check them BEFORE trying to autorun them at boot.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline acer

  • Member
  • ***
  • Posts: 242
  • Karma: 28
    • View Profile
  • Peppermint version(s): Peppermint 9R x86/ 10 x64
Re: WiFi LED indicator blinking whilst online
« Reply #14 on: October 05, 2016, 10:19:39 am »
No (remove those lines) .. now do these 3 commands run in sequence stop the LED blinking ?
Code: [Select]
sudo su
echo none "/sys/class/leds/ath5k-phy0::tx/trigger" > /dev/null
echo none "/sys/class/leds/ath5k-phy0::rx/trigger" > /dev/null

Ok, done these, and blinking is still happening.
Then as murraymint suggested, I input the original commands and the blinking has stopped (without a reboot), my bad oops!
appologies PCNetSpec