Choose style:

Author Topic: Wifi Disconnects Automatically  (Read 1517 times)

0 Members and 1 Guest are viewing this topic.

Offline GokulDeepak

  • nOOb
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Wifi Disconnects Automatically
« on: October 01, 2016, 08:48:33 am »
Hi friends. I have installed Peppermint just now. 
I use Netgear adaptor WNA 1000M. I do not install any software but the adaptor is working superb. But the problem is after few idle minutes the wifi gets disconnected automaticaly. So that I have to swith off the modem and reconnect or plug out and plugin the wifi adaptor once again.

I was using Linux Mint Cinnamon before this. I have the same problem with both the OS but if I use Windows it is normal. There is no problem with the adaptor as it is working nicely in windows 7, 10 and this problem exists only in linux mint and Peppermint.



Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25497
  • Karma: 2807
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Wifi Disconnects Automatically
« Reply #1 on: October 01, 2016, 08:48:33 am »
To help us help you, ALL new requests for technical support should include basic system information.

If you haven't already done so, please open a terminal (Ctrl+Alt+T) and run the following command:
Code: [Select]
inxi -Fz
then copy what was returned in the terminal and post it back here.

This was an automated response but please don't ignore it, providing this information now is highly likely to save time for both you and any prospective respondents and aid in the diagnosis of your problem  .. Thanks in advance :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25497
  • Karma: 2807
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Wifi Disconnects Automatically
« Reply #2 on: October 01, 2016, 10:53:19 am »
Can you answer the autoresponse above please .. in future we may not respond to new requests for support where the autoresponse is ignored ;)

Also post the output from:
Code: [Select]
lspci -vnn | grep -i net
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Admiral_Smith

  • nOOb
  • *
  • Posts: 21
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Wifi Disconnects Automatically
« Reply #3 on: October 02, 2016, 01:20:07 pm »
To troubleshoot, I would test the wifi connection with a network bridge first to see if the connection becomes solid.  I would also test analyze the signal strength on the device and neighboring devices to see if there is an imbalance.  You can also try to put foil on your router to increase directional strength.

Offline GokulDeepak

  • nOOb
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Wifi Disconnects Automatically
« Reply #4 on: October 03, 2016, 01:18:08 am »
For the command:  inxi -Fz

Code: [Select]
System:    Host: BlackBrain Kernel: 4.4.0-24-generic x86_64 (64 bit)
           Desktop: N/A Distro: Peppermint Seven

Machine:   System: LENOVO (portable) product: INVALID v: Lenovo B460e
           Mobo: LENOVO model: N/A Bios: LENOVO v: 4FCNA1WW date: 12/26/2011
CPU:       Dual core Pentium T4500 (-MCP-) cache: 1024 KB
           clock speeds: max: 2300 MHz 1: 1600 MHz 2: 1600 MHz
Graphics:  Card: Intel Mobile 4 Series Integrated Graphics Controller
           Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Mobile Intel GM45 Express
           GLX Version: 2.1 Mesa 11.2.0
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-24-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169
           IF: enp1s0 state: down mac: <filter>
           Card-2: NetGear WNA1000M 802.11bgn [Realtek RTL8188CUS]
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 320.1GB (1.9% used)
           ID-1: /dev/sda model: WDC_WD3200BPVT size: 320.1GB
Partition: ID-1: / size: 292G used: 3.9G (2%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 2.07GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 62.0C mobo: 62.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 180 Uptime: 39 min Memory: 829.9/1931.6MB
           Client: Shell (bash) inxi: 2.2.35

« Last Edit: October 03, 2016, 01:28:32 am by AndyInMokum, Reason: Encapsulating output with [code] »

Offline GokulDeepak

  • nOOb
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Wifi Disconnects Automatically
« Reply #5 on: October 03, 2016, 01:20:00 am »
Details for the command: lspci -vnn | grep -i net

Code: [Select]
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
Subsystem: Lenovo RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [17aa:3975]
« Last Edit: October 03, 2016, 01:29:08 am by AndyInMokum, Reason: Encapsulating output with [code] »

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Wifi Disconnects Automatically
« Reply #6 on: October 03, 2016, 01:34:52 am »
Hi GokulDeepak, welcome to the Peppermint Forum  8).  Thanks for providing the requested details  ;).  This is going to help us help you much quicker.  For future reference, could you please remember to encapsulate terminal outputs with the Insert, Code # function.  For extra long outputs, please use the Spoiler, Sp function.  Don't combine the functions.  Only use one or the other  ;).  These preserve the original format of the output.  This makes it easier for future visitors to relate to their own issues.  These functions are found in the forum editor, above the,  :-[ Embarrassed and  the :'( Cry emoticon respectively.  Use the Preview button to see how it'll look in the forum.  This time, I've done it for you - many thanks  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25497
  • Karma: 2807
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Wifi Disconnects Automatically
« Reply #7 on: October 03, 2016, 08:59:04 am »
is this a USBB adapter ?

If so, please post the output from
Code: [Select]
lsusb
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline GokulDeepak

  • nOOb
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Wifi Disconnects Automatically
« Reply #8 on: October 04, 2016, 12:02:22 am »
Yes. It is a USB Wifi Adopter. Netgear WNA 1000M. Actually, the wifi never gets disconnected but only the network connection will. Wifi will be in connection but when we go to some url the error msg will say no internet connection available. It won't ping too. So Only the net connection is getting disconnected. At the same time I can use it in my mobile so no problem with my router/mobile.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Wifi Disconnects Automatically
« Reply #9 on: October 04, 2016, 12:46:20 am »
Yes. It is a USB Wifi Adopter. Netgear WNA 1000M. Actually, the wifi never gets disconnected but only the network connection will. Wifi will be in connection but when we go to some url the error msg will say no internet connection available. It won't ping too. So Only the net connection is getting disconnected. At the same time I can use it in my mobile so no problem with my router/mobile.
In your network manager, try setting IPv6 to Ignore.  If that alone doesn't work, try deleting the default ethernet connection.  With some people, (myself included :) ) systemd gets confused which setting to use at boot.  So it tries to use all of them and it doesn't work.  Trimming down the options, seems to clear things up  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25497
  • Karma: 2807
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Wifi Disconnects Automatically
« Reply #10 on: October 04, 2016, 07:33:07 am »
Are you ignoring requests for terminal output for a reason ? .. this is the second time I've had to prompt you for it again in this topic ???
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline ronaldo48a

  • nOOb
  • *
  • Posts: 11
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 9
Re: Wifi Disconnects Automatically
« Reply #11 on: August 10, 2018, 11:53:57 am »
I have the same problem. What should i do?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25497
  • Karma: 2807
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Wifi Disconnects Automatically
« Reply #12 on: August 10, 2018, 06:42:56 pm »
@ronaldo48a

Can you start your own new topic please, and include the output requested in this posting:
https://forum.peppermintos.com/index.php/topic,6713.0.html
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec