Author Topic: excessive audio tearing when using headphones.  (Read 1619 times)

Offline JimmyTango

  • Jr. Member
  • **
  • Posts: 31
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
excessive audio tearing when using headphones.
« on: September 28, 2016, 04:43:55 am »
If I'm using headphones (I tried 2 pairs - my Sony's with an angled jack and my wife's Sennheisers with a straight jack) to listen to music or watch videos, there is a degree of sound tearing, which becomes subtle (but is still there) if I reduce both the system and the application (or website) volumes to around 25-30-ish %. However, if I use VLC at same volumes (reduce VLC's volume controller as well), the tearing becomes even more apparent.

I went to the PulseAudio Volume control panel --> Configuration --> Profile --> and there are only 2 options that produce sound at all: Analog Stereo Output and Analog Stereo Duplex, but nothing changes if I switch between those, all the others are HDMI options and I have no sound if I switch to them.

I also tried the PulseAudio Equalizer, and using the "Headphones" option which helped a little - I can now have the same amount of tearing at slightly higher volumes, but it doesn't seem like a solution.

Not sure if I have this problem because I'm noob, or if this is a hardware/peripherals problem... Perhaps this thread should be moved to a different forum section, but it was hard for me to decide - my apologies.  :(

Code: [Select]
System:    Host: merlin Kernel: 4.4.0-38-generic x86_64 (64 bit) Desktop: N/A
           Distro: Peppermint Seven
Machine:   System: HP (portable) product: HP Pavilion Notebook v: Type1ProductConfigId
           Mobo: HP model: 820B v: 82.24 Bios: Insyde v: F.06 date: 05/05/2016
CPU:       Dual core Intel Core i5-6200U (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 2800 MHz 1: 713 MHz 2: 727 MHz 3: 709 MHz
           4: 796 MHz
Graphics:  Card: Intel Sky Lake Integrated Graphics
           Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           GLX Version: 3.0 Mesa 11.2.0
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-38-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169
           IF: eno1 state: down mac: <filter>
           Card-2: Intel Wireless 3165 driver: iwlwifi
           IF: wlo1 state: up mac: <filter>
Drives:    HDD Total Size: 256.1GB (48.6% used)
           ID-1: /dev/sda model: SanDisk_SD8SNAT size: 256.1GB
Partition: ID-1: / size: 227G used: 109G (51%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 8.47GB used: 0.08GB (1%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 38.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 196 Uptime: 3:51 Memory: 1227.6/7873.3MB
           Client: Shell (bash) inxi: 2.2.35

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
excessive audio tearing when using headphones.
« Reply #1 on: September 28, 2016, 04:43:55 am »
To help us help you, ALL new requests for technical support should include basic system information.

If you haven't already done so, please open a terminal (Ctrl+Alt+T) and run the following command:
Code: [Select]
inxi -Fzthen copy what was returned in the terminal and post it back here.

This was an automated response but please don't ignore it, providing this information now is highly likely to save time for both you and any prospective respondents and aid in the diagnosis of your problem  .. Thanks in advance :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline murraymint

  • Trusted User
  • Veteran
  • *****
  • Posts: 2165
  • Karma: 415
  • soft boiled with a yolk of gold
    • View Profile
  • Peppermint version(s): 7, 8, 9
Re: excessive audio tearing when using headphones.
« Reply #2 on: September 28, 2016, 04:56:25 am »
Assuming "sound tearing" means distortion, are you sure you're plugged into a headphone output and not a line/hi-fi one?

Offline JimmyTango

  • Jr. Member
  • **
  • Posts: 31
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: excessive audio tearing when using headphones.
« Reply #3 on: September 28, 2016, 05:08:35 am »
Yes, distortion, crackling, tearing, bits of white noise.

and yes, I'm pretty sure, since it's a laptop and it only has a single socket for a headphone jack, and there's also a "headphones" icon right next to it.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: excessive audio tearing when using headphones.
« Reply #4 on: September 28, 2016, 05:18:00 am »
Have you tried the low latency kernel ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline JimmyTango

  • Jr. Member
  • **
  • Posts: 31
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: excessive audio tearing when using headphones.
« Reply #5 on: September 28, 2016, 05:54:29 am »
the whatwhat? you mean Output devices --> advanced ---> latency (is set to 0). Should I change it to a different value? or did you mean something else?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: excessive audio tearing when using headphones.
« Reply #6 on: September 28, 2016, 06:55:18 am »
Run:
Code: [Select]
sudo apt-get install linux-image-lowlatencythen REBOOT.

You can check you're on the low latency kernel with:
Code: [Select]
uname -a
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline JimmyTango

  • Jr. Member
  • **
  • Posts: 31
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: excessive audio tearing when using headphones.
« Reply #7 on: September 28, 2016, 08:55:37 am »
The crackling is still there, unfortunately.

Code: [Select]
Linux merlin 4.4.0-38-lowlatency #57-Ubuntu SMP PREEMPT Tue Sep 6 16:59:03 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: excessive audio tearing when using headphones.
« Reply #8 on: September 28, 2016, 10:45:15 am »
Okay, before we go any further, let's undo that.

REBOOT.

And as soon as your BIOS post screen disappears, hit and hold the Shift key .. you should be presented with the GRUB menu.

At the GRUB menu, select the "Advanced" option and hit enter

at the next screen select the "4.4.0-38 generic" kernel and hit enter to boot.

Once booted, run;
Code: [Select]
uname -aand as long as the output mentions "generic" and NOT "lowlatency", run:
Code: [Select]
sudo apt-get remove --purge linux-image-lowlatency linux-image-4.4.0-38-lowlatencyNow REBOOT again.

Once rebooted, post the output from:
Code: [Select]
uname -a
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline JimmyTango

  • Jr. Member
  • **
  • Posts: 31
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: excessive audio tearing when using headphones.
« Reply #9 on: September 28, 2016, 12:40:34 pm »
Well here's a problem... My laptop goes from black screen (lit up, so it's not a delay of the screen lighting up) to login screen in 4 seconds flat, and there's nothing in between. Every other time I can see an underscore popping up in the top left corner for about 0.01 second, but that's it. I rebooted my machine like 25 times trying to press/hold or press+hold shift at any stage of the black screen/underscore, but nothing happens, it just keeps bringing me to the login screen.

(I played some quake3arena back in the day, even semi-pro, so I'm not that bad at hitting a button quickly, I should think)

Perhaps there's a different way/button to get me there?
I really appreciate you investing so much time into the issue.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: excessive audio tearing when using headphones.
« Reply #10 on: September 28, 2016, 12:49:47 pm »
There is a more in depth way, but it also needs to be undone later .. before we try that, turn OFF your PC .. Turn ON your PC, and immediately hit AND HOLD the "Shift" key.

Did it eventually display the GRUB menu ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline JimmyTango

  • Jr. Member
  • **
  • Posts: 31
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: excessive audio tearing when using headphones.
« Reply #11 on: September 28, 2016, 12:58:00 pm »
I gave it 10 tries with both love and hate, but it didn't work, unfortunately

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: excessive audio tearing when using headphones.
« Reply #12 on: September 28, 2016, 01:14:09 pm »
Okay, run:
Code: [Select]
sudo pluma /etc/default/grubfind the line

GRUB_HIDDEN_TIMEOUT=0

and change it to

GRUB_HIDDEN_TIMEOUT=-1

(that's minus one)

SAVE the file and exit pluma

Back in the terminal run:
Code: [Select]
sudo update-grubNow reboot .. and this time the GRUB menu should be displayed.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline JimmyTango

  • Jr. Member
  • **
  • Posts: 31
  • Karma: 2
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: excessive audio tearing when using headphones.
« Reply #13 on: September 28, 2016, 01:24:10 pm »
Great. It worked and I've deleted the lowlatency kernel. So now I assume I should switch the GRUB timeout back to 0.
What's up next?

Code: [Select]
Linux merlin 4.4.0-38-generic #57-Ubuntu SMP Tue Sep 6 15:42:33 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
« Last Edit: September 28, 2016, 01:27:41 pm by JimmyTango »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: excessive audio tearing when using headphones.
« Reply #14 on: September 28, 2016, 01:31:32 pm »
Yeah....

Okay, run:
Code: [Select]
sudo pluma /etc/default/grubfind the line

GRUB_HIDDEN_TIMEOUT=-1

and change it to

GRUB_HIDDEN_TIMEOUT=0

(that's zero)

SAVE the file and exit pluma

Back in the terminal run:
Code: [Select]
sudo update-grubNow reboot .. and this time the GRUB menu should NOT be displayed.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec