Choose style:

Author Topic: No sounds with built-in speakers, Toshiba NB500, Peppermint 7  (Read 2024 times)

0 Members and 1 Guest are viewing this topic.

Offline Spree

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 7
No sounds with built-in speakers, Toshiba NB500, Peppermint 7
« on: September 07, 2016, 03:17:19 pm »
Hello.

First of all, apologies for my lack of Linux/Peppermint knowledge - it is the first time I install any Linux version.

The issue is: my netbook (Toshiba NB500), with peppermint 7, can't reproduce any sounds with the built-in speakers.
Details:
- If I put earphones in, sound works. I just need to leave the "Built-in audio" drop down menu in the "configuration" tab of the audio mixer on "Analog stereo output" and select "headphones" in the "output" tab
- If I use a USB audio device (in my case a microphone/headset kit), with his drivers, then a second drop down menu appeard in the "configuration" tab. I then have to - as suggested here - put the "built-in audio" in the "configuration" tab on "off", and then I can set the second drop down menu to whatever needs to be and it works
- When nothing is plugged in, however, I only have 1 drop down menu in the "configuration" tab. If I leave it on "built-in audio", then I can switch between "speakers" or "headphones (unplugged)" in the "output" tab - but speakers don't work. If I put the drop down menu in the "configuration" tab on "off", in the output menu I only have "dummy output", and sound does not work.
- Note that in either case the bars of the souds are moving, which means the system recognizes the sounds - it's the speakers that cannot reproduce them.

It seems rather clear to me that there is a problem with the installation/recognition of the Realtek audio drivers of the netbook by the operating system.
Any Ideas on what I could try (explained, if possible, as if to a 5 year old)?

Thanks a lot!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25963
  • Karma: 2836
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: No sounds with built-in speakers, Toshiba NB500, Peppermint 7
« Reply #1 on: September 07, 2016, 03:34:54 pm »
Hi Spree, and welcome to the nuthouse forum :)

Can you post the output from:
Code: [Select]
aplay -l
and
Code: [Select]
inxi -F
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Spree

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 7
Re: No sounds with built-in speakers, Toshiba NB500, Peppermint 7
« Reply #2 on: September 07, 2016, 05:04:39 pm »
Thanks for the reply.

aplay -l gives me

Code: [Select]
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC259 Analog [ALC259 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

inxi -F gives

Code: [Select]
System:    Host: muletto Kernel: 4.4.0-36-generic x86_64 (64 bit) Desktop: N/A
           Distro: Peppermint Seven
Machine:   System: TOSHIBA product: TOSHIBA NB500 v: PLL50E-05300UIT
           Mobo: TOSHIBA model: PBU00 v: 1.00
           Bios: TOSHIBA v: V1.90 date: 06/02/2011
CPU:       Single core Intel Atom N455 (-HT-) cache: 512 KB
           clock speeds: max: 1667 MHz 1: 1667 MHz 2: 1667 MHz
Graphics:  Card: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
           Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1024x600@60.00hz
           GLX Renderer: Mesa DRI Intel Pineview M
           GLX Version: 1.4 Mesa 11.2.0
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-36-generic
Network:   Card-1: Realtek RTL8188CE 802.11b/g/n WiFi Adapter
           driver: rtl8192ce
           IF: wlp7s0 state: up mac: 74:de:2b:55:6d:93
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169
           IF: enp9s0 state: down mac: b8:70:f4:d4:5e:19
Drives:    HDD Total Size: 320.1GB (1.9% used)
           ID-1: /dev/sda model: TOSHIBA_MK3275GS size: 320.1GB
Partition: ID-1: / size: 293G used: 4.9G (2%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 1.06GB used: 0.01GB (1%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 56.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 159 Uptime: 6 min Memory: 576.6/982.2MB
           Client: Shell (bash) inxi: 2.2.35

Thanks again for your time!

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25963
  • Karma: 2836
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: No sounds with built-in speakers, Toshiba NB500, Peppermint 7
« Reply #3 on: September 07, 2016, 05:21:02 pm »
Does running
Code: [Select]
alsactl restore
make sound work through the speakers .. at least until the next boot ?



You could try running:
Code: [Select]
sudo pluma /etc/modprobe.d/alsa-base.conf
adding a new line at the very bottom that reads
Code: [Select]
options snd-hda-intel model=auto
SAVE the file and exit pluma

Then REBOOT to test
« Last Edit: September 07, 2016, 05:45:00 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Spree

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 7
Re: No sounds with built-in speakers, Toshiba NB500, Peppermint 7
« Reply #4 on: September 08, 2016, 12:24:54 pm »
Back from work, I managed to test. Results:

Code: [Select]
alsactl restore

gives result
Code: [Select]
alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: File exists
alsactl: load_state:1683: Cannot open /var/lib/alsa/asound.state for reading: File exists
Found hardware: "HDA-Intel" "Realtek ALC259" "HDA:10ec0269,1179fdc6,00100100" "0x1179" "0xfdc0"
Hardware is initialized using a generic method

and does indeed restore audio via the built-in speakers.
This audio is however lost upon reboot.

I therefore tried running (both after reboot - therefore with no sounds, and after having run "alsactl restore" but before reeboting - therefore with sound)
Code: [Select]
sudo pluma /etc/modprobe.d/alsa-base.conf

This opens the pluma file that reads

Quote
"# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2"

at the very bottom, I added
Code: [Select]
options snd-hda-intel model=auto

Saved and closed.
This - as I think is to be expected - changed nothing immediately (when done without workin audio did not activate it, when done after "alsactl restore" - therefore with audio - did not deactivate it).

Unfortunately, upon reboot audio is still gone.
Running
Code: [Select]
 alsactl restore 
makes it reappear again, but again upon reboot audio is gone regardless of the pluma file.

Thanks again.

« Last Edit: September 08, 2016, 02:28:31 pm by AndyInMokum, Reason: Encapsulating output with [text] »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25963
  • Karma: 2836
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: No sounds with built-in speakers, Toshiba NB500, Peppermint 7
« Reply #5 on: September 08, 2016, 01:45:16 pm »
Try changing the line you added from
Code: [Select]
options snd-hda-intel model=auto
to
Code: [Select]
options snd-hda-intel model=generic
and rebooting to test.

Any difference ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Spree

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 7
Re: No sounds with built-in speakers, Toshiba NB500, Peppermint 7
« Reply #6 on: September 08, 2016, 03:19:10 pm »
Not really - still no sound after reboot.

Another detail I noticed - and I don't know if this is relevant or not - is that after
Code: [Select]
alsactl restore
the built in speakers work. However, if I plug in headphones (which still work) and the plug them off, the built in speakers have in the meantime stopped working (unless I type the restore code again in the terminal)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25963
  • Karma: 2836
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: No sounds with built-in speakers, Toshiba NB500, Peppermint 7
« Reply #7 on: September 08, 2016, 07:25:05 pm »
Okay there's a couple of things we can try here

a) experiment with some more driver options such as pin assignments

or

b) simply apply the dirty workaround that we had to use here:
https://forum.peppermintos.com/index.php/topic,3797.0.html

which would you like to do ?
« Last Edit: September 08, 2016, 07:26:38 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec