Choose style:

Author Topic: Fail message at boot.  (Read 2760 times)

0 Members and 1 Guest are viewing this topic.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Fail message at boot.
« on: September 03, 2016, 07:33:00 pm »
Hi all, my machine again froze after waking from: Suspend.  I was required to do a hard shutdown.  On reboot, instead of receiving the usual fsck clear message.  I'm now getting a longer message with a red Fail in parentheses.  Unfortunately, I can't read the message because the SSD has made the boot time too damn quick.  I've changed from the Xfce4 Power Manager to the Mate Power Manager.  That has slowed down the frequency of the freezes considerably. 

I'm multi-booting, so I've booted into SparkyLinux to run any repairs.   Here's a list of my partitions:
Code: [Select]
andy@sparky-dell-latitude:~$ sudo parted /dev/sda 'print'
[sudo] password for andy:
Model: ATA KINGSTON SV300S3 (scsi)
Disk /dev/sda: 120GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type      File system  Flags
 1      3145kB  120GB   120GB   extended               boot
 5      3146kB  21.5GB  21.5GB  logical   ext4
 6      21.5GB  40.8GB  19.3GB  logical   ext4
 7      40.8GB  62.3GB  21.5GB  logical   ext4
 8      62.3GB  81.6GB  19.3GB  logical   ext4
 9      81.6GB  103GB   21.5GB  logical   ext4
10      103GB   120GB   16.9GB  logical   ext4

andy@sparky-dell-latitude:~$
and
Code: [Select]
andy@sparky-dell-latitude:~$ sudo parted /dev/sdb 'print'
Model: ATA WDC WD10JPVX-60J (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type     File system     Flags
 1      1049kB  992GB   992GB   primary  ext4
 2      992GB   1000GB  8589MB  primary  linux-swap(v1)

andy@sparky-dell-latitude:~$
[bPeppermint 7[/b] is on: /dev/sda9 and /dev/sda10.   The partitions of the second hard drive are a shared /DATA partition and a swap space.  I've run:
Code: [Select]
sudo fsck -M /dev/sda9
Code: [Select]
sudo fsck -M /dev/sda10
and
Code: [Select]
sudo fsck -M /dev/sdb1
They all check out fine.
Code: [Select]
andy@sparky-dell-latitude:~$ sudo fsck -M /dev/sda9
fsck from util-linux 2.28.1
e2fsck 1.43.1 (08-Jun-2016)
PM7/: clean, 358059/1310720 files, 2087535/5242880 blocks
andy@sparky-dell-latitude:~$
and
Code: [Select]
ndy@sparky-dell-latitude:~$ sudo fsck -M /dev/sda10
fsck from util-linux 2.28.1
e2fsck 1.43.1 (08-Jun-2016)
PM7/home: clean, 65122/1036320 files, 1912738/4137472 blocks
andy@sparky-dell-latitude:~$
and
Code: [Select]
andy@sparky-dell-latitude:~$ sudo fsck -M /dev/sdb1
[sudo] password for andy:
fsck from util-linux 2.28.1
e2fsck 1.43.1 (08-Jun-2016)
/DATA: clean, 144171/60530688 files, 71270819/242093312 blocks (check in 5 mounts)
andy@sparky-dell-latitude:~$
When I boot into Peppermint 7, it appears to be running fine.  I can't figure out what's causing the Fail alert  :-\.  These random freezes are driving me crazy  >:(.  Where can I find the boot log?  Maybe that'll shed some light on what's happening  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5443
  • Karma: 957
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Fail message at boot.
« Reply #1 on: September 03, 2016, 07:45:57 pm »
Where can I find the boot log?  Maybe that'll shed some light on what's happening  ;).

Code: [Select]
╭─vindsl@Boogaloo-5 ~  
╰─➤  journalctl 

That will give you everything.

There are filters, too.  Hit Ctrl-Home to see the commands.   ;)

EDIT

This might be more useful to you ...

Code: [Select]
╭─vindsl@Boogaloo-5 ~  
╰─➤  journalctl -b0 --system _COMM=systemd


« Last Edit: September 03, 2016, 07:49:38 pm by VinDSL, Reason: Addendum »

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Fail message at boot.
« Reply #2 on: September 03, 2016, 08:00:39 pm »
Where can I find the boot log?  Maybe that'll shed some light on what's happening  ;).

Code: [Select]
╭─vindsl@Boogaloo-5 ~  
╰─➤  journalctl 

That will give you everything.

There are filters, too.  Hit Ctrl-Home to see the commands.   ;)

EDIT

This might be more useful to you ...

Code: [Select]
╭─vindsl@Boogaloo-5 ~  
╰─➤  journalctl -b0 --system _COMM=systemd
Thanks John, I'll give that a whirl when I boot back into PM7.  I wish I could get to the bottom of this hard freezing.  I wouldn't have these issues if I could fix it.  It's the only problem I have with PM7, apart from it booting too quick to readerror/fail messages  ;D.
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5443
  • Karma: 957
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Fail message at boot.
« Reply #3 on: September 03, 2016, 08:38:05 pm »
Happy hunting !   ;)

Offline emegra

  • Global Moderator
  • Veteran
  • *****
  • Posts: 1916
  • Karma: 415
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64bit
Re: Fail message at boot.
« Reply #4 on: September 04, 2016, 01:24:46 am »
Hi Andy

Would /var/log/boot.log perhaps shed any light on it ?



Graeme
If you can keep your head while all around are losing theirs then you're not quite grasping the situation

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Fail message at boot.
« Reply #5 on: September 04, 2016, 01:47:43 am »
Found the little rascal:
Code: [Select]
[  OK  ] Started Create Volatile Files and Directories.
[FAILED] Failed to start LSB: AppArmor initialization.
See 'systemctl status apparmor.service' for details.
I don't think it's anything very important.  I'd like to clear it up though, if possible.  Any help is much appreciated  ;).

Many thanks to both VinDSL and Emegra for their assistance  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline emegra

  • Global Moderator
  • Veteran
  • *****
  • Posts: 1916
  • Karma: 415
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64bit
Re: Fail message at boot.
« Reply #6 on: September 04, 2016, 02:25:56 am »
Have you run in the terminal
Code: [Select]
systemctl status apparmor.service

any clues there ?




Graeme
If you can keep your head while all around are losing theirs then you're not quite grasping the situation

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Fail message at boot.
« Reply #7 on: September 04, 2016, 02:47:49 am »
Have you run in the terminal
Code: [Select]
systemctl status apparmor.service

any clues there ?




Graeme
That looks fine:
Code: [Select]
andy@andy-Latitude-PM7 ~ $ systemctl status apparmor.service
● apparmor.service - LSB: AppArmor initialization
   Loaded: loaded (/etc/init.d/apparmor; bad; vendor preset: enabled)
   Active: active (exited) since zo 2016-09-04 08:24:44 CEST; 4min 54s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 2414 ExecStart=/etc/init.d/apparmor start (code=exited, status=0/SUCCESS)

sep 04 08:24:41 andy-Latitude-PM7 systemd[1]: Starting LSB: AppArmor initialization...
sep 04 08:24:41 andy-Latitude-PM7 apparmor[2414]:  * Starting AppArmor profiles
sep 04 08:24:41 andy-Latitude-PM7 apparmor[2414]: Skipping profile in /etc/apparmor.d/di
sep 04 08:24:41 andy-Latitude-PM7 apparmor[2414]: Skipping profile in /etc/apparmor.d/di
sep 04 08:24:44 andy-Latitude-PM7 apparmor[2414]:    ...done.
sep 04 08:24:44 andy-Latitude-PM7 systemd[1]: Started LSB: AppArmor initialization.
Tried rebooting again and the nano second Fail message is still there.  Also the Fail message is back at boot.  There's no record of it in the, /var/log/boot.log file:

Spoiler (click here to view / hide)
[  OK  ] Started Show Plymouth Boot Screen.
[  OK  ] Started Forward Password Requests to Plymouth Directory Watch.
[  OK  ] Created slice system-systemd\x2dbacklight.slice.
         Starting Load/Save Screen Backlight Brightness of backlight:acpi_video0...
[  OK  ] Started Load/Save Screen Backlight Brightness of backlight:acpi_video0.
         Starting Load/Save Screen Backlight Brightness of backlight:intel_backlight...
[  OK  ] Found device KINGSTON_SV300S37A120G PM7/home.
         Starting File System Check on /dev/disk/by-uuid/63073424-260d-45b5-b2c6-a7e9a88ce396...
[  OK  ] Started File System Check Daemon to report status.
[  OK  ] Started File System Check on /dev/disk/by-uuid/63073424-260d-45b5-b2c6-a7e9a88ce396.
         Mounting /home...
[  OK  ] Mounted /home.
[  OK  ] Listening on Load/Save RF Kill Switch Status /dev/rfkill Watch.
         Starting Load/Save RF Kill Switch Status...
[  OK  ] Started Load/Save Screen Backlight Brightness of backlight:intel_backlight.
[  OK  ] Reached target Sound Card.
[  OK  ] Started Load/Save RF Kill Switch Status.
         Starting Load/Save Screen Backlight Brightness of leds:dell::kbd_backlight...
[  OK  ] Started Load/Save Screen Backlight Brightness of leds:dell::kbd_backlight.
[  OK  ] Found device WDC_WD10JPVX-60JC3T0 2.
         Activating swap /dev/disk/by-uuid/50dbb1b9-5dc0-4e1a-ba37-db6336f41130...
[  OK  ] Activated swap /dev/disk/by-uuid/50dbb1b9-5dc0-4e1a-ba37-db6336f41130.
[  OK  ] Reached target Swap.
[  OK  ] Found device WDC_WD10JPVX-60JC3T0 /DATA.
         Starting File System Check on /dev/disk/by-uuid/8a9f41c5-fd91-4895-83df-67207ebe3970...
[  OK  ] Started File System Check on /dev/disk/by-uuid/8a9f41c5-fd91-4895-83df-67207ebe3970.
         Mounting /mnt/DATA...
[  OK  ] Mounted /mnt/DATA.
[  OK  ] Reached target Local File Systems.
         Starting Create Volatile Files and Directories...
         Starting Clean up any mess left by 0dns-up...
         Starting Enable support for additional executable binary formats...
         Starting LSB: ebtables ruleset management...
         Starting Set console font and keymap...
         Starting LSB: AppArmor initialization...
         Starting Tell Plymouth To Write Out Runtime Data...
[  OK  ] Started Create Volatile Files and Directories.
[  OK  ] Started Clean up any mess left by 0dns-up.
         Starting Nameserver information manager...
         Mounting Arbitrary Executable File Formats File System...
         Starting Update UTMP about System Boot/Shutdown...
[  OK  ] Reached target System Time Synchronized.
[  OK  ] Started Nameserver information manager.
[  OK  ] Mounted Arbitrary Executable File Formats File System.
[  OK  ] Started Enable support for additional executable binary formats.
[  OK  ] Started Update UTMP about System Boot/Shutdown.
[  OK  ] Started Set console font and keymap.
[  OK  ] Created slice system-getty.slice.
[  OK  ] Started Tell Plymouth To Write Out Runtime Data.
[  OK  ] Started LSB: ebtables ruleset management.
[  OK  ] Started LSB: AppArmor initialization.
         Starting Raise network interfaces...
[  OK  ] Reached target System Initialization.
[  OK  ] Started Trigger resolvconf update for networkd DNS.
[  OK  ] Listening on UUID daemon activation socket.
[  OK  ] Listening on Avahi mDNS/DNS-SD Stack Activation Socket.
[  OK  ] Listening on CUPS Scheduler.
[  OK  ] Started CUPS Scheduler.
[  OK  ] Listening on D-Bus System Message Bus Socket.
[  OK  ] Started Daily Cleanup of Temporary Directories.
[  OK  ] Started Daily apt activities.
[  OK  ] Reached target Timers.
[  OK  ] Listening on ACPID Listen Socket.
[  OK  ] Reached target Sockets.
[  OK  ] Started ACPI Events Check.
[  OK  ] Reached target Paths.
[  OK  ] Reached target Basic System.
         Starting Login Service...
[  OK  ] Started CUPS Scheduler.
[  OK  ] Started D-Bus System Message Bus.
         Starting Accounts Service...
         Starting Save/Restore Sound Card State...
[  OK  ] Started Regular background program processing daemon.
         Starting Avahi mDNS/DNS-SD Stack...
         Starting Modem Manager...
         Starting LSB: Set the CPU Frequency Scaling governor to "ondemand"...
         Starting LSB: daemon to balance interrupts for SMP systems...
         Starting mintsystem.service...
         Starting LSB: Record successful boot for GRUB...
[  OK  ] Started Run anacron jobs.
         Starting Permit User Sessions...
         Starting System Logging Service...
         Starting Restore /etc/resolv.conf if the system crashed before the ppp link was shut down...
[  OK  ] Started ACPI event daemon.
         Starting Console System Startup Logging...
         Starting Initialize hardware monitoring sensors...
         Starting Detect the available GPUs and deal with any system changes...
         Starting Network Manager...
[  OK  ] Started System Logging Service.
[  OK  ] Started Permit User Sessions.
[  OK  ] Started Restore /etc/resolv.conf if the system crashed before the ppp link was shut down.
[  OK  ] Started Console System Startup Logging.
[  OK  ] Started Initialize hardware monitoring sensors.
[  OK  ] Started Save/Restore Sound Card State.
[  OK  ] Started LSB: Set the CPU Frequency Scaling governor to "ondemand".
[  OK  ] Started LSB: daemon to balance interrupts for SMP systems.
[  OK  ] Started LSB: Record successful boot for GRUB.
[  OK  ] Started Avahi mDNS/DNS-SD Stack.
[  OK  ] Started Network Manager.
[  OK  ] Started Login Service.
         Starting Network Manager Script Dispatcher Service...
         Starting Network Manager Wait Online...
         Starting Authenticate and Authorize Users to Run Privileged Tasks...
[  OK  ] Started Make remote CUPS printers available locally.
[  OK  ] Started Authenticate and Authorize Users to Run Privileged Tasks.
[  OK  ] Started Network Manager Script Dispatcher Service.
[  OK  ] Started Raise network interfaces.
[  OK  ] Reached target Network.
         Starting OpenBSD Secure Shell server...
         Starting OpenVPN service...
[  OK  ] Started OpenVPN service.
[  OK  ] Started Accounts Service.
[  OK  ] Started Modem Manager.
[  OK  ] Stopped LSB: Start NTP daemon.
[  OK  ] Started OpenBSD Secure Shell server.
[  OK  ] Started mintsystem.service.
[  OK  ] Started Detect the available GPUs and deal with any system changes.
         Starting Light Display Manager...
         Starting LSB: Start NTP daemon...
[close]

I'm now officially baffled  :-\.
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Fail message at boot.
« Reply #8 on: September 04, 2016, 03:38:36 am »
Have you run in the terminal
Code: [Select]
systemctl status apparmor.service

any clues there ?




Graeme
That looks fine:
Code: [Select]
andy@andy-Latitude-PM7 ~ $ systemctl status apparmor.service
● apparmor.service - LSB: AppArmor initialization
   Loaded: loaded (/etc/init.d/apparmor; bad; vendor preset: enabled)
   Active: active (exited) since zo 2016-09-04 08:24:44 CEST; 4min 54s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 2414 ExecStart=/etc/init.d/apparmor start (code=exited, status=0/SUCCESS)

sep 04 08:24:41 andy-Latitude-PM7 systemd[1]: Starting LSB: AppArmor initialization...
sep 04 08:24:41 andy-Latitude-PM7 apparmor[2414]:  * Starting AppArmor profiles
sep 04 08:24:41 andy-Latitude-PM7 apparmor[2414]: Skipping profile in /etc/apparmor.d/di
sep 04 08:24:41 andy-Latitude-PM7 apparmor[2414]: Skipping profile in /etc/apparmor.d/di
sep 04 08:24:44 andy-Latitude-PM7 apparmor[2414]:    ...done.
sep 04 08:24:44 andy-Latitude-PM7 systemd[1]: Started LSB: AppArmor initialization.
Tried rebooting again and the nano second Fail message is still there.  Also the Fail message is back at boot.  There's no record of it in the, /var/log/boot.log file:

Spoiler (click here to view / hide)
[  OK  ] Started Show Plymouth Boot Screen.
[  OK  ] Started Forward Password Requests to Plymouth Directory Watch.
[  OK  ] Created slice system-systemd\x2dbacklight.slice.
         Starting Load/Save Screen Backlight Brightness of backlight:acpi_video0...
[  OK  ] Started Load/Save Screen Backlight Brightness of backlight:acpi_video0.
         Starting Load/Save Screen Backlight Brightness of backlight:intel_backlight...
[  OK  ] Found device KINGSTON_SV300S37A120G PM7/home.
         Starting File System Check on /dev/disk/by-uuid/63073424-260d-45b5-b2c6-a7e9a88ce396...
[  OK  ] Started File System Check Daemon to report status.
[  OK  ] Started File System Check on /dev/disk/by-uuid/63073424-260d-45b5-b2c6-a7e9a88ce396.
         Mounting /home...
[  OK  ] Mounted /home.
[  OK  ] Listening on Load/Save RF Kill Switch Status /dev/rfkill Watch.
         Starting Load/Save RF Kill Switch Status...
[  OK  ] Started Load/Save Screen Backlight Brightness of backlight:intel_backlight.
[  OK  ] Reached target Sound Card.
[  OK  ] Started Load/Save RF Kill Switch Status.
         Starting Load/Save Screen Backlight Brightness of leds:dell::kbd_backlight...
[  OK  ] Started Load/Save Screen Backlight Brightness of leds:dell::kbd_backlight.
[  OK  ] Found device WDC_WD10JPVX-60JC3T0 2.
         Activating swap /dev/disk/by-uuid/50dbb1b9-5dc0-4e1a-ba37-db6336f41130...
[  OK  ] Activated swap /dev/disk/by-uuid/50dbb1b9-5dc0-4e1a-ba37-db6336f41130.
[  OK  ] Reached target Swap.
[  OK  ] Found device WDC_WD10JPVX-60JC3T0 /DATA.
         Starting File System Check on /dev/disk/by-uuid/8a9f41c5-fd91-4895-83df-67207ebe3970...
[  OK  ] Started File System Check on /dev/disk/by-uuid/8a9f41c5-fd91-4895-83df-67207ebe3970.
         Mounting /mnt/DATA...
[  OK  ] Mounted /mnt/DATA.
[  OK  ] Reached target Local File Systems.
         Starting Create Volatile Files and Directories...
         Starting Clean up any mess left by 0dns-up...
         Starting Enable support for additional executable binary formats...
         Starting LSB: ebtables ruleset management...
         Starting Set console font and keymap...
         Starting LSB: AppArmor initialization...
         Starting Tell Plymouth To Write Out Runtime Data...
[  OK  ] Started Create Volatile Files and Directories.
[  OK  ] Started Clean up any mess left by 0dns-up.
         Starting Nameserver information manager...
         Mounting Arbitrary Executable File Formats File System...
         Starting Update UTMP about System Boot/Shutdown...
[  OK  ] Reached target System Time Synchronized.
[  OK  ] Started Nameserver information manager.
[  OK  ] Mounted Arbitrary Executable File Formats File System.
[  OK  ] Started Enable support for additional executable binary formats.
[  OK  ] Started Update UTMP about System Boot/Shutdown.
[  OK  ] Started Set console font and keymap.
[  OK  ] Created slice system-getty.slice.
[  OK  ] Started Tell Plymouth To Write Out Runtime Data.
[  OK  ] Started LSB: ebtables ruleset management.
[  OK  ] Started LSB: AppArmor initialization.
         Starting Raise network interfaces...
[  OK  ] Reached target System Initialization.
[  OK  ] Started Trigger resolvconf update for networkd DNS.
[  OK  ] Listening on UUID daemon activation socket.
[  OK  ] Listening on Avahi mDNS/DNS-SD Stack Activation Socket.
[  OK  ] Listening on CUPS Scheduler.
[  OK  ] Started CUPS Scheduler.
[  OK  ] Listening on D-Bus System Message Bus Socket.
[  OK  ] Started Daily Cleanup of Temporary Directories.
[  OK  ] Started Daily apt activities.
[  OK  ] Reached target Timers.
[  OK  ] Listening on ACPID Listen Socket.
[  OK  ] Reached target Sockets.
[  OK  ] Started ACPI Events Check.
[  OK  ] Reached target Paths.
[  OK  ] Reached target Basic System.
         Starting Login Service...
[  OK  ] Started CUPS Scheduler.
[  OK  ] Started D-Bus System Message Bus.
         Starting Accounts Service...
         Starting Save/Restore Sound Card State...
[  OK  ] Started Regular background program processing daemon.
         Starting Avahi mDNS/DNS-SD Stack...
         Starting Modem Manager...
         Starting LSB: Set the CPU Frequency Scaling governor to "ondemand"...
         Starting LSB: daemon to balance interrupts for SMP systems...
         Starting mintsystem.service...
         Starting LSB: Record successful boot for GRUB...
[  OK  ] Started Run anacron jobs.
         Starting Permit User Sessions...
         Starting System Logging Service...
         Starting Restore /etc/resolv.conf if the system crashed before the ppp link was shut down...
[  OK  ] Started ACPI event daemon.
         Starting Console System Startup Logging...
         Starting Initialize hardware monitoring sensors...
         Starting Detect the available GPUs and deal with any system changes...
         Starting Network Manager...
[  OK  ] Started System Logging Service.
[  OK  ] Started Permit User Sessions.
[  OK  ] Started Restore /etc/resolv.conf if the system crashed before the ppp link was shut down.
[  OK  ] Started Console System Startup Logging.
[  OK  ] Started Initialize hardware monitoring sensors.
[  OK  ] Started Save/Restore Sound Card State.
[  OK  ] Started LSB: Set the CPU Frequency Scaling governor to "ondemand".
[  OK  ] Started LSB: daemon to balance interrupts for SMP systems.
[  OK  ] Started LSB: Record successful boot for GRUB.
[  OK  ] Started Avahi mDNS/DNS-SD Stack.
[  OK  ] Started Network Manager.
[  OK  ] Started Login Service.
         Starting Network Manager Script Dispatcher Service...
         Starting Network Manager Wait Online...
         Starting Authenticate and Authorize Users to Run Privileged Tasks...
[  OK  ] Started Make remote CUPS printers available locally.
[  OK  ] Started Authenticate and Authorize Users to Run Privileged Tasks.
[  OK  ] Started Network Manager Script Dispatcher Service.
[  OK  ] Started Raise network interfaces.
[  OK  ] Reached target Network.
         Starting OpenBSD Secure Shell server...
         Starting OpenVPN service...
[  OK  ] Started OpenVPN service.
[  OK  ] Started Accounts Service.
[  OK  ] Started Modem Manager.
[  OK  ] Stopped LSB: Start NTP daemon.
[  OK  ] Started OpenBSD Secure Shell server.
[  OK  ] Started mintsystem.service.
[  OK  ] Started Detect the available GPUs and deal with any system changes.
         Starting Light Display Manager...
         Starting LSB: Start NTP daemon...
[close]

I'm now officially baffled  :-\.
More progress.  It's systemd thing, (naturally  >:().
Code: [Select]
Failed to start LSB: QEMU KVM module loading script.
I've disabled the qemu with:
Code: [Select]
systemctl disable qemu-kvm
The fail messages have now disappeared at boot and shutdown/reboot.  Is it safe to completely remove this metapackage and is it recommended.  I see there are security concerns associated with it - many thanks  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline emegra

  • Global Moderator
  • Veteran
  • *****
  • Posts: 1916
  • Karma: 415
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint 9 64bit
Re: Fail message at boot.
« Reply #9 on: September 04, 2016, 04:12:58 am »
Just out of curiosity have you tried this booting with another kernel ?





Graeme
If you can keep your head while all around are losing theirs then you're not quite grasping the situation

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Fail message at boot.
« Reply #10 on: September 04, 2016, 04:40:43 am »
Just out of curiosity have you tried this booting with another kernel ?





Graeme
The system freezing happen in every kernel I've tried.  It was happening while we were beta testing too.  I haven't tried the 4.7.2 kernel.  I could give that a go.  I don't expect much though.  The initial thought was a failing memory card.  I've run a couple of system diagnostic from the BIOS.  The memory cards checked out each time.  I've the Intel microcode running.  So the CPU firmware is up to date and optimized for Linux.  The system freezes were MUCH worse with the Xfce4 Power Manager.  I could just about guarantee the system would freeze coming out of suspend and hibernate.  While the Mate Power Manager  is a long way from perfect with applying settings.  It's still light years ahead of the Xfce4 Power Manager on this machine.  The system freezes are really sporadic.  I can't see any fixed pattern.  This is what's making the issue so annoying and difficult to diagnose.
« Last Edit: September 04, 2016, 04:46:44 am by AndyInMokum »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3136
  • Karma: 567
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Fail message at boot.
« Reply #11 on: September 04, 2016, 05:17:32 am »
Seeing all these problems - I am so happy I just shut my laptop down when not in use.  It only take a min or two to reboot anyway :)

Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P10 x64 Desktop - AMD Threadrippe 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 1 x 43" 1 x 27" 4k 3840x2160 - 1 x 34" 5120x2160
P10 x64 Laptop - i7-7700HQ - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Fail message at boot.
« Reply #12 on: September 04, 2016, 05:24:08 am »
Seeing all these problems - I am so happy I just shut my laptop down when not in use.  It only take a min or two to reboot anyway :)

Regards Zeb...
I know what you mean.  I'm just a stubon old goat, who thinks because it's there, it should work.  If it doesn't, I want to know why  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26280
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Fail message at boot.
« Reply #13 on: September 04, 2016, 05:29:08 am »
well qemu-kvm isn't installed by default on my machine so I'd guess it should be safe to remove depending on what added it in the first place .. just FYI here's what installing it on my system would pull in:-

Quote
  cpu-checker ipxe-qemu libboost-random1.58.0 libboost-thread1.58.0
  libbrlapi0.6 libcacard0 libfdt1 libiscsi2 librados2 librbd1 libspice-server1
  libusbredirparser1 libxen-4.6 libxenstore3.0 msr-tools qemu-block-extra
  qemu-kvm qemu-system-common qemu-system-x86 qemu-utils seabios sharutils

So if I were you I'd run a simulated purge
Code: [Select]
sudo apt-get remove --purge -s qemu-kvm
and see what it says will be removed .. you should then be able to figure out what pulled it in in the first place.

You could also purge apparmor and check if that helps .. you can always add it back later if you wish
Code: [Select]
sudo apt-get remove --purge apparmor apparmor-notify
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Fail message at boot.
« Reply #14 on: September 04, 2016, 08:03:42 am »
well qemu-kvm isn't installed by default on my machine so I'd guess it should be safe to remove depending on what added it in the first place .. just FYI here's what installing it on my system would pull in:-

Quote
  cpu-checker ipxe-qemu libboost-random1.58.0 libboost-thread1.58.0
  libbrlapi0.6 libcacard0 libfdt1 libiscsi2 librados2 librbd1 libspice-server1
  libusbredirparser1 libxen-4.6 libxenstore3.0 msr-tools qemu-block-extra
  qemu-kvm qemu-system-common qemu-system-x86 qemu-utils seabios sharutils

So if I were you I'd run a simulated purge
Code: [Select]
sudo apt-get remove --purge -s qemu-kvm
and see what it says will be removed .. you should then be able to figure out what pulled it in in the first place.

You could also purge apparmor and check if that helps .. you can always add it back later if you wish
Code: [Select]
sudo apt-get remove --purge apparmor apparmor-notify
Cheers, I'll try this a little later on today  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.