Choose style:

Author Topic: Need help with Wifi  (Read 3767 times)

0 Members and 1 Guest are viewing this topic.

Offline aroute

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
Need help with Wifi
« on: May 30, 2014, 04:34:53 pm »
Please help me connect my Wifi. I have done a fresh install from a CD I have had for a while. My PeppermintOS may not be latest (it is PeppermintICE from the CD I burnt in 2011). However, I have updated the system and waiting to get some help on Wifi setup for the first time.

I have a Linksys PCMCIA card WPC54G Version 2. My Wifi router is Linksys E1000 with WPA/WPA2 Mixed Mode.

Here's the info you need.

Spoiler (click here to view / hide)
sudo lshw -C network
[sudo] password for user:
  *-network               
       description: Ethernet interface
       product: 82557/8/9/0/1 Ethernet Pro 100
       vendor: Intel Corporation
       physical id: 4
       bus info: pci@0000:02:04.0
       logical name: eth0
       version: 09
       serial: 00:d0:59:c6:97:66
       size: 100MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.24-k2-NAPI duplex=full firmware=N/A ip=192.168.1.109 latency=66 link=yes maxlatency=56 mingnt=8 multicast=yes port=MII speed=100MB/s
       resources: irq:5 memory:40200000-40200fff ioport:2000(size=64) memory:40000000-4001ffff
  *-network UNCLAIMED
       description: Network controller
       product: ACX 111 54Mbps Wireless Interface
       vendor: Texas Instruments
       physical id: 3
       bus info: pci@0000:03:00.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm cap_list
       configuration: latency=0
       resources: memory:28020000-28021fff memory:28000000-2801ffff
[close]

Offline rjm65

  • Veteran
  • ****
  • Posts: 1003
  • Karma: 300
  • I have Peppermint Fresh Breath. :P
    • View Profile
  • Peppermint version(s): Win-98 /Win-7/ Peppermint 9
Re: Need help with Wifi
« Reply #1 on: May 30, 2014, 05:35:12 pm »

I have a Linksys PCMCIA card WPC54G Version 2. My Wifi router is Linksys E1000 with WPA/WPA2 Mixed Mode.
I have that same card in an ibm laptop and it works fine using peppermint 3, I would hazard a guess maybe your old version the driver was not available back then...
peppermint 3 or 4 should work with that card and if you can wait a bit longer peppermint 5 is due out soon and will be an LTS release...
Robert
Peppermint 9 User

Gateway Solo 9300 Pro
IBM T40

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Need help with Wifi
« Reply #2 on: May 30, 2014, 05:40:09 pm »
OK, bit of a long shot here, but try this...

(with a wired connection) open a terminal and run these commands in sequence:
Code: [Select]
cd /lib/firmware/ti-connectivity
then
Code: [Select]
sudo wget https://dl.dropboxusercontent.com/u/11876059/wl1251-fw.bin
then
Code: [Select]
sudo modprobe wl1251_sdio
did wireless spring to life ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline aroute

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
Re: Need help with Wifi
« Reply #3 on: May 30, 2014, 05:55:37 pm »
I managed to go little further with instructions on ndiswrapper. I can see my Wifi router, my PCMCIA card appears to be working as well. However, from the list of security protocols available to connect to the router, I see WEP, LEAP etc, but I don't see WPA. My router has WPA security.  How do I get the drop-down list of connection box to show me WPA security?

Offline aroute

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
Re: Need help with Wifi
« Reply #4 on: May 30, 2014, 06:06:38 pm »
I can set the WEP in the connection properties of network applet itself, but when I click my wifi network to connect, it asks me for Authentication. The drop-down box does not show me WPA, instead it only shows WEP 40/ WEP 128 LEAP and Dynamic LEAP.


Offline aroute

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
Re: Need help with Wifi
« Reply #5 on: May 30, 2014, 06:08:01 pm »
Hi, I could only run the command you have in the middle (wget).

OK, bit of a long shot here, but try this...

(with a wired connection) open a terminal and run these commands in sequence:
Code: [Select]
cd /lib/firmware/ti-connectivity
then
Code: [Select]
sudo wget https://dl.dropboxusercontent.com/u/11876059/wl1251-fw.bin
then
Code: [Select]
sudo modprobe wl1251_sdio
did wireless spring to life ?

Offline rjm65

  • Veteran
  • ****
  • Posts: 1003
  • Karma: 300
  • I have Peppermint Fresh Breath. :P
    • View Profile
  • Peppermint version(s): Win-98 /Win-7/ Peppermint 9
Re: Need help with Wifi
« Reply #6 on: May 30, 2014, 07:01:09 pm »
The one i set up was working fine but the people I set it up for were only using wep security so it may not be capable of wpa, pcnetspec will figure it out for you just do what he is telling you to do and it should work...
Robert
Peppermint 9 User

Gateway Solo 9300 Pro
IBM T40

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Need help with Wifi
« Reply #7 on: May 30, 2014, 08:45:25 pm »
There's a VERY good chance the adapter doesn't support WPA/WPA2 .. it was made before WPA became an accepted standard.

If you want to stick with WPA/WPA2 you'll need a more recent adapter.

your other option is to change your router to WEP .. this will entaill you having to change the settings on ALL connected devices.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline aroute

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
Re: Need help with Wifi
« Reply #8 on: June 02, 2014, 04:45:33 pm »
Folks, thanks for your help. I have decided to abandon this idea of using this old Linksys wifi card. I will attempt to use the TP-LINK N150 Wireless Nano USB Adapter (which should be arriving soon). Hopefully I won't run into these issues as the reviews of this card suggest that it is Linux plug and play.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Need help with Wifi
« Reply #9 on: June 02, 2014, 05:12:12 pm »
OK, thanks for the update .. if you get the TP-Link adapter to work, can you please mark this topic as (ABANDONED)

Thanks in advance :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec