Choose style:

Author Topic: Problems with touchpad... (SOLVED)  (Read 638 times)

0 Members and 1 Guest are viewing this topic.

Offline grioghair

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Problems with touchpad... (SOLVED)
« on: August 18, 2016, 05:43:58 pm »
I have just installed Peppermint 7 on an HP Stream 11. It seems to recognize my touchpad as a mouse. It has no right click enabled. I had the same problem on Peppermint 6.

Is there a fix for this problem?

Thanks,

Steve


Sent from my iPad using Tapatalk
« Last Edit: August 19, 2016, 12:52:48 pm by PCNetSpec, Reason: marked as solved. »

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25306
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Problems with touchpad...
« Reply #1 on: August 18, 2016, 06:31:18 pm »
Hi grioghair, and welcome to the candy striped asylum forum :)

Try this...

Open a terminal and run:
Code: [Select]
sudo pluma /usr/share/X11/xorg.conf.d/50-synaptics.conf
find the first "InputClass" section that reads:-
Code: [Select]
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
      MatchDevicePath "/dev/input/event*"
EndSection
and change it to
Code: [Select]
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
      MatchDevicePath "/dev/input/event*"
        Option "ClickPad" "true"
EndSection
SAVE the file,

and REBOOT
« Last Edit: August 18, 2016, 06:43:29 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline grioghair

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Problems with touchpad...
« Reply #2 on: August 19, 2016, 09:47:05 am »
Hi grioghair, and welcome to the candy striped asylum forum :)

Try this...

Open a terminal and run:
Code: [Select]
sudo pluma /usr/share/X11/xorg.conf.d/50-synaptics.conf
find the first "InputClass" section that reads:-
Code: [Select]
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
      MatchDevicePath "/dev/input/event*"
EndSection
and change it to
Code: [Select]
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
      MatchDevicePath "/dev/input/event*"
        Option "ClickPad" "true"
EndSection
SAVE the file,

and REBOOT

Thank you, PCNetSpec...that worked like a charm.

Many, many thanks,

Grioghair


Sent from my iPad using Tapatalk

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25306
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Problems with touchpad...
« Reply #3 on: August 19, 2016, 12:52:24 pm »
You're most welcome grioghair :)

If you're happy this is solved now, can you please mark the topic (SOLVED) .. you can do this by editing the FIRST posting in this topic and changing

Subject: Problems with touchpad... (SOLVED)

Thanks in advance.

[EDIT]

I've done this one for you, but can you remember in the future please :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline grioghair

  • nOOb
  • *
  • Posts: 3
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Problems with touchpad...
« Reply #4 on: August 21, 2016, 05:36:53 pm »
You're most welcome grioghair :)

If you're happy this is solved now, can you please mark the topic (SOLVED) .. you can do this by editing the FIRST posting in this topic and changing

Subject: Problems with touchpad... (SOLVED)

Thanks in advance.

[EDIT]

I've done this one for you, but can you remember in the future please :)

Yes, sure. I only just got back on the board. Will a kernel upgrade fix this in the future? Everything is working great now. Thank you for the help.

Steve

Online PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25306
  • Karma: 2793
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Problems with touchpad... (SOLVED)
« Reply #5 on: August 21, 2016, 10:23:46 pm »
It might .. you never know :)

But at least we have a known working solution now.

Thanks for marking the topic solved.
« Last Edit: August 21, 2016, 10:25:23 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec