Choose style:

Author Topic: Peppermint 7 - Switching Nemo to PCManFM  (Read 1961 times)

0 Members and 1 Guest are viewing this topic.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25725
  • Karma: 2822
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Peppermint 7 - Switching Nemo to PCManFM
« on: August 07, 2016, 07:57:12 am »
This tutorial is tested in Peppermint 7 though it would probably also work in Peppermint 6 (just replace references to "pluma" with "gedit").

To switch back from the Nemo file manager to PCManFM (these instructions have been requested by people who want USB automounting, but be aware you'll loose a LOT of functionality that comes with Nemo so I don't advise this)....

First BE AWARE, DO NOT under any circumstances uninstall nemo, it will take peppermint-default-setting with it and break your system .. instead it will be left installed but hidden.

Open a terminal, and run:
Code: [Select]
sudo apt-get install pcmanfm
then
Code: [Select]
pluma ~/.config/lxsession/Peppermint/desktop.conf
find the line
Code: [Select]
file_manager/command=nemo
and change it to
Code: [Select]
file_manager/command=pcmanfm
also find the line
Code: [Select]
desktop_manager/command=nemo -n
and change it to
Code: [Select]
desktop_manager/command=pcmanfm --desktop
SAVE the file and exit pluma.

In the main menu go to:-
menu > Preferences > Default Applications for LXSession
and select the "Autostart" tab

Remove the tick from the "Nemo" item.

Close the LXSession Configuration app.

Log off/on to test.

(you'll probably end up with no wallpaper .. just right-click the desktop and select "Desktop Preferences" and set your wallpaper there)

Once you're happy that PCManFM is controlling the desktop, you'll need to hide the "Files" menu item otherwise whenever you click it nemo will take over the desktop, so open a terminal and run:
Code: [Select]
sudo pluma /usr/share/applications/nemo.desktop
scroll to the bottom and find the line
Code: [Select]
X-Unity-IconBackgroundColor=#af4853
and immediately underneath it add the line
Code: [Select]
NoDisplay=true
SAVE the file and exit pluma.

Now right-click on the "Files" launcher on the taskbar and select "Properties", on the "General" tab highlight "Files" and click the Delete button (X) .. now click the Add button (+), search for "pcmanfm" highlight it and click "Add".

That's it .. you're done.



If you use keyboard shortcuts to open the file manager you'll also want to run:
Code: [Select]
pluma ~/.config/peppermint-control-center/xbindkeys.conf
and change the references to "nemo" to "pcmanfm"



Okay now I need to set my system back to nemo .. pcmanfm is far too basic for my needs :)
« Last Edit: August 07, 2016, 08:07:02 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec