Author Topic: Can't disable tap to click [solved]  (Read 1548 times)

Offline LNXlady

  • Member
  • ***
  • Posts: 97
  • Karma: 52
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Can't disable tap to click [solved]
« on: August 08, 2016, 04:30:31 pm »
I've got "tap to click" disabled in the control center but still, when I tap with 2 fingers the context menu pops up like it is set for a right-click on tap. It's annoying because I use 2 finger scroll so half the time when I start the scroll the menu pops up and I have to dismiss it. Is there some other place to tell it not to do this?

BTW- Haven't tried Peppermint in a long time and it is has really grown up. It's looking great and working smoothly for the most part. I'm enjoying it.
« Last Edit: August 09, 2016, 07:17:52 am by LNXlady »

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Can't disable tap to click
« Reply #1 on: August 08, 2016, 05:11:47 pm »
Hi LNXlady, welcome the Peppermint Forum  8).  Could we have a little more information about your machine?  Please run the following command in a terminal window:
Code: [Select]
inxi -FPost the output back to the forum.  Someone will quickly get back to you with assistance  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline Slim.Fatz

  • Global Moderator
  • Veteran
  • *****
  • Posts: 2393
  • Karma: 633
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: Can't disable tap to click
« Reply #2 on: August 09, 2016, 12:21:34 am »
Hi LNXlady,

Nice to hear that you have returned to PeppermintOS to test Peppermint 7 !! I think that maybe this time you will stay!  8)

I cannot say for sure that this will help, but it is worth trying, should not cause any problems and is easy to reverse back in case it does not work. Go to Menu -> System -> dconf Editor and when it opens click on the little triangle to the left of org to get a list of categories.

In this new list you click on the triangle on left of gnome and then in the new list click on the triangle to the left of desktop, then on the triangle to the left of peripherals. Now you should see touchpad listed. Click on it to get a list of settings to change (they appear in the right side pane of the window). Try out some of the things there to see if they solve your problem.
If they do help, or even if they do not, please report back here to let us know.  ;)

Regards,

-- Slim
« Last Edit: August 09, 2016, 12:55:39 am by Slim.Fatz »
Respect science, respect nature, respect each other.

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26437
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Can't disable tap to click
« Reply #3 on: August 09, 2016, 03:17:23 am »
If this is a synaptics touchpad....

Open a terminal and run:
Code: [Select]
sudo pluma /usr/share/X11/xorg.conf.d/50-synaptics.conffind the section that reads:-
Code: [Select]
# This option enables the bottom right corner to be a right button on clickpads
# and the right and middle top areas to be right / middle buttons on clickpads
# with a top button area.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"
EndSection
and add the "TapButton2 0" option before the "EndSection" line, so that section now reads:-
Code: [Select]
# This option enables the bottom right corner to be a right button on clickpads
# and the right and middle top areas to be right / middle buttons on clickpads
# with a top button area.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "SecondarySoftButtonAreas" "58% 0 0 15% 42% 58% 0 15%"
        Option "TapButton2" "0"
EndSection
SAVE the file, and REBOOT to test.



For reference - synaptics touchpad config options:
https://wiki.archlinux.org/index.php/Touchpad_Synaptics
« Last Edit: August 09, 2016, 03:25:04 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline LNXlady

  • Member
  • ***
  • Posts: 97
  • Karma: 52
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Can't disable tap to click
« Reply #4 on: August 09, 2016, 07:16:58 am »
Thanks to everyone who replied. I tried slim.Fatz suggestion first but tap was already disabled there and none of the other options affected the tapping. It is a synaptics pad though and PCNetSpec's suggestion seems to have done the trick! Easy fix, thanks!

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3233
  • Karma: 625
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: Can't disable tap to click
« Reply #5 on: August 09, 2016, 08:23:37 am »
Thanks to everyone who replied. I tried slim.Fatz suggestion first but tap was already disabled there and none of the other options affected the tapping. It is a synaptics pad though and PCNetSpec's suggestion seems to have done the trick! Easy fix, thanks!

Hi LNXlady

Glad everything is resolved and thanks for markng the topic Solved.

Easy for PCNetSpec...  flamin hard   >:( (puzzled look) for the rest of us mortals 
Regards Zeb...
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

P10r x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k