Choose style:

Author Topic: Libusb-0.1.so.4 problem [SOLVED]  (Read 8556 times)

0 Members and 1 Guest are viewing this topic.

Offline al3xshaman

  • nOOb
  • *
  • Posts: 14
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Libusb-0.1.so.4 problem [SOLVED]
« on: August 01, 2016, 02:53:37 pm »
Hello everyone,

I tried to install driver for modem Huawei E303 from internal storage, but I faced with the following problem:
Code: [Select]
$ sudo ./install 
install begin...
the Mobile Broad HL Service has been installed before.
now begin to verify version ...
the INSTALLED version is : 22.001.10.00.03
the INSTALLING version is : 22.001.10.00.03
do you want to re-install it?([Y]/N):y
yes/install...
begin to copy file...
copy end ...
begin to install ...
install success...
run the process...
/usr/local/MobileBrServ/mbbservice
/usr/local/MobileBrServ/mbbservice: error while loading shared libraries: libusb-0.1.so.4: cannot open shared object file: No such file or directory
install end...
Preass any key to exit.
 
I checked existence:
Code: [Select]
 $ locate libusb-0.1.so.4
/lib/x86_64-linux-gnu/libusb-0.1.so.4
/lib/x86_64-linux-gnu/libusb-0.1.so.4.4.4

I tried to find solution in such places like this http://askubuntu.com/questions/311401/libusb-0-1-so-4-shared-lib-error-in-ubuntu-64-bit-system but it was helpless.
 :-\
Could you help me resolve it?

Thanks in advance.
« Last Edit: August 03, 2016, 02:10:55 pm by al3xshaman »
Be root for your own life...

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25713
  • Karma: 2821
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Libusb-0.1.so.4 problem
« Reply #1 on: August 01, 2016, 05:34:01 pm »
so you tried installing the 32bit version of the library
Code: [Select]
sudo apt-get install libusb-0.1-4:i386
?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline al3xshaman

  • nOOb
  • *
  • Posts: 14
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Libusb-0.1.so.4 problem
« Reply #2 on: August 02, 2016, 02:34:42 pm »
Sure. How it was mentioned here http://askubuntu.com/questions/311401/libusb-0-1-so-4-shared-lib-error-in-ubuntu-64-bit-system I did it, but I have following:
Code: [Select]
$ sudo apt-get install libusb-0.1-4:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libusb-0.1-4:i386
E: Couldn't find any package by glob 'libusb-0.1-4'
E: Couldn't find any package by regex 'libusb-0.1-4'

May be any dependencies were not set

P.S. just in case I use peppermint 7 (64 bit)
« Last Edit: August 02, 2016, 02:43:56 pm by al3xshaman »
Be root for your own life...

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25713
  • Karma: 2821
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Libusb-0.1.so.4 problem
« Reply #3 on: August 02, 2016, 02:44:42 pm »
what's the output from
Code: [Select]
cat /etc/lsb-release
and
Code: [Select]
uname -a
« Last Edit: August 02, 2016, 02:46:33 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline al3xshaman

  • nOOb
  • *
  • Posts: 14
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Libusb-0.1.so.4 problem
« Reply #4 on: August 02, 2016, 02:51:13 pm »
what's the output from
Code: [Select]
cat /etc/lsb-release
and
Code: [Select]
uname -a

Code: [Select]
 ~ $ cat /etc/lsb-release
DISTRIB_ID=Peppermint
DISTRIB_RELEASE=7
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Peppermint 7 Seven"
~ $ uname -a
Linux alexander-book 4.4.0-31-generic #50-Ubuntu SMP Wed Jul 13 00:07:12 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

It's strange. Recently I've tried to install teamviewer, but it said me "Wrong architechture i386". It seems to me I'm not allowed to install software of 32bit architecture.
« Last Edit: August 02, 2016, 02:53:27 pm by al3xshaman »
Be root for your own life...

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25713
  • Karma: 2821
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: Libusb-0.1.so.4 problem
« Reply #5 on: August 02, 2016, 03:04:25 pm »
You shouldn't have to do this but run:
Code: [Select]
sudo dpkg --add-architecture i386
then
Code: [Select]
sudo apt-get update
now does
Code: [Select]
sudo apt-get install libusb-0.1-4:i386
work ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline al3xshaman

  • nOOb
  • *
  • Posts: 14
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Libusb-0.1.so.4 problem
« Reply #6 on: August 02, 2016, 03:12:19 pm »
You shouldn't have to do this but run:
Code: [Select]
sudo dpkg --add-architecture i386
then
Code: [Select]
sudo apt-get update
now does
Code: [Select]
sudo apt-get install libusb-0.1-4:i386
work ?

It's incredible!!! It really works.!!! Thank you very much  :) :) :)

P.S. I plugged 3G Modem and driver was installed automatic without any actions  :)
Be root for your own life...

Offline al3xshaman

  • nOOb
  • *
  • Posts: 14
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: Libusb-0.1.so.4 problem
« Reply #7 on: August 02, 2016, 03:15:28 pm »
I like this OS more and more)  ;)
Be root for your own life...