Author Topic: Wi Fi Not Working in PM 7 on HP Notebook [SOLVED and CLOSED]  (Read 1930 times)

harishpathangay

  • Guest
Hi,
Wi Fi Not Working in PM 7 on HP Notebook?
output of lspci -k:
Code: [Select]
harish@HP-Notebook ~ $ lspci -k|more
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
Subsystem: Hewlett-Packard Company Broadwell-U Host Bridge -OPI
Kernel driver in use: bdw_uncore
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
Subsystem: Hewlett-Packard Company Broadwell-U Integrated Graphics
Kernel driver in use: i915
Kernel modules: i915
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
Subsystem: Hewlett-Packard Company Broadwell-U Audio Controller
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
00:04.0 Signal processing controller: Intel Corporation Broadwell-U Camarillo Device (rev 09)
Subsystem: Hewlett-Packard Company Broadwell-U Processor Thermal Subsystem
Kernel driver in use: proc_thermal
Kernel modules: processor_thermal_device
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
Subsystem: Hewlett-Packard Company Wildcat Point-LP USB xHCI Controller
Kernel driver in use: xhci_hcd
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
Subsystem: Hewlett-Packard Company Wildcat Point-LP MEI Controller
Kernel driver in use: mei_me
Kernel modules: mei_me
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
Subsystem: Hewlett-Packard Company Wildcat Point-LP High Definition Audio Controller
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1c.2 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1c.5 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #6 (rev e3)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
Subsystem: Hewlett-Packard Company Wildcat Point-LP LPC Controller
Kernel driver in use: lpc_ich
Kernel modules: lpc_ich
00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
Subsystem: Hewlett-Packard Company Wildcat Point-LP SATA Controller [AHCI Mode]
Kernel driver in use: ahci
Kernel modules: ahci
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
Subsystem: Hewlett-Packard Company Wildcat Point-LP SMBus Controller
Kernel modules: i2c_i801
00:1f.6 Signal processing controller: Intel Corporation Wildcat Point-LP Thermal Management Controller (rev 03)
Subsystem: Hewlett-Packard Company Wildcat Point-LP Thermal Management Controller
Kernel driver in use: intel_pch_thermal
Kernel modules: intel_pch_thermal
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 07)
Subsystem: Hewlett-Packard Company RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
Kernel driver in use: r8169
Kernel modules: r8169
0d:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
Subsystem: Hewlett-Packard Company RTL8723BE PCIe Wireless Network Adapter
Kernel driver in use: rtl8723be
Kernel modules: rtl8723be


Thanks,
Harish Pathangay
« Last Edit: July 26, 2016, 02:23:49 am by harishpathangay »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Wi Fi Not Working in PM 7 on HP Notebook
« Reply #1 on: July 17, 2016, 02:39:04 am »
rtl8723be should work out of the box :-\

What's the output from:
Code: [Select]
rfkill listare you sure you haven't just disabled it via the Fn+F12 key combo (the key with the airplane)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

harishpathangay

  • Guest
Re: Wi Fi Not Working in PM 7 on HP Notebook
« Reply #2 on: July 17, 2016, 07:13:57 am »
hi,
it did not work out of the box.
however I modified the conf file in etc/modprobe.d [some thing like that, I do not exactly remember] as suggested by a google search output.
added ant_sel=1 option and it worked fine.
Will observe whether it is stable for more than a hour and getting good speed.
Definitely it is working with only tweaking not out of the box.
Will keep you posted after a day of observation.

thanks,
harish pathangay

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Wi Fi Not Working in PM 7 on HP Notebook
« Reply #3 on: July 17, 2016, 07:37:11 am »
Hmm, someone at HP must have hooked up the antenna to the wrong socket ::)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

harishpathangay

  • Guest
Re: Wi Fi Not Working in PM 7 on HP Notebook
« Reply #4 on: July 20, 2016, 11:39:20 pm »
Hi,
I reinstalled Peppermint 7 again facing wifi issues. Specifically i am facing Range Detection Issues. It only works till my next room. It was working earlier from hall.
And suddenly Antenna 2 is not working. It is only working in Antenna 1.

Code: [Select]
harish@HP-Notebook ~ $ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
Code: [Select]
harish@HP-Notebook ~ $ modinfo rtl8723be
filename:       /lib/modules/4.4.0-31-generic/kernel/drivers/net/wireless/realtek/rtlwifi/rtl8723be/rtl8723be.ko
firmware:       rtlwifi/rtl8723befw.bin
description:    Realtek 8723BE 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE <wlanfae@realtek.com>
author:         PageHe <page_he@realsil.com.cn>
srcversion:     3B2ECD9306CE299232BAE5D
alias:          pci:v000010ECd0000B723sv*sd*bc*sc*i*
depends:        rtlwifi,rtl8723-common,rtl_pci,btcoexist,mac80211
intree:         Y
vermagic:       4.4.0-31-generic SMP mod_unload modversions
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
parm:           debug:Set debug level (0-5) (default 0) (int)
parm:           disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)
parm:           ant_sel:Set to 1 or 2 to force antenna number (default 0)
 (int)


Code: [Select]
harish@HP-Notebook ~ $ inxi -F
System:    Host: HP-Notebook Kernel: 4.4.0-31-generic x86_64 (64 bit) Desktop: N/A Distro: Peppermint Seven
Machine:   System: HP product: HP Notebook v: Type1ProductConfigId
           Mobo: HP model: 80C1 v: 96.47 Bios: Insyde v: F.21 date: 05/17/2016
CPU:       Dual core Intel Pentium 3825U (-HT-MCP-) cache: 2048 KB
           clock speeds: max: 1900 MHz 1: 1900 MHz 2: 1900 MHz 3: 816 MHz 4: 811 MHz
Graphics:  Card: Intel Broadwell-U Integrated Graphics
           Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel Broadwell GT1 GLX Version: 3.0 Mesa 11.2.0
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller driver: snd_hda_intel
           Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.4.0-31-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller driver: r8169
           IF: enp7s0 state: down mac: fc:3f:db:d5:f2:94
           Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be
           IF: wlp13s0 state: up mac: 30:f7:72:0e:46:99
Drives:    HDD Total Size: 500.1GB (1.6% used) ID-1: /dev/sda model: HGST_HTS545050A7 size: 500.1GB
Partition: ID-1: / size: 66G used: 3.9G (7%) fs: ext4 dev: /dev/sda7
           ID-2: swap-1 size: 4.10GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 45.5C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 173 Uptime: 16 min Memory: 599.1/3866.9MB Client: Shell (bash) inxi: 2.2.35

Thanks,
Harish Pathangay
« Last Edit: July 20, 2016, 11:56:55 pm by AndyInMokum »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Wi Fi Not Working in PM 7 on HP Notebook
« Reply #5 on: July 21, 2016, 04:21:24 am »
Put it back to antenna 2 .. you're going to have range issues if you're using the socket without an antenna.

So what's the contents of your
Code: [Select]
pluma /etc/modprobe.d/rtl8723.confnow ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

harishpathangay

  • Guest
Re: Wi Fi Not Working in PM 7 on HP Notebook
« Reply #6 on: July 22, 2016, 04:18:02 am »
Code: [Select]
options rtl8723be ant_sel=1 fwlps=N ips=N

this is the current content and it working fine with in a small distance. range detectin issues are there.

Code: [Select]
harish@HP-Notebook ~ $ iwconfig
enp7s0    no wireless extensions.

lo        no wireless extensions.

wlp13s0   IEEE 802.11bgn  ESSID:"HiFi" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: 80:37:73:91:B6:78   
          Bit Rate=150 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=56/70  Signal level=-54 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:20   Missed beacon:0


thanks,
harish pathangay
« Last Edit: July 26, 2016, 04:18:09 am by AndyInMokum »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Wi Fi Not Working in PM 7 on HP Notebook
« Reply #7 on: July 22, 2016, 04:36:40 am »
Hmm, I made a typo in my earlier post and yet you still posted some output .. so I'm wondering if you adjusted my command or you have 2 conf files for the rtl8723be

Can you post the output from:
Code: [Select]
ls /etc/modprobe.d?

Reason I ask is I already placed a file at
/etc/modprobe.d/rtl8723be.conf
with these contents
options rtl8723be fwlps=0 ips=0
yet yours seems to have "N"'s in place of the "0"'s
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

harishpathangay

  • Guest
Re: Wi Fi Not Working in PM 7 on HP Notebook
« Reply #8 on: July 22, 2016, 10:53:56 pm »
Hi,
I could not find file rtl8723.conf.
But I can see file rtl8723be.conf
Hence I posted its contents. This is the file I am changing the parameters on and off and antenna selection etc..

I will try the

options rtl8723be ant_sel=1 fwlps=0 ips=0

and let you know.

thanks,
harish pathangay

harishpathangay

  • Guest
Re: Wi Fi Not Working in PM 7 on HP Notebook
« Reply #9 on: July 22, 2016, 11:09:06 pm »
Hi,
As Always, let me thank you for your patient support on this issue. it means a lot.
Here are the details. Rebooted the System, still having range issues.

Code: [Select]
harish@HP-Notebook ~ $ ls /etc/modprobe.d
alsa-base.conf              blacklist-oss.conf              libpisock9.conf
blacklist-ath_pci.conf      blacklist-rare-network.conf     mlx4.conf
blacklist.conf              blacklist-watchdog.conf         rtl8723be.conf
blacklist-firewire.conf     fbdev-blacklist.conf            vmwgfx-fbdev.conf
blacklist-framebuffer.conf  intel-microcode-blacklist.conf
blacklist-modem.conf        iwlwifi.conf

Code: [Select]
harish@HP-Notebook ~ $ cat rtl8723be.conf
cat: rtl8723be.conf: No such file or directory
harish@HP-Notebook ~ $ cat /etc/modprobe.d/rtl8723be.conf
options rtl8723be ant_sel=1 fwlps=0 ips=0
harish@HP-Notebook ~ $
« Last Edit: July 26, 2016, 04:17:14 am by AndyInMokum »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Wi Fi Not Working in PM 7 on HP Notebook
« Reply #10 on: July 23, 2016, 07:22:09 am »
is this a dual booter ? .. if so how is the wireless range in Windows ?

I'm beginning to wonder if you have a loose antenna .. it's certainly on a different connector to mine (which only works on "ant_sel=2" (or the default "0" which I'm assuming is autoselect)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

harishpathangay

  • Guest
Re: Wi Fi Not Working in PM 7 on HP Notebook
« Reply #11 on: July 23, 2016, 11:41:05 am »
Hi,
Yes, the range in windows 10 OS is good.
Only in Peppermint OS I see issues.
It is a dual boot with Win 10 and PM 7.

How can I confirm it is a physical antenna issue when it is working properly in Windows 10?

Thanks,
Harish Pathangay

harishpathangay

  • Guest
Re: Wi Fi Not Working in PM 7 on HP Notebook
« Reply #12 on: July 24, 2016, 01:38:05 am »
Hi,
It seems like it is working with the following entries and i am getting the range that i had earlier, not great but still doable.
Let me observe for a day or so and check with you again. i will keep you posted after some testing and observation for a day or two. Just to make sure it is consistent signal levels strength.

options rtl8723be ant_sel=1 fwlps=0 ips=0

Thanks,
Harish Pathangay


harishpathangay

  • Guest
Re: Wi Fi Not Working in PM 7 on HP Notebook
« Reply #13 on: July 26, 2016, 02:22:50 am »
hi,
the following setting seems to work for 2 days now. stable,range is okay and speed is also good.

Code: [Select]
harish@HP-Notebook ~ $ cat /etc/modprobe.d/rtl8723be.conf
options rtl8723be ant_sel=1 swenc=Y fwlps=0 ips=0

if any problems let you know later. but definitely looks good only.

thanks,
harish pathangay
« Last Edit: July 26, 2016, 04:15:58 am by AndyInMokum »