Choose style:

Author Topic: SOLVED -- Installing Se7en- Problems with Modify top Bar -- need shutdown  (Read 1727 times)

0 Members and 1 Guest are viewing this topic.

Offline crazyodaz

  • nOOb
  • *
  • Posts: 12
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): SIX - ATE - SE7EN


so yea --- deleted the top bar -- oops --- LOL

FIRST OF ALL --- BIG HUGE THANK YOU TO SE7EN CREW!!!!!!

6 would not run right on this desktop -- maybe it was the i7 -- maybe something else, been tossing between Mint and Peppermint on my laptop, so glad I stumbled on Peppermint few months ago -- anyways... here we go

========================

top bar is reserved for mac's --- get rid of it -- LOL --- I did -- and now my problem


as you can see -- I cant shut down -- cant restart -- cant do normal stuff --- but I can change the start button back to Windows98 style button -- LOL

maybe I am over-looking this issue --- I appreciate any input

again -- SERIOUSLY --- BOTH KODI AND VMWARE working on peppermint 7 --- seriously -- something i could not accomplish with 6 --- THANK YOU SE7EN CREW <3

and thanks for any insight on my Panel modification and stupidity of trying to make something old run even better

I got another issue I will post later --- DRIVER MICROCODE INTEL -- that hapens in MINT 18 beta and peppermint --- not sure what this driver is --- never needed it or was asked for it in 14.04 based machines

just wondering how to fix the GREY'd out SHUTDOWN and REBOOT options
thanks again
« Last Edit: June 29, 2016, 12:17:49 am by crazyodaz »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Hi, crazyodaz and welcome to the forum :)

See this posting:
https://forum.peppermintos.com/index.php/topic,3712.msg37316.html#msg37316
is that what you mean ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline crazyodaz

  • nOOb
  • *
  • Posts: 12
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): SIX - ATE - SE7EN
Hi, crazyodaz and welcome to the forum :)

See this posting:
https://forum.peppermintos.com/index.php/topic,3712.msg37316.html#msg37316
is that what you mean ?

yes and no .... and thank you --- LOL

seems the terminal command ---
 
Code: [Select]
peppermint-logout 

was all I needed --- went back into the main panel settings and added a custom "LAUNCHER" like what the picture shows

now when i click the shutdown on bottom left -- the menu pops up

IMPORTANT NOTE --- my "START BUTTON" is just applications launcher -- it is NOT whiskers ---  all that is left to do is take out the Session Manager that had the greyed out restart buttons -- and just use the one created thanks to your referal tip

thanks again --- appreciate it --- will change as SOLVED


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Cool, glad you got there in the end :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline tppthpthp

  • Jr. Member
  • **
  • Posts: 28
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): 6 & 7
For those naysayers..........The search tool works!
I ran into the same exact problem while tinkering with switching the applications menu and needed to add a shutdown button.
However, I still have a grey'd out item at the bottom of my Applications menu stating "no applications found". But that's minor. I'm sure it's something I'm missing.

Thanks crazyodaz for a solution.

And I'll just echo crazyodaz sentiment -- BIG HUGE THANK YOU TO SE7EN CREW!!!!!!


tppthpthp aka: "bob"

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
What's the contents of
Code: [Select]
pluma ~/.config/xfce4/panel/whiskermenu-7.rc

If however you're not talking about the main menu .. can you say exactly what you mean by

Quote
I still have a grey'd out item at the bottom of my Applications menu stating "no applications found".
« Last Edit: July 21, 2016, 08:48:21 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline tppthpthp

  • Jr. Member
  • **
  • Posts: 28
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): 6 & 7
I switched out my whisker menu to the applications menu in panel preferences.
As seen here.
https://forum.peppermintos.com/index.php/topic,3705.0.html

Everything is there and works fine. Just the last item at the bottom of the list states "No applications found".
tppthpthp aka: "bob"

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
If you want a menu like the one from Peppermint 6 (the image below is using the "Applications Menu" xfce4-panel applet in Peppermint 7)


Run these commands in sequence:
Code: [Select]
cd /etc/xdg/menus
then
Code: [Select]
sudo wget https://dl.dropboxusercontent.com/u/31525164/peppermint-hierarchical.menu.tar.gz
then
Code: [Select]
sudo tar xvf peppermint-hierarchical.menu.tar.gz
now right-click your "Applications Menu" panel applet, and choose "Properties"

At the bottom of the Applications Menu preferences dialog, select "Use custom menu file" .. then click the little "Browse" icon, and browse to

File System > etc > xdg > menus

and choose the "peppermint-hierarchical.menu" file .. and click the "Open" button.

Then make the other settings look like this:-


Now (if you want the "End Session" button in the menu) back in a terminal, run:
Code: [Select]
sudo pluma /usr/share/applications/peppermint-logout.desktop
and change the line

NoDisplay=true

to

NoDisplay=false

SAVE the file and exit pluma



If you need to make any changes to the top level menu applications....
sudo pluma /etc/xdg/menus/peppermint-hierarchical.menu
and make your changes to ONLY the BOTTOM 2 sections
Code: [Select]
<!-- General layout of the whole menu -->
    <Layout>
        <Menuname>Settings</Menuname>
        <Separator/>
        <Merge type="all"/>
        <Separator/>
        <Menuname>Administration</Menuname>
        <Menuname>DesktopSettings</Menuname>
        <Separator/>
            <Filename>firefox.desktop</Filename>
            <Filename>mintinstall.desktop</Filename>
            <Filename>sakura.desktop</Filename>
            <Filename>gnome-search-tool.desktop</Filename>
            <Filename>nemo.desktop</Filename>
            <Filename>xfce4-run.desktop</Filename>
        <Separator/>
            <Filename>peppermint-logout.desktop</Filename>


    </Layout>

        <Include>
            <Filename>firefox.desktop</Filename>
            <Filename>mintinstall.desktop</Filename>
            <Filename>sakura.desktop</Filename>
            <Filename>gnome-search-tool.desktop</Filename>
            <Filename>nemo.desktop</Filename>
            <Filename>xfce4-run.desktop</Filename>
            <Filename>peppermint-logout.desktop</Filename>
        </Include>


</Menu>
« Last Edit: July 21, 2016, 12:13:59 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec