Choose style:

Author Topic: can't find networks, but still auto connects to networks  (Read 2779 times)

0 Members and 1 Guest are viewing this topic.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: can't find networks, but still auto connects to networks
« Reply #15 on: July 11, 2016, 12:09:16 pm »
I wonder how systemd is deciding on network device node/device names

I seem to remember tnhat everyone with this problem has a node/device name like

wlp3s0

Where mine is simply

wlo1

neither are in the "biosdevname" format .. which makes sense as we don't have it installed by default .. so I wonder how systemd arrives at its naming convention  :-\

Might be interesting to see the output from:
Code: [Select]
ifconfig
for a few people WITH the problem, and a few WITHOUT the problem
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5304
  • Karma: 943
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: can't find networks, but still auto connects to networks
« Reply #16 on: July 11, 2016, 04:44:26 pm »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25659
  • Karma: 2819
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: can't find networks, but still auto connects to networks
« Reply #17 on: July 11, 2016, 04:58:20 pm »
Oooohh!! .. the net.ifnames=0 kernel boot parameter is handy, and changes my nework device name back to the old style "wlan0" format.

Anyone having this problem up for an experiment .. doubt if it'll make an difference, but worth a shot eh ?

Thanks Missieur Deezle :)
« Last Edit: July 11, 2016, 05:05:20 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online VinDSL

  • Global Moderator
  • Hero
  • *****
  • Posts: 5304
  • Karma: 943
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: can't find networks, but still auto connects to networks
« Reply #18 on: July 11, 2016, 11:11:20 pm »
 :D

Offline intuxikated

  • nOOb
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: can't find networks, but still auto connects to networks
« Reply #19 on: July 16, 2016, 04:44:46 pm »
(on default network manager now)

so i found out that if i logged out and back in again the icon would be fine, and the menu would also work as expected.
i had autologin on so i turned it off, and now it works from the minute i boot up my computer,
but now i have to input my password when i start my computer, not a big deal though.

i'm guessing you (tppthpthp) also have autologin enabled? try if logging out and in again helps with the icon and menu.
if so do this to disable autologin

sudo pluma /etc/lightdm/lightdm.conf
remove your username after "autologin-user="

save and then reboot
you'll have  to login but the icon and right click menu should be fine now.

Offline zebedeeboss

  • Global Moderator
  • Hero
  • *****
  • Posts: 3043
  • Karma: 563
  • Life first... Peppermint a close 2nd :)
    • View Profile
  • Peppermint version(s): P10 / P9 Respin
Re: can't find networks, but still auto connects to networks
« Reply #20 on: July 17, 2016, 01:12:40 am »
I wonder how systemd is deciding on network device node/device names

Maybe this:  https://major.io/2015/08/21/understanding-systemds-predictable-network-device-names/

 :-\ :-\ :-\  There goes Concorde.......  WOOOOSH!!!!!!!!!
Be Kind Whenever Possible...   It is Always Possible - Dalai Lama

Linux User #565092
P10 x64 Desktop - AMD Threadripper 2950X - 64Gb RAM - NVIDIA RTX2080Ti 11Gb - 2 x 27" 4k 3840x2160 - 1 x 34" 5120x2160
P9/10 @ P9 x64 Laptop - i7-7700HQ @ 2.80GHz - 8Gb RAM - Nvidia GTX1050 4Gb - 15.6" HD 1920x1080

Offline tppthpthp

  • Jr. Member
  • **
  • Posts: 28
  • Karma: 3
  • New Forum User
    • View Profile
  • Peppermint version(s): 6 & 7
Re: can't find networks, but still auto connects to networks
« Reply #21 on: July 21, 2016, 08:22:15 am »
i'm guessing you (tppthpthp) also have autologin enabled? try if logging out and in again helps with the icon and menu.
if so do this to disable autologin

sudo pluma /etc/lightdm/lightdm.conf
remove your username after "autologin-user="

save and then reboot
you'll have  to login but the icon and right click menu should be fine now.

YEP! That fixed it! And logging in isn't a big issue. Probably a better practice in the long run.
This is awesome! I love this support forum. This is the second thing that I've learned about this OS today and I haven't even started on my coffee yet.

Apologies for not responding sooner. Took a few days off and was away from technology.
tppthpthp aka: "bob"