Choose style:

Author Topic: How to prevent ModemManager from starting? (SOLVED)  (Read 2655 times)

0 Members and 1 Guest are viewing this topic.

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1812
  • Karma: 474
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
How to prevent ModemManager from starting? (SOLVED)
« on: July 08, 2016, 11:09:40 am »
Hi,

This might not be a very advanced question, but ... On a desktop machine running Peppermint Six (32 bit), how do I go about preventing the modem manager process from being started at every boot?

Thanks in advance,

-- Slim

P.S.

Solved this one myself: I just removed the executable flags from the file

Code: [Select]
/usr/sbin/ModemManager
and now it's neither starting at boot nor getting started by the NetworkManager process after boot.  8)

Regards,

-- Slim
« Last Edit: July 08, 2016, 12:11:08 pm by Slim.Fatz »
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: How to prevent ModemManager from starting? (SOLVED)
« Reply #1 on: July 08, 2016, 12:13:59 pm »
This will show ypou the status of the ModemManager.service (ie. if it's running or not):
Code: [Select]
sudo systemctl status ModemManager.service
this will stop the ModemManager.service:
Code: [Select]
sudo systemctl stop ModemManager.service
this will disable the ModemManager.service (so it doesn't autostart):
Code: [Select]
sudo systemctl disable ModemManager.service

Note:-
Hitting the "Q" key will quit a "systemctl status" command back to the command prompt



To re-enable:
Code: [Select]
sudo systemctl enable ModemManager.service
then:
Code: [Select]
sudo systemctl start ModemManager.service
then you can check it's status again with:
Code: [Select]
sudo systemctl status ModemManager.service

Note:-
Hitting the "Q" key will quit a "systemctl status" command back to the command prompt
« Last Edit: July 08, 2016, 12:20:28 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Slim.Fatz

  • Trusted User
  • Veteran
  • *****
  • Posts: 1812
  • Karma: 474
  • Where's the mouse?
    • View Profile
  • Peppermint version(s): Peppermint 7, 8.5 & 10 - 64bit
Re: How to prevent ModemManager from starting? (SOLVED)
« Reply #2 on: July 08, 2016, 12:22:40 pm »
Hi PCNetSpec,

Thanks for the tips, mate, but as you were writing them I was posting my solution.  ;D Besides: Peppermint Six does not use systemd so systemctl status does not exist as a command. I know: Six / 7 ... don't worry: I get confused all the time too.  :D

Just stopping ModemManager from being started at boot does not help much since it seems that the NetworkManager process starts it, or checks regularly to see if it is running, and if it isn't running it (NetworkManager) will start it. I do not want to remove the package (ModemManager) because I suspect it will just get pulled in again when a new NetworkManager version appears (and it seems to be fairly regularly updated).

Sorry to have wasted your time.  :-[ I owe you a pint (at least)!  8)

Regards,

-- Slim
« Last Edit: July 08, 2016, 12:27:11 pm by Slim.Fatz »
"Life first -- Peppermint a close 2nd!" -- Zeb

Tread lightly: Fluxbox, JWM, i3, Openbox, awesome

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: How to prevent ModemManager from starting? (SOLVED)
« Reply #3 on: July 08, 2016, 01:31:11 pm »
Sorry mate I didn't spot the BRIGHT RED "Peppermint 6" <facepalm egg smiley thing>

Maybe:
Code: [Select]
sudo service ModemManager stop
and
Code: [Select]
sudo service ModemManager status
?
« Last Edit: July 08, 2016, 01:34:11 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec