Choose style:

Author Topic: no sound on laptop (SOLVED)  (Read 4412 times)

0 Members and 1 Guest are viewing this topic.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25725
  • Karma: 2822
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: no sound on laptop
« Reply #15 on: July 04, 2016, 08:45:04 pm »
It's not a perfect fix more of a workaround, but hey if it works right :)

You're welcome Bloch.

Seems you're not the only one with this issue on that laptop model
http://ubuntuforums.org/showthread.php?t=2323498
« Last Edit: July 04, 2016, 08:47:35 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Bloch

  • Member
  • ***
  • Posts: 112
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: no sound on laptop
« Reply #16 on: July 05, 2016, 10:39:54 am »
Hi, PCNetSpec.
The problem isn't not solved.
No sound again. How can i do?
Yes. No sound on laptops (All ubuntus based)

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25725
  • Karma: 2822
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: no sound on laptop
« Reply #17 on: July 05, 2016, 12:50:25 pm »
Does running the command manually work ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Bloch

  • Member
  • ***
  • Posts: 112
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: no sound on laptop
« Reply #18 on: July 06, 2016, 07:51:22 am »
Yes. It is the only way.

Alsactl Restore in Autostart won't work.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25725
  • Karma: 2822
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: no sound on laptop
« Reply #19 on: July 06, 2016, 02:23:07 pm »
so it worked before, but it doesn't now ?

if so, let's try adding a 5 second delay

Delete the "alsactl restore" command we previously entered in LXSession Default Settings

Now run:
Code: [Select]
pluma ~/.my-alsactl-restore-script.sh
make it read
Code: [Select]
#!/bin/bash
sleep 5 ; alsactl restore

    exit 0
SAVE the file and exit pluma

Now make it executable:
Code: [Select]
chmod +x ~/.my-alsactl-restore-script.sh
now in LXSession Default Settings add a new autostart commend that runs that script .. so

/home/<username>/.my-alsactl-restore-script.sh

obviously replacing <username> with your actual username.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Bloch

  • Member
  • ***
  • Posts: 112
  • Karma: 7
  • New Forum User
    • View Profile
  • Peppermint version(s): 7
Re: no sound on laptop
« Reply #20 on: July 09, 2016, 12:20:40 pm »
SOLVED!