Author Topic: Problem installing 7 on MSI Wind  (Read 1682 times)

Offline UUUnicorn

  • Newly Subscribed
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Five
Problem installing 7 on MSI Wind
« on: June 26, 2016, 11:13:48 am »
Help, please! Thank you in advance!

I tried installing Peppermint OS 7 32-bit from DVD in external optical drive onto my MSI Wind netbook, but a window opened with the information below. I don't know how to fix this.

Thank you very much in advance! BEAUTIFUL distro/release!

Unsafe Swap Space

An unsafe swap space has been detected.

This is a fatal error since sensitive data...

« Last Edit: June 26, 2016, 11:16:02 am by UUUnicorn »

Offline Timo

  • Member
  • ***
  • Posts: 163
  • Karma: 37
  • Open Source is more than the sum of its bytes
    • View Profile
  • Peppermint version(s): PM7 Respin (64bit) & PM8 (64bit)
Re: Problem installing 7 on MSI Wind
« Reply #1 on: June 26, 2016, 11:30:55 am »
Was this the auto installation or manual?
If manual have you created a swap partition?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Problem installing 7 on MSI Wind
« Reply #2 on: June 26, 2016, 11:42:14 am »
If this is to b e the ONLY OS on the netbook, boot to the Live session desktop, then open a terminal and run:
Code: [Select]
sudo swapoff --allif prompted for a password, just hit enter.

Now close the terminal and start the installation from the "Install Peppermint 7" desktop icon.

Basically it's just found a swap partition flagged as having a hibernation state saved.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline UUUnicorn

  • Newly Subscribed
  • *
  • Posts: 4
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Five
Re: Problem installing 7 on MSI Wind
« Reply #3 on: June 26, 2016, 01:41:38 pm »
Well, it seemed to install okay. When I restarted, though, the Peppermint OS splash screen appeared with the words "starting up" at the top, but it didn't go beyond it. When I hit "Enter", at the bottom of the screen, this appeared:

cryptsetup: cryptsetup failed, bad password or options?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Problem installing 7 on MSI Wind
« Reply #4 on: June 26, 2016, 01:53:36 pm »
Okay, it seems like what happened was on your previous OS you'd chosen disk encryption .. this gave you an encrypted swap partition, and explains the original error.

On a fresh install the easiest and quickest fix here would probably be for you to boot to the LiveUSB/LiveCD again, run:
Code: [Select]
sudo swapoff --allproa
then fire up Gparted and delete ALL partitions on the hard drive leaving only empty unpartitioned space.

Once applied and finished, close GParted, and reinstall from the desktop icon.
« Last Edit: June 26, 2016, 01:56:13 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec