Choose style:

Author Topic: Gis weather(SOLVED)  (Read 3186 times)

0 Members and 1 Guest are viewing this topic.

Online alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1149
  • Karma: 83
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Gis weather(SOLVED)
« on: April 17, 2016, 05:22:32 pm »
Hello Peppermint people. I installed My Weather Indicator and it worked good yesterday but today everything is N/A. So I installed gis weather, which is nice, but I would like to relocate it on the desktop and be able to start it and stop it at will just as I am able to do with My Weather Indicator. Is that possible? Thanks guys.
« Last Edit: April 21, 2016, 11:26:30 am by alynur »
What was I thinking?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Gis weather
« Reply #1 on: April 17, 2016, 05:35:16 pm »
No idea .. what's wrong with fixing "My Weather Indicator" ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1149
  • Karma: 83
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Gis weather
« Reply #2 on: April 17, 2016, 06:29:36 pm »
No idea .. what's wrong with fixing "My Weather Indicator" ?

How would we do that?
What was I thinking?

Online VinDSL

  • Administrator
  • Hero
  • *****
  • Posts: 5597
  • Karma: 1012
  • Peppermint Mod
    • View Profile
  • Peppermint version(s): Developmental Builds
Re: Gis weather
« Reply #3 on: April 17, 2016, 06:45:00 pm »
Looks like they started a bug on this:  https://bugs.launchpad.net/my-weather-indicator/+bug/1569040

You could watch the page or, better yet, subscribe.   ;)

EDIT

Reading through the bugs, it looks like the Yahoo.com API changed.

Supposedly, version 0.7.10-0extras15.10.1 fixes the prob.

You might try upgrading to that ver:  http://www.ubuntuupdates.org/package/atareao_atareao/trusty/main/base/my-weather-indicator
« Last Edit: April 17, 2016, 06:56:30 pm by VinDSL, Reason: Addendum »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Gis weather
« Reply #4 on: April 18, 2016, 06:29:50 am »
Try this:
Code: [Select]
sudo killall my-weather-indicator
then
Code: [Select]
sudo apt-get remove --purge my-weather-indicator
then
Code: [Select]
sudo apt-get autoremove
then
Code: [Select]
sudo rm -rv /opt/extras.ubuntu.com/my-weather-indicator
then
Code: [Select]
rm -rv ~/.config/my-weather-indicator
then
Code: [Select]
sudo apt-get update
then
Code: [Select]
sudo apt-get install --reinstall gir1.2-gtk-3.0 gir1.2-gdkpixbuf-2.0 gir1.2-appindicator3-0.1 gir1.2-notify-0.7 gir1.2-webkit-3.0 python3-tz python3-cairo python-lxml python-dateutil python3-requests python3-httplib2
then
Code: [Select]
cd ~/Downloads
then
Code: [Select]
wget https://launchpad.net/~atareao/+archive/ubuntu/atareao/+files/my-weather-indicator_0.7.10-0extras15.10.1_all.deb
then
Code: [Select]
sudo dpkg -i my-weather-indicator_0.7.10-0extras15.10.1_all.deb
now try starting it
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1149
  • Karma: 83
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Gis weather
« Reply #5 on: April 18, 2016, 03:45:31 pm »
Looks like they started a bug on this:  https://bugs.launchpad.net/my-weather-indicator/+bug/1569040

You could watch the page or, better yet, subscribe.   ;)

EDIT

Reading through the bugs, it looks like the Yahoo.com API changed.

Supposedly, version 0.7.10-0extras15.10.1 fixes the prob.

You might try upgrading to that ver:  http://www.ubuntuupdates.org/package/atareao_atareao/trusty/main/base/my-weather-indicator
Hi VinDSL I tried installing the extra file version but it was the same as what was already installed, at any rate, it still doesn't work

Try this:
Code: [Select]
sudo killall my-weather-indicator
then
Code: [Select]
sudo apt-get remove --purge my-weather-indicator
then
Code: [Select]
sudo apt-get autoremove
then
Code: [Select]
sudo rm -rv /opt/extras.ubuntu.com/my-weather-indicator
then
Code: [Select]
rm -rv ~/.config/my-weather-indicator
then
Code: [Select]
sudo apt-get update
then
Code: [Select]
sudo apt-get install --reinstall gir1.2-gtk-3.0 gir1.2-gdkpixbuf-2.0 gir1.2-appindicator3-0.1 gir1.2-notify-0.7 gir1.2-webkit-3.0 python3-tz python3-cairo python-lxml python-dateutil python3-requests python3-httplib2
then
Code: [Select]
cd ~/Downloads
then
Code: [Select]
wget https://launchpad.net/~atareao/+archive/ubuntu/atareao/+files/my-weather-indicator_0.7.10-0extras15.10.1_all.deb
then
Code: [Select]
sudo dpkg -i my-weather-indicator_0.7.10-0extras15.10.1_all.deb
now try starting it

Hi PCNetSpec, I followed these instructions and the app doesn't open I got this after running the last instruction

 
Code: [Select]
sudo dpkg -i my-weather-indicator_0.7.10-0extras15.10.1_all.deb
Selecting previously unselected package my-weather-indicator.
(Reading database ... 280936 files and directories currently installed.)
Preparing to unpack my-weather-indicator_0.7.10-0extras15.10.1_all.deb ...
Unpacking my-weather-indicator (0.7.10-0extras15.10.1) ...
dpkg: dependency problems prevent configuration of my-weather-indicator:
 my-weather-indicator depends on gir1.2-geocodeglib-1.0; however:
  Package gir1.2-geocodeglib-1.0 is not installed.
 my-weather-indicator depends on python3-dateutil; however:
  Package python3-dateutil is not installed.
 my-weather-indicator depends on python3-requests-oauthlib; however:
  Package python3-requests-oauthlib is not installed.

dpkg: error processing package my-weather-indicator (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for fontconfig (2.11.0-0ubuntu4.1) ...
Errors were encountered while processing:
 my-weather-indicator

What was I thinking?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Gis weather
« Reply #6 on: April 18, 2016, 06:50:48 pm »
Okay they must have added some dependencies, try
Code: [Select]
sudo apt-get remove --purge my-weather-indicator
then
Code: [Select]
sudo apt-get install gir1.2-geocodeglib-1.0 python3-dateutil python3-requests-oauthlib
then
Code: [Select]
cd ~/Downloads
then
Code: [Select]
sudo dpkg -i my-weather-indicator_0.7.10-0extras15.10.1_all.deb
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1149
  • Karma: 83
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Gis weather
« Reply #7 on: April 18, 2016, 08:31:35 pm »
Okay, now it's opening again but still all the information is N/A so we're where we were when we started.
What was I thinking?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Gis weather
« Reply #8 on: April 19, 2016, 06:45:09 am »
Okay probably the best thing to do would be to remove the 0.7.10 version, remove the PPA (so it doesn't get updated), and reinstall the working 0.7.1 version.
https://launchpad.net/~atareao/+archive/ubuntu/atareao/+files/my-weather-indicator_0.7.1-0extras15.10.0_all.deb
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1149
  • Karma: 83
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Gis weather
« Reply #9 on: April 19, 2016, 10:23:15 am »
Okay probably the best thing to do would be to remove the 0.7.10 version, remove the PPA (so it doesn't get updated), and reinstall the working 0.7.1 version.
https://launchpad.net/~atareao/+archive/ubuntu/atareao/+files/my-weather-indicator_0.7.1-0extras15.10.0_all.deb
Hi again, this is what's installed. And it doesn't work either. I guess I should ask, how do I remove the PPA of the first version?
« Last Edit: April 19, 2016, 10:25:02 am by alynur »
What was I thinking?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Gis weather
« Reply #10 on: April 19, 2016, 10:47:05 am »
What's the output from this long command:
Code: [Select]
for APT in `find /etc/apt/ -name \*.list`; do grep -o "^deb http://ppa.launchpad.net/[a-z0-9\-]\+/[a-z0-9\-]\+" $APT | while read ENTRY ; do USER=`echo $ENTRY | cut -d/ -f4` PPA=`echo $ENTRY | cut -d/ -f5` ; echo ppa:$USER/$PPA ; done ; done
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1149
  • Karma: 83
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Gis weather
« Reply #11 on: April 19, 2016, 10:57:24 am »
What's the output from this long command:
Code: [Select]
for APT in `find /etc/apt/ -name \*.list`; do grep -o "^deb http://ppa.launchpad.net/[a-z0-9\-]\+/[a-z0-9\-]\+" $APT | while read ENTRY ; do USER=`echo $ENTRY | cut -d/ -f4` PPA=`echo $ENTRY | cut -d/ -f5` ; echo ppa:$USER/$PPA ; done ; done

Code: [Select]
ppa:rvm/smplayer
ppa:pipelight/stable
ppa:peppermintos/p6-release
ppa:me-davidsansome/clementine
ppa:ffdiaporamateam/stable
ppa:atareao/atareao
ppa:noobslab/apps
ppa:mc3man/mpv-tests
ppa:ubuntu-wine/ppa
« Last Edit: January 08, 2017, 06:07:17 pm by AndyInMokum, Reason: Encapsulation output with [code]. »
What was I thinking?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26466
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Gis weather
« Reply #12 on: April 19, 2016, 11:07:43 am »
To remove the PPA (ppa:atareao/atareao) but leave any software installed from it intact
Code: [Select]
sudo add-apt-repository --remove ppa:atareao/atareao



To purge the PPA (ppa:atareao/atareao) including removing all software installed from it
Code: [Select]
sudo apt-get install ppa-purge
then
Code: [Select]
sudo ppa-purge ppa:atareao/atareao
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Online alynur

  • Trusted User
  • Veteran
  • *****
  • Posts: 1149
  • Karma: 83
  • Habitual Forum Browser
    • View Profile
  • Peppermint version(s): P 9R (64bit), P 10
Re: Gis weather
« Reply #13 on: April 21, 2016, 11:24:22 am »
To remove the PPA (ppa:atareao/atareao) but leave any software installed from it intact
Code: [Select]
sudo add-apt-repository --remove ppa:atareao/atareao



To purge the PPA (ppa:atareao/atareao) including removing all software installed from it
Code: [Select]
sudo apt-get install ppa-purge
then
Code: [Select]
sudo ppa-purge ppa:atareao/atareao
Okay, after completing above instructions I still had My Weather Indicator that would launch and still had N/A for all info.? So I performed sudo apt-get remove my-weather-indicator and finally it was no longer available. I then installed the deb file I had previously downloaded from Ubuntu's web site, the same one that was installed, and it installed and worked like it should. So I decided to wait until today, which it is still working, to post back that it is now working. So I don't know. I guess if it stops working again, I'll perform the ppa purge and then reinstall the deb file I have saved in downloads. Anyway, so far so good, thanks guys, until the next time :)
What was I thinking?

Offline PeppermintKelley

  • Member
  • ***
  • Posts: 100
  • Karma: 3
  • New to Peppermint
    • View Profile
  • Peppermint version(s): Peppermint 7 Respin (64bit)
Re: Gis weather(SOLVED)
« Reply #14 on: January 08, 2017, 12:39:42 pm »
I'm new to Peppermint and I am using version 7.
I wanted to load Gis-Weather and I see this thread is a tutorial on how to install My Weather Indicator.

Here is how I installed Gis Weather.

Gis-Weather Widget
http://www.noobslab.com/2016/12/gis-weather-widget-updated-and-now.html

Code: [Select]
sudo add-apt-repository ppa:noobslab/apps
Code: [Select]
sudo apt-get update
Code: [Select]
sudo apt-get install gis-weather

https://github.com/RingOV/gis-weather/wiki/How-to:-AccuWeather-city-code
http://www.accuweather.com/en/us/cary-nc/27513/weather-forecast/334877
City code for AccuWeather Cary NC is
us/cary-nc/27513,334877

Kelley
« Last Edit: January 08, 2017, 06:03:29 pm by AndyInMokum, Reason: Encapsulating instructions with [code] »
Former Linux Mint user who has made the switch to Peppermint 7.