Choose style:

Author Topic: Pc fan always working [Solved]  (Read 1572 times)

0 Members and 1 Guest are viewing this topic.

Offline Alex

  • Jr. Member
  • **
  • Posts: 98
  • Karma: 8
    • View Profile
Pc fan always working [Solved]
« on: April 01, 2016, 10:55:03 am »
Hi.
Cpu fan is always running since i installed Peppermint 6 32bit in my netbook? What is the solution to solve this problem?
I tried this, but not works. http://linuxforums.org.uk/index.php?topic=12502.0 (stage 9 by PcNetSpec)
Thanks.
« Last Edit: April 02, 2016, 10:49:48 pm by Alex »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Pc fan always working
« Reply #1 on: April 01, 2016, 11:03:58 am »
What's the make/model of netbook ?
and the output from:
Code: [Select]
uname -a



In fact please post the output from:
Code: [Select]
inxi -F
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Pc fan always working
« Reply #2 on: April 01, 2016, 11:33:48 am »
OK, the following instructions are for a single boot ONLY.

Turn ON your PC, and as soon as your BIOS POST screen disappears, press the SHIFT key and hold it, until you are presented with the GRUB menu .. SIMILAR to this:
(you won't have long to hit the shift key, and the timing can be a little awkward, so it may even be easier to hit AND HOLD the Shift key DURING the BIOS POST .. ie. immediately after turning on your PC)


Select the 'default' kernel (the top one), and rather than pressing enter, press E to edit.

You will be presented with a screen SIMILAR to this:


Press DOWN ARROW until you get to the line that starts with:

Quote
linux /boot

and press the END key to position the cursor at the end of the that line... it *usually* ends with “quiet splash”.

Now you can enter additional kernel boot options... so add acpi_osi=Linux as in the above screenshot (except replacing nomodeset with acpi_osi=Linux) .. so that line now contains:

Quote
quiet splash acpi_osi=Linux
(doesn't matter if it moves down a line, as long as there is a space between splash and acpi_osi=Linux)

Now hit Ctrl+X to boot.

and test the fan

WARNING - be vigilant to see if the fan comes on AT ALL .. if it doesn't and your PC appears to be getting TOO hot, reboot .. a reboot will remove the change.

If this works, we can easily make it permanent.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Alex

  • Jr. Member
  • **
  • Posts: 98
  • Karma: 8
    • View Profile
Re: Pc fan always working
« Reply #3 on: April 01, 2016, 12:08:19 pm »
I replace the end of line quiet splash "handoff "with acpi_osi=Linux. I found "handoff in the end of the line.
Fan is working. I don't no. How I check netbook temperature? Why  i have this problem?

3.16.0-67-generic i686 is my default kernel.
« Last Edit: April 01, 2016, 12:13:48 pm by Alex »

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1013
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: Pc fan always working
« Reply #4 on: April 01, 2016, 02:01:08 pm »
Hi Alex, could you please remember to encapsulate terminal outputs with the Insert, Code # function.  For extra long outputs, please use the Spoiler, Sp function.  It preserves the original format of the output.  This makes it easier for future visitors to relate to their own issues.  These functions are found in the forum editor, above the,  :-[ Embarrassed and  the :'( Cry emoticon respectively.  I've done this for you this time - many thanks  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Pc fan always working
« Reply #5 on: April 01, 2016, 03:01:23 pm »
Is the fan now going on and off ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Alex

  • Jr. Member
  • **
  • Posts: 98
  • Karma: 8
    • View Profile
Re: Pc fan always working
« Reply #6 on: April 02, 2016, 05:10:04 pm »
Hi, PCNetSpec.
Yes, fan going on and off.
Thanks for support.

"If this works, we can easily make it permanent."

How?


Sorry, AndyInMokum. Thanks for your advice.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Pc fan always working
« Reply #7 on: April 02, 2016, 06:00:13 pm »
Open a terminal and run:
Code: [Select]
sudo cp -v /etc/default/grub /etc/default/grub.bak
then:
Code: [Select]
sudo gedit /etc/default/grub
find the line that reads
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and change it to
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"
SAVE the file and exit gedit.

Back in the terminal run:
Code: [Select]
sudo update-grub
reboot to test.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Alex

  • Jr. Member
  • **
  • Posts: 98
  • Karma: 8
    • View Profile
Re: Pc fan always working
« Reply #8 on: April 02, 2016, 10:49:13 pm »
Thanks, PcNetSpec.
Cheers.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26290
  • Karma: 2855
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Pc fan always working [Solved]
« Reply #9 on: April 03, 2016, 07:15:22 am »
You're welcome :)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec