Author Topic: Fn-Brightness keys on Asus X200M not working properly [SOLVED]  (Read 2071 times)

Offline DrMartinus

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Hi,

I have installed peppermint 6 on my Asus EeePC X200M, and it's working fine except for one issue: the Fn-Brightness keys don't work. I tried a fix that had been recommended by others. I added
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=linux acpi_osi="into the grup bootloader. This changed the behaviour in a way, because now I see a window on the desktop showing me the brightness scale and according to which key I press, also moving to brighter or darker. Yet, the brightness doesn't change at all.
I also tried
Code: [Select]
xbackground -dec -10and other values, but that didn't change anything either.
I also tried
Code: [Select]
xgamma -gamma 0.5wich actually changed the gamma values, but not the background light's brightness, which I primarily desire in order to save power. As of now, I am clueless. Does anyone here have an idea?

BTW, I read about a tool incorporated into the panel that should provide an easy way to change the monitor brightness, but I don't see anything of that sort in my panel, even though the installation is fresh and I haven't made any alterations except updating the packages for which updates were available.

Thanks for any help!

Martin
« Last Edit: March 15, 2016, 05:11:09 am by DrMartinus »

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Fn-Brightness keys on Asus X200M not working properly
« Reply #1 on: March 13, 2016, 09:22:15 am »
Have you tried (one at a time) one of these kernel boot parameters in place of your "acpi_osi=linux acpi_osi="

acpi_backlight=video
or
acpi_backlight=vendor
or
acpi_backlight=native
or
acpi_backlight=none
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline DrMartinus

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Fn-Brightness keys on Asus X200M not working properly
« Reply #2 on: March 14, 2016, 11:10:41 pm »
I tried all the options, with and without the options I added, it didn't make any difference.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Fn-Brightness keys on Asus X200M not working properly
« Reply #3 on: March 15, 2016, 12:17:02 am »
I tried all the options, with and without the options I added, it didn't make any difference.
You could try this, if you have an Intel graphics card: Fix Brightness Control Not Working for Ubuntu 14.04 & Linux Mint 17.  Good luck  ;).
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline DrMartinus

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Fn-Brightness keys on Asus X200M not working properly [SOLVED]
« Reply #4 on: March 15, 2016, 05:09:04 am »
Well, that worked. Thank you very much! For all who might have the same problem:

1. Check if the graphics chip is Intel. If so, continue:
2. create (as root) a file in /usr/share/X11/xorgconf.d named "20-intel.conf"
3. If the file already exists edit it, else put into the file the following lines (as root):
Code: [Select]
Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection
4. Go to /etc/default and open the file grub (as root)
5. Edit the line that begins with "GRUB_CMDLINE_LINUX_DEFAULT as follows:
Code: [Select]
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="The important part ist the "acpi_osi="
5. run
Code: [Select]
sudo update-grub
That should do it. It did it for me.

« Last Edit: March 15, 2016, 05:10:47 am by DrMartinus »

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Fn-Brightness keys on Asus X200M not working properly [SOLVED]
« Reply #5 on: March 15, 2016, 06:21:58 am »
Great, I'm glad it worked out for you  ;).  I'm not sure why you're editing the the /etc/default/grub file.  I never had to mess with: acpi_osi  :-\.  Thanks for marking the topic as [SOLVED]  ;).
« Last Edit: March 15, 2016, 06:26:56 am by AndyInMokum »
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline DrMartinus

  • Newly Subscribed
  • *
  • Posts: 5
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): 6
Re: Fn-Brightness keys on Asus X200M not working properly [SOLVED]
« Reply #6 on: March 16, 2016, 10:10:15 am »
The acpi_osi was not in my grub, and without it, the Fn-Brightness-keys wouldn't work.  That's why it needs to be added. Maybe in other systems it's already there.

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4889
  • Karma: 1058
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 10 (64-bit)
Re: Fn-Brightness keys on Asus X200M not working properly [SOLVED]
« Reply #7 on: March 16, 2016, 11:14:42 am »
The acpi_osi was not in my grub, and without it, the Fn-Brightness-keys wouldn't work.  That's why it needs to be added. Maybe in other systems it's already there.
Weird, I don't have it in any of my computers and the Fn-Brightness works fine after the initial tweak  :-\.  I was just curious.
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.