Author Topic: Problems with the Bluetooth Part Intel Wireless 7260 AC (Solved/Alternative Way)  (Read 3819 times)

Offline Horsesgamer

  • Newly Subscribed
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint Eight X86_64
I Use now Since 4 Monts or So Peppermint 6
But i Have a Few Problems with the Funktions of the Hardware.

1.) Bluetooth
My LAptop Came with Onboard Bluetooth and Wlan Card Both Old and Slow.
But i Bought a Intel AC7260 with Bluetooth 4.0 Module onboard. an there is the Problem.
I Removed the Old ABGN Card and Replaced it with AC7260 worked Fine and Wifi Works with My Fritzbox 7490 in AC Mode.
The Only Problem is The Bluetooth i Have still the Onboard Only working the One from The Wifi Card didnt get Reconized.
If i Unplug the Onboard Bluetooth which is just a Small Module Onboard with an Cable i can Remove.
Then Peppermint Say there is No Bluetooth Adapter Installed.

Code: [Select]
Bus 003 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

2.) Graphiccard
Everytime i Reboot my System i get after the Desktop Loads Grafikerror  (Small Lines over the Screen).
The Only Way to get my Desktop Back is STRG + ALT + F8 and then STRG + ALT + F7 to get it Working.
Latest Proprietary NV Driver is Installed (304.131) others arent working


Maybe Someone Knows a Ho to Fix those Problem
Just the Bluetooth Thing would be Enough.
That i Can Connect and Use My Bluetooth Speaker and Headset and Transfer Files Faster than with the OLD Bluetooth Module.
« Last Edit: March 03, 2016, 01:58:29 am by Horsesgamer »
My System
atm on LXLE Since Peppermint Broke and i don't Get 8 Respin Running Waiting for Peppermint 9

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Few Problems With FS Amilo Xi1526
« Reply #1 on: February 27, 2016, 06:30:52 am »
Can you run:
Code: [Select]
dmesg > ~/Desktop/dmesg.txtyou'll then find a file called dmesg.txt on your desktop.

Can you host that file online somewhere, and provide a link to it.



When you have the garbled graphics, does dropping to a console with:
Stgr+All+F3
then running
sudo service lightdm restart
then logging in also fix the graphics anomolies ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Horsesgamer

  • Newly Subscribed
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint Eight X86_64
Re: Few Problems With FS Amilo Xi1526
« Reply #2 on: February 27, 2016, 03:28:26 pm »
Thats the Version with old Bluetooth Module Connected.
https://drive.google.com/file/d/0B0VIEfNgmBpTMjB0d3NkWUl1QnM/view?usp=sharing

I will add a Version with the Old Module unplugged if you want.
« Last Edit: February 27, 2016, 03:34:13 pm by Horsesgamer »
My System
atm on LXLE Since Peppermint Broke and i don't Get 8 Respin Running Waiting for Peppermint 9

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Few Problems With FS Amilo Xi1526
« Reply #3 on: February 27, 2016, 04:08:46 pm »
Okay I'm lost here .. how can you have the old adapter and the new one attached at the same time ?

Were the original ones two separate physical cards, but the new one is a combo card that fits into just the wireless socket ? .. if this is the cased I doubt if the socket has the physical circuitry necessary to run the bluetooth side of the card.
« Last Edit: February 27, 2016, 04:12:22 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Horsesgamer

  • Newly Subscribed
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint Eight X86_64
Re: Few Problems With FS Amilo Xi1526
« Reply #4 on: February 27, 2016, 07:19:23 pm »
Before Wifi and Bluetooth where Seperate Cards.
But the New WiFi Card has Bluetooth Onboard  and if i Remember Right it did work Under Win10  But Win10 is a PAIN because Driver Manager kicks and Replaces Drivers Without Reasons.
And The Windows 7 Installation i kicked for Peppermint did Reconize the Card including the Bluetooth Module.
The Old Bluetooth is his OWn Module mit Own Connection


But i Found something that doesnt make me Happy
https://wireless.wiki.kernel.org/en/users/Drivers/iwlwifi

Easy Said the 7260 i Have is a Pain with Drivern and it looks Like even the Developer of iwlwifi put the Developing of Drivers in the trash.
There is NO DRIVER Which Supports Bluetooth and Wifi all Drivers Writen are WiFi Only.

Looks Like i Have to Get Sometime another Card that has Working Driver for Bluetooth and WiFi under Linux.
My System
atm on LXLE Since Peppermint Broke and i don't Get 8 Respin Running Waiting for Peppermint 9

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Few Problems With FS Amilo Xi1526
« Reply #5 on: February 28, 2016, 08:32:31 am »
Where are you getting that from ? .. the iwlwifi driver has the bluetooth coexist option, why would that be there if bluetooth wasn't enabled in the driver ?

What's the output from:
Code: [Select]
hcitool devand
Code: [Select]
hciconfig
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Horsesgamer

  • Newly Subscribed
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint Eight X86_64
Re: Few Problems With FS Amilo Xi1526
« Reply #6 on: February 28, 2016, 01:14:06 pm »
hcitool dev
Code: [Select]
Devices:
hci0 00:10:60:D0:0A:6D

And hciconfig brings up

Code: [Select]
hci0: Type: BR/EDR  Bus: USB
BD Address: 00:10:60:D0:0A:6D  ACL MTU: 384:8  SCO MTU: 64:8
UP RUNNING PSCAN
RX bytes:1030 acl:0 sco:0 events:49 errors:0
TX bytes:452 acl:0 sco:0 commands:48 errors:0

But thats Still from the Old 3.0 Bluetooth Module which is pre installed

_____

Here mal with the Old Module unplugged from Mainboard.

Dmesg
https://drive.google.com/open?id=0B0VIEfNgmBpTSU8zV3E2NDRmY00

Other commands dont bring anything anymore because there i no Bluetooth installed or better said no Driver for Loadet.

Thats what i think is the Problem that the iwlwifi Things are not completly set up or installed.
« Last Edit: February 28, 2016, 01:34:33 pm by Horsesgamer »
My System
atm on LXLE Since Peppermint Broke and i don't Get 8 Respin Running Waiting for Peppermint 9

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Few Problems With FS Amilo Xi1526
« Reply #7 on: February 28, 2016, 02:19:07 pm »
Apparently the bluetooth side of the adapter is USB (even though wireless is PCIe), so does
Code: [Select]
lsusbshow anything connected ?
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Horsesgamer

  • Newly Subscribed
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint Eight X86_64
Re: Few Problems With FS Amilo Xi1526
« Reply #8 on: February 28, 2016, 05:57:22 pm »
It Cant be Showed Up because the Old Module is Unplugged.

Code: [Select]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 041e:0011 Creative Technology, Ltd
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

My System
atm on LXLE Since Peppermint Broke and i don't Get 8 Respin Running Waiting for Peppermint 9

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Few Problems With FS Amilo Xi1526
« Reply #9 on: February 29, 2016, 03:56:23 am »
Nope, doesn't appear to be being detected at all :-\ .. what's the output from:
Code: [Select]
lspci -vnn | grep -i netand
Code: [Select]
rfkill list
[EDIT]

Just as a matter of interest, can you download an Ubuntu 16.04 ISO, and see if the adapter is recognised in that .. maybe the more recent kernel will support that cards chipset better .. if it does, maybe we can try a more recent kernel in Peppermint 6
« Last Edit: February 29, 2016, 04:00:07 am by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Horsesgamer

  • Newly Subscribed
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint Eight X86_64
Re: Few Problems With FS Amilo Xi1526
« Reply #10 on: February 29, 2016, 06:07:29 am »
Code: [Select]
horsesgamer@Horsesgamer-Lap ~ $ lspci -vnn | grep -i net
04:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev bb)
05:05.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8169 PCI Gigabit Ethernet Controller [10ec:8169] (rev 10)
horsesgamer@Horsesgamer-Lap ~ $

Code: [Select]
horsesgamer@Horsesgamer-Lap ~ $ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
horsesgamer@Horsesgamer-Lap ~ $



That with Ubuntu could i Try even i had Problems with 14.04 getting it Running.
Downloading 16.04 Yesterdays Build
_____

So now did Test 16.04 which was a bit of pain but got it Bootin from USB.
And No Even after Installin the Propitary Drivers for the CPU? and the GPU
There was no Bluetooth option.
There is a Dmesg for ya https://drive.google.com/open?id=0B0VIEfNgmBpTNTJremI0U3hfZlk

And there the Other Commands
Code: [Select]
ubuntu@ubuntu:~$ dmesg > ~/Desktop/dmesg.txt
ubuntu@ubuntu:~$ hcitool dev
Devices:
ubuntu@ubuntu:~$ hciconfig
ubuntu@ubuntu:~$ lsusb
Bus 001 Device 002: ID 0781:5567 SanDisk Corp. Cruzer Blade
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 041e:0011 Creative Technology, Ltd
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 006 Device 002: ID 14cd:1212 Super Top microSD card reader (SY-T18)
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
ubuntu@ubuntu:~$ lspci -vnn | grep -i net
04:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev bb)
05:05.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8169 PCI Gigabit Ethernet Controller [10ec:8169] (rev 10)
Subsystem: Fujitsu Technology Solutions RTL8169 PCI Gigabit Ethernet Controller [1734:10ac]
ubuntu@ubuntu:~$ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
ubuntu@ubuntu:~$
« Last Edit: February 29, 2016, 07:32:37 am by Horsesgamer »
My System
atm on LXLE Since Peppermint Broke and i don't Get 8 Respin Running Waiting for Peppermint 9

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 26452
  • Karma: 65531
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 10
Re: Problems with the Bluetooth Part Intel Wireless 7260 AC
« Reply #11 on: March 01, 2016, 03:51:56 am »
Nope, I'm afraid the bluetooth side of the hardware isn't being picked up at all so I'm not sure there's anything else we can do.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline Horsesgamer

  • Newly Subscribed
  • *
  • Posts: 16
  • Karma: 0
  • New Forum User
    • View Profile
  • Peppermint version(s): Peppermint Eight X86_64
Re: Problems with the Bluetooth Part Intel Wireless 7260 AC
« Reply #12 on: March 01, 2016, 08:16:08 am »
Well then did Buy an USB Buetooth Donge now.
Hoped to Save an USB Port But yea Paid just a Bit extra to Get this Combocard With WiFi and Bluetooth.
Now i was Forced to Get that USB Dongle Because a Bluetooth 4 board with that Connector i have onboard dosnt Exist. (Bluetooth 3 Was the LAst and Only)
Have to Hope that My Buyed Parts are Coming in Time Before CeBIT 2016.
Good Thing is if The Dongle Works, i can connect my Big Bluetooth Speaker with that instead using the USB Cable.

___
EDIT:
My Dongle is here and is now Working Feels Good to Have Working and Faster Bluetooth.
Found out that the Old one was Only Bluetooth 2.0 not 3.0
My New One
Code: [Select]
horsesgamer@Horsesgamer-Lap ~ $ hciconfig -a
hci0: Type: BR/EDR  Bus: USB
BD Address: 00:1A:7D:DA:71:0C  ACL MTU: 310:10  SCO MTU: 64:8
UP RUNNING PSCAN
RX bytes:1194 acl:0 sco:0 events:69 errors:0
TX bytes:1556 acl:0 sco:0 commands:69 errors:0
Features: 0xff 0xff 0x8f 0xfe 0xdb 0xff 0x5b 0x87
Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
Link policy: RSWITCH HOLD SNIFF PARK
Link mode: SLAVE ACCEPT
Name: 'Horsesgamer-Lap'
Class: 0x6c0100
Service Classes: Rendering, Capturing, Audio, Telephony
Device Class: Computer, Uncategorized
HCI Version: 4.0 (0x6)  Revision: 0x22bb
LMP Version: 4.0 (0x6)  Subversion: 0x22bb
Manufacturer: Cambridge Silicon Radio (10)

Thread can be Closed.
« Last Edit: March 03, 2016, 01:57:34 am by Horsesgamer »
My System
atm on LXLE Since Peppermint Broke and i don't Get 8 Respin Running Waiting for Peppermint 9