Choose style:

Author Topic: no wifi connection (SOLVED)  (Read 8532 times)

0 Members and 1 Guest are viewing this topic.

Offline ste956888

  • nOOb
  • *
  • Posts: 12
  • Karma: 0
  • New Forum User
    • View Profile
no wifi connection (SOLVED)
« on: May 18, 2014, 09:42:04 am »
Hello, I'm a new user. I've just installed Peppermint on an old Acer Aspire 1672 WLMi.

The wifi button is on, but if I disconnect the Lan router cable I receive the messagge "fuori rete" (I'm Italian), i.e. no connection.

What should I do to use my wifi network?

Thanks.
« Last Edit: May 25, 2014, 04:28:02 pm by ste956888 »

Offline AndyInMokum

  • Global Moderator
  • Hero
  • *****
  • Posts: 4808
  • Karma: 1012
  • "Keep on Rockin' in the Free World"
    • View Profile
  • Peppermint version(s): PM 9 & PM 8 Respin-2 (64-bit)
Re: no wifi connection
« Reply #1 on: May 18, 2014, 10:11:40 am »
Hi ste956888, welcome to the forums.  Left lick on the WiFi bar graph icon in the panel.  Select your network from the drop down menu.  If it isn't visible, select  More Networks.  Find your network and select it.  You will be asked for your user password,  This is the one you chose at installation.  After you enter your password, select Authenticate.  You will now be asked to enter your WiFi password.  Hit enter and you should now have Wifi.  I hope that this helps.  Good luck and have fun  ;)!
Backup! Backup! Backup! If you're missing any of these -  you ain't Backed Up!
For my system info please L/click HERE.

Offline ste956888

  • nOOb
  • *
  • Posts: 12
  • Karma: 0
  • New Forum User
    • View Profile
Re: no wifi connection
« Reply #2 on: May 18, 2014, 10:25:01 am »
Hello Andy, thanks for your reply. Actually there's no wifi icon in the panel, just a symbol referred to the wire connection. I tried to left click on it but the only option was to eneble or disable it.

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: no wifi connection
« Reply #3 on: May 18, 2014, 10:49:19 am »
Can you open a terminal (Ctrl+Alt+T), and post the output from running the following command:
Code: [Select]
lshw -C network
it'll take3 a few seconds to complete .. so give it time ;)

and remember linux commands ARE case sensitive .. so that's a capital C
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline ste956888

  • nOOb
  • *
  • Posts: 12
  • Karma: 0
  • New Forum User
    • View Profile
Re: no wifi connection
« Reply #4 on: May 18, 2014, 11:12:01 am »
Here it is

WARNING: you should run this program as super-user.
  *-network:0 UNCLAIMED   
       description: Ethernet controller
       product: IPN 2220 802.11g
       vendor: InProComm Inc.
       physical id: 2
       bus info: pci@0000:02:02.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list
       configuration: latency=64 maxlatency=32 mingnt=32
       resources: ioport:a480(size=32) memory:e8201000-e820101f memory:e8200800-e8200fff
  *-network:1
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 3
       bus info: pci@0000:02:03.0
       logical name: eth0
       version: 10
       serial: 00:0f:b0:5f:2a:8d
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=full ip=192.168.1.130 latency=128 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100Mbit/s
       resources: irq:19 ioport:a000(size=256) memory:e8201400-e82014ff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

To me reads like Arabic, but for you may be clear?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: no wifi connection
« Reply #5 on: May 18, 2014, 12:08:56 pm »
OK, with a wired connection (so you have an active internet connection), open a terminal and run these commans in sequence:
Code: [Select]
sudo apt-get update
then
Code: [Select]
sudo apt-get upgrade
then
Code: [Select]
sudo apt-get dist-upgrade
then REBOOT.

Once rebooted, run:
Code: [Select]
cd ~
then
Code: [Select]
wget https://dl.dropboxusercontent.com/u/11876059/ipn2220-xp.tar.gz
then
Code: [Select]
tar xvf ipn2220-xp.tar.gz
then
Code: [Select]
sudo apt-get install linux-headers-generic build-essential dkms ndisgtk ndiswrapper-dkms

Now in the menu's go to:-

menu > System Tools > Windows Wireless Drivers

Click "Install New Driver" and in the resulting window click where it says "(none" .. then in the left hand column select "File System"
in the right panel enter into
/home/<your-usrename>/ipn222-xp
and select the
neti2220.inf
file, and click "Open" .. then click "Install"

Did wireless spring to life ?

You can check by normal (left) clicking the NetworkManager icon (in the system tray - by the clock), and seeing if any wireless networks are listed.
« Last Edit: May 18, 2014, 12:10:46 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline ste956888

  • nOOb
  • *
  • Posts: 12
  • Karma: 0
  • New Forum User
    • View Profile
Re: no wifi connection
« Reply #6 on: May 18, 2014, 01:07:07 pm »
Hello, J've followed the instructions... but at the last step I've got the message "not a valid driver .inf file"

Am I hopeless ??

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: no wifi connection
« Reply #7 on: May 18, 2014, 01:21:37 pm »
I'm going to guess you pointed it at the

neti2220.PNF

file.

where you SHOULD have pointed it at the

neti2220.inf

file...

Try again ;)
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline ste956888

  • nOOb
  • *
  • Posts: 12
  • Karma: 0
  • New Forum User
    • View Profile
Re: no wifi connection
« Reply #8 on: May 18, 2014, 01:32:23 pm »
Well, you were right. sorry.

Now it said driver installed, but apparently nothing has changed. There's no icon for the wireless connection in the panel, nor elsewhere on the screen... shall I reboot?

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: no wifi connection
« Reply #9 on: May 18, 2014, 01:46:21 pm »
Yeah .. try rebooting, then post the output from:
Code: [Select]
lshw -C network
again.



also post the output from:
Code: [Select]
sudo iwlist scanning
« Last Edit: May 18, 2014, 01:49:50 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline ste956888

  • nOOb
  • *
  • Posts: 12
  • Karma: 0
  • New Forum User
    • View Profile
Re: no wifi connection
« Reply #10 on: May 18, 2014, 02:36:10 pm »
Hi, here I am again.

This is the result of the posts:

lshw -C network
WARNING: you should run this program as super-user.
  *-network:0             
       description: Wireless interface
       product: IPN 2220 802.11g
       vendor: InProComm Inc.
       physical id: 2
       bus info: pci@0000:02:02.0
       logical name: wlan0
       version: 00
       serial: 00:0e:9b:93:e3:0c
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ndiswrapper+neti2220 driverversion=1.58+INPROCOMM,11/04/2004,3.03.1 latency=64 link=no maxlatency=32 mingnt=32 multicast=yes wireless=IEEE 802.11g
       resources: irq:18 ioport:a480(size=32) memory:e8201000-e820101f memory:e8200800-e8200fff
  *-network:1
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 3
       bus info: pci@0000:02:03.0
       logical name: eth0
       version: 10
       serial: 00:0f:b0:5f:2a:8d
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=full ip=192.168.1.130 latency=128 link=yes maxlatency=64 mingnt=32 multicast=yes port=MII speed=100Mbit/s
       resources: irq:19 ioport:a000(size=256) memory:e8201400-e82014ff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.
ste@ste-Aspire-1670 ~ $ sudo iwlist scanning
[sudo] password for ste:
wlan0     No scan results

lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

I believe that something has arrived, because when I rebooted, without lan cable, for a second a window has popped out saying that a wireless network is available. Then it disappeared and, again, I don't understand how to activate it.


Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: no wifi connection
« Reply #11 on: May 18, 2014, 02:48:30 pm »
OK, look down by your clock (bottom right of screen.

There will be an icon for your wired connection that looks like 2 cables plugged together (while you have a wired connection) or 2 cables disconnected (when you don't have a wired connection)

Unplug your ethernet cable.

then click that icon.

a list of available networks should pop up

click YOUR network in that list

You will be prompted for your password for "Authentication" .. this wants your Peppermint password

then you'll be prompted for your wireless key .. enter it and click "Connect"

You should now have a wireless connection

if not, plugging the ethernet cable back in will automagically switch you back to a wired connection .. because wired connections take precedence.
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline ste956888

  • nOOb
  • *
  • Posts: 12
  • Karma: 0
  • New Forum User
    • View Profile
Re: no wifi connection
« Reply #12 on: May 18, 2014, 03:17:57 pm »
Yes you are right. I found my network, I was asked the password, then it showed a little circle moving in rounds ... and then it didn't work as if I had written a wrong password. I tried three times. Then I tried with another pc: pwd was correct.

Well, it's enough for today (here it's 9.15 pm), I'll try again tomorrow. I thank you, you've been really kind and got almost the good result. Tomorrow I'll check again disconnecting the router and then starting again.

Thanks

Offline PCNetSpec

  • Administrator
  • Hero
  • *****
  • Posts: 25459
  • Karma: 2800
  • "-rw-rw-rw-" .. The Number Of The Beast
    • View Profile
    • PCNetSpec
  • Peppermint version(s): Peppermint 8R, 9, and 9R
Re: no wifi connection
« Reply #13 on: May 18, 2014, 03:33:03 pm »
I'm going to guess this is either

a) (most likely) the driver doesn't like WPA2 .. you could try setting your router to use WEP as the wireless security method.
or
b) it's having problems with getting an IP address assigned by the routers DHCP server .. give the PC a static IP
or
c) get a USB wireless adapter that's known to work with Linux native drivers (rather than requiring Linux to use th Windows drivers as this one does).

but first, post the output from:
Code: [Select]
sudo iwlist scanning

[EDIT]

Hold on .. was it your Peppermint password that failed, or your wireless key ?

Remember .. the FIRST password it wants will be your Peppermint password .. THEN it'll ask for your wireless key.
« Last Edit: May 18, 2014, 03:40:10 pm by PCNetSpec »
WARNING: You are logged into reality as 'root' .. logging in as 'insane' is the only safe option.

Team Peppermint
PCNetSpec

Offline ste956888

  • nOOb
  • *
  • Posts: 12
  • Karma: 0
  • New Forum User
    • View Profile
Re: no wifi connection
« Reply #14 on: May 25, 2014, 04:26:16 pm »
Hello, sorry but last week I never had the chance to try again. I've just tried ... and this time it has worked.
I wanted to thank you !! You've been very helpful, and patient. Thanks a lot.